Bug 248580 - [RFE]CRM #1359436: Cannot install RHEL 5 on a system with a 3ware 9650se controller
[RFE]CRM #1359436: Cannot install RHEL 5 on a system with a 3ware 9650se cont...
Status: CLOSED DUPLICATE of bug 223465
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Henzl
Martin Jenner
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2007-07-17 12:21 EDT by Issue Tracker
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-02 08:08:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
3ware RHEL5 patch for 9650SE (17.21 KB, patch)
2007-09-17 17:26 EDT, Adam Radford
no flags Details | Diff

  None (edit)
Description Issue Tracker 2007-07-17 12:21:14 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2007-07-17 12:21:19 EDT

The 3w-9xxx Linux kernel module didn't get support for the 3ware 9650se controller until kernel 2.6.19 . There is already a feature request filed for RHEL-4 and it looks like RHEL4.5's kernel may get a backported driver update to add 9650se support[https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=220850], But the 2.6.18-8 kernel [ships with RHEL-5] does not contain a backport support for 9650se. As the 9650se driver disk for RHEL5 is not yet available form the vendor [3ware], The customer wants support for 9650se in RHEL-5 future updates.

This event sent from IssueTracker by tdunnon  [SEG - Feature Request]
 issue 118489
Comment 2 Tom Coughlan 2007-08-13 11:10:01 EDT
Tomas, please consider for 5.2.
Comment 3 Adam Radford 2007-09-17 17:26:37 EDT
Created attachment 197871 [details]
3ware RHEL5 patch for 9650SE

This patch updates the 3w-9xxx driver in RHEL5 to add 
support for the 3ware 9650SE series of controllers.
Comment 4 Tomas Henzl 2007-09-26 07:14:43 EDT
Hi Adam,

thanks for the effort you have done with this patch. I'm sorry
but in the meantime someone else changed the sources in order to add 
support for the 9650SE. 
As we do not have this card, I think that it would be useful if you could 
look into these changes and/or test our latest beta kernel if it works well
with the 9650SE controller.
I'm now sending the appropriate files to you.

Comment 6 Marc Bejarano 2007-11-09 15:00:45 EST
duping a public bug on a private one isn't cool.

tomas: can you make bug 223465 public or undupe, please?
Comment 7 Tomas Henzl 2007-11-12 05:48:55 EST
Sorry it was not intentionally, I'll ask the owner of 223465 to make it public.
Besides that the support for 9650se should be in 2.6.18-24.el5 (also in RHEL 5.1)
You can download this test kernel from http://people.redhat.com/dzickus/el5

Note You need to log in before you can comment on or make changes to this bug.