This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 248596 - Anaconda crashes on Kickstart upgrade
Anaconda crashes on Kickstart upgrade
Status: CLOSED DUPLICATE of bug 241395
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 13:33 EDT by Ed Swierk
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 13:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed Swierk 2007-07-17 13:33:08 EDT
The F7 Anaconda crashes if you feed it a ks.cfg containing "upgrade":

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 949, in <module>
    kickstart.setSteps(anaconda)
  File "/usr/lib/anaconda/kickstart.py", line 1056, in setSteps
    upgrade.setSteps(anaconda)
AttributeError: 'bool' object has no attribute 'setSteps'
install exited abnormally [1/1]

(In setSteps in kickstart.py, the local variable "upgrade" shadows the global
module of the same name.)
Comment 1 Chris Lumens 2007-07-17 13:35:27 EDT

*** This bug has been marked as a duplicate of 241395 ***

Note You need to log in before you can comment on or make changes to this bug.