Bug 248674 - kernel 2.6.22.1-15.fc6 causes fancontrol (lm_sensors) issues
kernel 2.6.22.1-15.fc6 causes fancontrol (lm_sensors) issues
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
6
i386 Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
: Reopened
: 251572 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 00:38 EDT by Dietmar Schnabel
Modified: 2015-03-04 20:18 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.10.4-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 20:27:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dietmar Schnabel 2007-07-18 00:38:34 EDT
Description of problem:

The fancontrol script from lm_sensors does not work with this version of the
kernel because of following problems.

The directory /proc/sys/dev/sensors does not exist anymore in this version of
the kernel.

This might also be solved through a update of lm_sensors.

I did not find a proper position of the same information after the update to the
new kernel. (i found similar information within:  
/sys/devices/platform/w83627hf.656 but then the temp*_input information was
different because the temperature values there are multiplied by 1000. I got it
all working again with slight modifications to the fancontrol script bug I
believe this breaks compatibility and should be solved on kernel level.


Version-Release number of selected component (if applicable):

2.6.22.1-15.fc6 (from updates testing - currently not fully released)

How reproducible:

The problem is easily reproducible because using pwmconfig from lm_sensors does
not work

Steps to Reproduce:
1. start pwmconfig
.
  
Actual results:

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

Expected results:

System should detect pwm-capable sensors.

Additional info:
Comment 1 Jarod Wilson 2007-07-18 09:30:57 EDT
In general, stuff in /proc has been deprecated in favor of stuff in /sys for
some time now. lm_sensors will indeed have to be updated, there is no kernel bug
here, so far as I know.
Comment 2 Hans de Goede 2007-07-18 10:26:45 EDT
Hi,

Short intro: I'm a community co-maintainer of lm_sensors in F-7 and devel, and
also active in upstream lm_sensors development.

Upstream will soon release 2.10.4, which includes a fix for this (might already
be in 2.10.3 too, I don't know which version Fc-6 is at). As soon as 2.10.4 is
released I will built it for F-7 updates-testing and devel. Phil, what do you
think about doing an update to 2.10.4 for FC-6 too?
Comment 3 Chuck Ebbert 2007-07-20 10:59:16 EDT
FC-6 is at version 2.10.1 and it needs to be updated to at least 2.10.3
to get lm_sensors working on the new kernel.
Comment 4 Hans de Goede 2007-07-20 11:15:44 EDT
(In reply to comment #3)
> FC-6 is at version 2.10.1 and it needs to be updated to at least 2.10.3
> to get lm_sensors working on the new kernel.
> 


Ok,

Since FC-6 is from the pre merge era, I can't do this. Phil, I think you could
best take the latest F-7 version and build that for FC-6, then drop it in
updates-testing for FC-6 for a while.
Comment 5 Fedora Update System 2007-07-20 15:30:21 EDT
lm_sensors-2.10.4-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Dietmar Schnabel 2007-07-21 01:45:11 EDT
(In reply to comment #5)
> lm_sensors-2.10.4-1.fc7 has been pushed to the Fedora 7 testing repository. 
If problems still persist, please make note of it in this bug report.

I have tested the FC7 Version on FC6 and it looks like the problem is solved -
please build and release this version for FC6 also!

Thank you for your quick reaction!

Dietmar
Comment 7 Fedora Update System 2007-08-06 13:56:08 EDT
lm_sensors-2.10.4-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Hans de Goede 2007-08-10 07:55:43 EDT
Reopening as this bug is against FC-6 and thus an F-7 update clearly doesn't fix
this (my bad).

Phil, repeating myself:
Since FC-6 is from the pre merge era, I can't do this. Phil, I think you could
best take the latest F-7 version and build that for FC-6, then drop it in
updates-testing for FC-6 for a while.
Comment 9 Hans de Goede 2007-08-10 07:56:58 EDT
*** Bug 251572 has been marked as a duplicate of this bug. ***
Comment 10 Chuck Ebbert 2007-08-14 15:49:07 EDT
Still unfixed, latest lm_sensors for FC6 is still 2.10.1.
Comment 11 Till Maas 2008-01-05 20:27:05 EST
Sorry, this won't be fixed in FC6, because it is now in end of life state and
will not receive any updates. Please use Fedora 7 or 8, where this issue is fixed.

Note You need to log in before you can comment on or make changes to this bug.