Bug 248822 - ADSL does not work in dom0
Summary: ADSL does not work in dom0
Status: CLOSED DUPLICATE of bug 248821
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
high
Target Milestone: ---
Assignee: Rik van Riel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-18 23:45 UTC by Arik Raffael Funke
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 23:46:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arik Raffael Funke 2007-07-18 23:45:05 UTC
Description of problem:
Adsl connection that works flawlessly on a system started with a non-xen kernel 
ceases to work when system is started with xen-kernel as dom0. The system is 
CLEAN and there are NO configuration/environment changes between the two 
situations EXCEPT the choice of the kernel during grub-stage.

Steps to Reproduce:
1. Clean install of Fedora 7 with virtualisation option
2. Start with non-xen kernel and setup adsl (i.e. connect to a adsl modem via a 
network card). This works flawlessly.
3. Restart with xen-kernel into dom0
4. Retry to connect with adsl: impossible


Demonstration:

In non-xen kernel: (adsl works)
===============================
[root@gaia ~]# pppoe -I eth0 -A
Access-Concentrator: ULMC03-10k
Got a cookie: ea 64 c2 d8 c9 f6 70 96 72 27 c2 72 eb 23 fb 1d
AC-Ethernet-Address: 00:19:e8:6e:70:31
--------------------------------------------------
[root@gaia ~]#


In xen-kernel, dom0: (adsl does not work)
=========================================
[root@gaia ~]# pppoe -I eth0 -A
pppoe: Timeout waiting for PADO packets
[root@gaia ~]# 



In /var/messages it says (in dom0 where adsl connection fails):

Jul 17 00:08:21 gaia pppd[3494]: pppd 2.4.4 started by root, uid 0
Jul 17 00:08:21 gaia pppd[3494]: Using interface ppp0
Jul 17 00:08:21 gaia pppd[3494]: Connect: ppp0 <--> /dev/pts/1
Jul 17 00:08:52 gaia pppd[3494]: LCP: timeout sending Config-Requests
Jul 17 00:08:52 gaia pppd[3494]: Connection terminated.
Jul 17 00:08:52 gaia pppd[3494]: Modem hangup
Jul 17 00:08:56 gaia pppoe[3495]: Timeout waiting for PADO packets
Jul 17 00:08:56 gaia pppd[3494]: Exit.
Jul 17 00:08:56 gaia pppoe-connect: PPPoE connection lost; attempting re-
connection.
Jul 17 00:09:01 gaia pppd[3569]: pppd 2.4.4 started by root, uid 0
Jul 17 00:09:01 gaia pppd[3569]: Using interface ppp0
Jul 17 00:09:01 gaia pppd[3569]: Connect: ppp0 <--> /dev/pts/1
Jul 17 00:09:32 gaia pppd[3569]: LCP: timeout sending Config-Requests
Jul 17 00:09:32 gaia pppd[3569]: Connection terminated.
Jul 17 00:09:32 gaia pppd[3569]: Modem hangup
Jul 17 00:09:36 gaia pppoe[3570]: Timeout waiting for PADO packets
Jul 17 00:09:36 gaia pppd[3569]: Exit.

Comment 1 Arik Raffael Funke 2007-07-18 23:46:25 UTC

*** This bug has been marked as a duplicate of 248821 ***


Note You need to log in before you can comment on or make changes to this bug.