Bug 248828 - hgk program is missing from RPM breaking hgext.hgk extension
Summary: hgk program is missing from RPM breaking hgext.hgk extension
Status: CLOSED DUPLICATE of bug 217054
Alias: None
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-19 00:48 UTC by Daniel Berrange
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-11 21:29:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2007-07-19 00:48:23 UTC
Description of problem:
The hgk extension (providing the hg view command) relies on being able to invoke
a standalone script to do some of its work. The extension itself is in the RPM,
but the script is not.

Version-Release number of selected component (if applicable):
mercurial-0.9.3-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Add to $HOME/.hgrc
[extensions]
hgext.hgk=
2. Goto a local HG repository
3. Run 'hg view'
  
Actual results:
sh: hgk: command not found


Expected results:
The HG viewer is displayed

Additional info:
The RPM spec file needs to include the file  contrib/hgk. The extension assume
it is in $PATH, but since its not intended for use directly by a end-user it is
 perhaps putting it in /usr/libexec/hgk and fixing the extenion to run it from
there.

Comment 1 Till Maas 2007-08-11 21:29:38 UTC

*** This bug has been marked as a duplicate of 217054 ***


Note You need to log in before you can comment on or make changes to this bug.