Bug 217054 - Package does not include hgk and other contrib scripts
Package does not include hgk and other contrib scripts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 238828 248828 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 10:06 EST by Steven Yi
Modified: 2008-01-05 12:16 EST (History)
9 users (show)

See Also:
Fixed In Version: mercurial-0.9.4-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 12:16:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Package "contrib" instead of only sample.hgrc (288 bytes, patch)
2007-07-02 12:54 EDT, Gordon Messmer
no flags Details | Diff

  None (edit)
Description Steven Yi 2006-11-23 10:06:04 EST
Description of problem:

The current rpm package does not include the hgk script from mercurial/contrib.

Version-Release number of selected component (if applicable):

0.9.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I think that the hgk script from contrib should either be included with the
mercurial package.  The hgk.py library file from mercurial/hgext is included but
the script to run it is not (from mercurial/contrib).  HGK does not run
otherwise without the script.
Comment 1 Pavel Roskin 2007-03-14 19:00:31 EDT
I'm observing the same issue in 0.9.3-1.fc7 in Fedora development.  Considering
that gitk is packaged separately from git, I think it would be logical to do the
same for hgk.
Comment 2 Satish Balay 2007-05-27 00:59:11 EDT
Just a note that debian/ubuntu packages it as part of mercurial. But either way
I'd like to see this feature in fedora packages.

-----------------------------------------------
[octagon:~] > cat /etc/issue
Ubuntu 7.04
[octagon:~] > dpkg -L mercurial | grep hgk
/usr/share/mercurial/hgk
/usr/share/python-support/mercurial/hgext/hgk.py
[octagon:~] > 
-----------------------------------------------
Comment 3 Gordon Messmer 2007-07-02 12:53:25 EDT
Would it be sufficient to just package the entire "contrib" directory?
Comment 4 Gordon Messmer 2007-07-02 12:54:30 EDT
Created attachment 158348 [details]
Package "contrib" instead of only sample.hgrc
Comment 5 Till Maas 2007-08-11 17:29:43 EDT
*** Bug 248828 has been marked as a duplicate of this bug. ***
Comment 6 Till Maas 2007-08-11 17:35:36 EDT
*** Bug 238828 has been marked as a duplicate of this bug. ***
Comment 7 Till Maas 2007-08-11 17:44:36 EDT
I added the co-maintainers to CC, maybe one of them has the time to process this
request.
Comment 8 Till Maas 2008-01-05 12:16:13 EST
In Fedora 7 contrib stuff is now available in /usr/share/mercurial/contrib/

Note You need to log in before you can comment on or make changes to this bug.