Bug 248884 - Removing i386 evolution in a x86_64 system removes translations.
Removing i386 evolution in a x86_64 system removes translations.
Status: CLOSED DUPLICATE of bug 247749
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 09:14 EDT by Gustavo Maciel Dias Vieira
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 01:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustavo Maciel Dias Vieira 2007-07-19 09:14:41 EDT
Description of problem:

I have a x86_64 system. I noticed that Evolution and some related Gnome packages
had both i386 and x86_64 versions installed. To save time when downloading
updates I decided to remove the i386 packages. After the removal, the translated
messages in evolution disappeared. 

Version-Release number of selected component (if applicable):
evolution-2.10.3-1.fc7.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. Install both i386 and x86_64 evolution packages
2. Remove i386
3.
  
Actual results:
'rpm -V evolution' shows /usr/share/locale/* and /usr/share/doc/evolution* as
missing

Expected results:
! Actual results

Additional info:

I don't know if I should file this under evolution. Removing this package I
noticed the bug, but the following packages were affected (lost translations or
other common files):
evolution
evolution-data-server
gnome-panel
gnome-utils
gnome-pilot
control-center
gnome-applets
compiz

Workarounds: 

1) Don't remove i386 packages. :)

2) Download a copy of the affected x86_64 packages and 'rpm -Uvh --force *rpm'.
Comment 1 Matthew Barnes 2007-07-19 09:37:33 EDT
Just curious, how did you wind up with both 32-bit and 64-bit versions of these
packages installed?
Comment 2 Gustavo Maciel Dias Vieira 2007-07-19 09:59:20 EDT
I have no idea. Just did a very standard F7 installation. You know, I was asking
this very same question just before I removed the packages. My last theory was
that they were standard because of binary only Evolution plugins...

Unfortunately, I only have one x86_64 machine, so I can't check if this is a
situation somehow special of this installation.
Comment 3 Matthew Barnes 2007-07-19 10:29:33 EDT
A colleague suggested the i386 and x84_64 versions may have been different, such
as evolution-2.10.2-2.fc7.i386 and evolution-2.10.3-1.fc7.x86_64.

I don't think there's anything I can do about this.  Fedora is not designed to
have the same application installed twice for different architectures.  We
support that for libraries, but not applications.

It sounds like your system was just in a weird configuration.  I suggest
applying the workaround you mentioned to any other applications that got
installed twice.
Comment 4 Gustavo Maciel Dias Vieira 2007-07-19 10:46:50 EDT
I checked the installation log for my system, some findings:

Both i386 and x86_64 versions were the same, since installation, through all
updates, up to the point I removed them.

My anaconda-ks.cfg shows that I have not explicitly asked for the i386 versions
to be installed. The install log shows they were.

There is one exception to your rule that applications are not designed for
multiple archs: Firefox. Both Firefox i386 and x86_64 are installed by default
and I actually use both (i386 only for Java plugin).

Anyway, thanks for checking this problem. It's clear now this isn't a Evolution
problem. But, I still like to pursue it further. Should I file it under
anaconda? Do you recommend another module?
Comment 5 Matthew Barnes 2007-07-19 11:25:46 EDT
I'd start with anaconda.  I can't think of anything else that might be at fault.
Comment 6 Gustavo Maciel Dias Vieira 2007-07-19 11:57:41 EDT
For the record: I created bug 248911.
Comment 7 Jeremy Katz 2007-07-25 16:40:42 EDT
This is entirely normal; the translations shouldn't be getting removed, though
Comment 8 Panu Matilainen 2007-08-13 01:54:11 EDT

*** This bug has been marked as a duplicate of 247749 ***

Note You need to log in before you can comment on or make changes to this bug.