Bug 248911 - Anaconda installs i386 Evolution and GNOME in x86_64 systems.
Anaconda installs i386 Evolution and GNOME in x86_64 systems.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 11:56 EDT by Gustavo Maciel Dias Vieira
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 16:40:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gustavo Maciel Dias Vieira 2007-07-19 11:56:19 EDT
Description of problem:

A default installation of F7 in a x86_64 machine installs Evolution and some
other GNOME applications in both i386 and x86_64 architectures.

At first I assumed this was normal behavior, similar to what happens to Firefox.
However, since I don't use them, I decided to remove the i386 packages and run
into bug #248884. In the resolution of bug #248884, Matthew Barnes informed me
that "Fedora is not designed to have the same application installed twice for
different architectures."

Then, Anaconda (or Yum) has a bug where applications (in this case Evolution and
some other GNOME apps) are wrongly installed twice, inducing the situation where
a package removal can also remove some vital components like translations.


Version-Release number of selected component (if applicable):
F7 installer as released.


How reproducible:
Deterministic

Steps to Reproduce:
1. Install F7, select GNOME.
2.
3.
Comment 1 Jeremy Katz 2007-07-25 16:40:19 EDT
anaconda is doing entirely the right thing here.  We install both arches. 
mbarnes is just confused.  bug 248884 is a bug in rpm as it shouldn't remove the
shared files on removing one arch.  Reopening and reassigning it accordingly.

Note You need to log in before you can comment on or make changes to this bug.