Bug 248996 - Review Request: libopensync-plugin-synce - Synce plugin for libopensync
Summary: Review Request: libopensync-plugin-synce - Synce plugin for libopensync
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 244917
TreeView+ depends on / blocked
 
Reported: 2007-07-20 07:44 UTC by Andreas Bierfert
Modified: 2009-08-31 21:30 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-08-16 05:57:49 UTC
panemade: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description Andreas Bierfert 2007-07-20 07:44:47 UTC
Spec URL: http://fedora.lowlatency.de/review/libopensync-plugin-synce.spec
SRPM URL: http://fedora.lowlatency.de/review/libopensync-plugin-synce-0.22-2.src.rpm
Description:
Synce plugin for libopensync

Comment 1 Parag AN(पराग) 2007-07-20 09:42:58 UTC
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPMs.
+ source files match upstream.
f325b7dd9f273c46e77fb7b337325880  libopensync-plugin-synce-0.22.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
- dist tag is NOT present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is small so no need of -doc subpackage.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no static libraries.
+ no .pc files are present.
+ no -devel subpackage exists.
+ no .la files.
+ no translations available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ shared libraries scriptlet used.
+ Provides: synce_plugin.so
+ Requires(interp): /sbin/ldconfig /sbin/ldconfig
+ Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) libglib-2.0.so.0 libopensync.so.0
librapi.so.2 librra.so.0 libsynce.so.0 libxml2.so.2 rtld(GNU_HASH)
+Not a GUI App.
APPROVED.


Comment 2 Andreas Bierfert 2007-07-20 09:48:39 UTC
New Package CVS Request
=======================
Package Name: libopensync-plugin-synce
Short Description: Synce plugin for libopensync
Owners: andreas.bierfert@lowlatency.de
Branches: FC-6 F-7

Comment 3 Kevin Kofler 2007-07-20 11:50:59 UTC
The changelog says:
- add obsoletes as discussed in #244917
but it looks like you forgot the actual Obsoletes.

Comment 4 Andreas Bierfert 2007-07-20 11:57:22 UTC
Ups... now that you say that +) I will add them after import. Thanks for
pointing it out.

Comment 5 Parag AN(पराग) 2007-08-16 05:55:40 UTC
any progress? Can this be closed now?

Comment 6 Kevin Kofler 2007-08-16 05:57:49 UTC
It has been pushed already.

Comment 7 Andreas Bierfert 2009-08-30 21:39:31 UTC
Package Change Request
======================
Package Name: libopensync-plugin-synce
New Branches: F-10
Owners: awjb

Comment 8 Jason Tibbitts 2009-08-31 18:28:20 UTC
CVS done (although I'm confused as to how this ended up with F-9 and F-11 branches but no F-10 branch).

Comment 9 Kevin Kofler 2009-08-31 21:30:08 UTC
Because F10 shipped with the libopensync 0.3x development version. There are plans to revert everything to 0.22 because the 0.3x versions are just broken.


Note You need to log in before you can comment on or make changes to this bug.