Bug 249044 - Please change initscript start level
Please change initscript start level
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
: 267281 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 10:57 EDT by Tim Waugh
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-06 16:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-07-20 10:57:17 EDT
Description of problem:
CUPS now needs to after avahi, but still needs to be before haldaemon. 
Unfortunately both avahi and haldaemon start at level 98. :-)

For the moment I've set cups to start at level 98 as well, and this should work
just because it is alphabetically where it needs to be, but it would be nicer if
there was a numeric space for it.

Version-Release number of selected component (if applicable):
avahi-0.6.20-5.fc8
Comment 1 Lennart Poettering 2007-07-24 17:27:26 EDT
I changed this in the init scripts shipped upstream now (r1501). I will shortly
prepare an updated package for fedora.
Comment 2 Lennart Poettering 2007-07-24 19:48:37 EDT
Tim, could you elaborate a little why cups needs to be started before hal? I
told the Debian people about this bug and they're now eager to learn why this
order has to assured?

Thanks!
Comment 3 Tim Waugh 2007-07-30 05:28:51 EDT
Sure.  The reason is that once hal has started, HAL callouts for connected
printers will be called.  This causes the hal-cups-utils package to start adding
printers to CUPS (if not already present).  The hal_lpadmin program in
hal-cups-utils requires cupsd to be running at that point.
Comment 4 Lennart Poettering 2007-08-12 13:03:41 EDT
Fixed in Rawhide.
Comment 5 Tim Waugh 2007-09-03 13:13:30 EDT
Now the start level is 97; but it still doesn't give me enough room to put CUPS
in between avahi-daemon and haldaemon without relying on alphabetic ordering.

Please make it at most 96, so that I can put CUPS at 97 (between avahi-daemon
and haldaemon which is at 98).

Thanks.
Comment 6 Lennart Poettering 2007-09-06 12:26:47 EDT
*** Bug 267281 has been marked as a duplicate of this bug. ***
Comment 7 Lennart Poettering 2007-09-06 16:08:49 EDT
Fixed in 0.6.21-5 which i just committed to rawhide.

Note You need to log in before you can comment on or make changes to this bug.