Bug 249094 - virt-manager starts domU install even though error with duplicate name exists
virt-manager starts domU install even though error with duplicate name exists
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Hugh Brock
:
: 251489 (view as bug list)
Depends On:
Blocks: 223107
  Show dependency treegraph
 
Reported: 2007-07-20 17:06 EDT by Chuck Morrison
Modified: 2010-10-22 12:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHEA-2007-0637
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:34:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Aggressively free domain pointer in libvirt (1.71 KB, patch)
2007-07-24 15:45 EDT, Hugh Brock
no flags Details | Diff

  None (edit)
Description Chuck Morrison 2007-07-20 17:06:47 EDT
Description of problem:

In making and deleting a lot of domU instances, I've occasionally used a name
more than once. Even if it was previously deleted, virt-manager always gives an
error about the name being used before. It then proceeds to start the install
even though I go back and change the name. This is confusing to say the least.

Version-Release number of selected component (if applicable):


How reproducible:

happens every time

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Hugh Brock 2007-07-23 17:10:09 EDT
Hmm, good catch, thanks. This turns out to be a nasty python reference-counting
bug (we think). Working on a fix now.
Comment 3 Hugh Brock 2007-07-24 15:42:23 EDT
The patch below fixes the problem by forcing libvirt to release the underlying
pointer to the domain object, even though the python code doesn't always release
the reference reliably.
Comment 4 Hugh Brock 2007-07-24 15:45:01 EDT
Created attachment 159881 [details]
Aggressively free domain pointer in libvirt

This patch aggressively frees the domain pointer in libvirt so that when you
create a domain with the same name as one you just deleted, the deleted domain
configuration doesn't get resurrected in virt-manager.
Comment 7 Daniel Berrange 2007-08-09 08:58:31 EDT
*** Bug 251489 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Berrange 2007-08-09 09:09:03 EDT
For reference, this bug is addressed in virt-manager-0.4.0-3.el5

* Tue Jul 24 2007 Hugh O. Brock <hbrock@redhat.com> - 0.4.0-3.el5
- Aggressively free libvirt domain object after it has been deleted. Workaround
  for python's unreliable garbage collection. (rhbz #249094)
Comment 11 errata-xmlrpc 2007-11-07 11:34:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0637.html

Note You need to log in before you can comment on or make changes to this bug.