Bug 249131 - [Regression] iwl3945 module no longer loads
[Regression] iwl3945 module no longer loads
Status: CLOSED DUPLICATE of bug 248997
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 02:35 EDT by Stefan Becker
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 06:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2007-07-21 02:35:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
The iwl3945 module no longer loads with the latest F7 kernel due to firmware loading error:

Jul 21 09:07:55 l3f1199 kernel: iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Networ
k Connection driver for Linux, 0.0.36kd
Jul 21 09:07:55 l3f1199 kernel: iwl3945: Copyright(c) 2003-2007 Intel Corporatio
n
Jul 21 09:07:55 l3f1199 kernel: ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (l
evel, low) -> IRQ 21
Jul 21 09:07:55 l3f1199 kernel: iwl3945: Detected Intel PRO/Wireless 3945ABG Net
work Connection
Jul 21 09:07:55 l3f1199 kernel: iwl3945: Could not read microcode: -22
Jul 21 09:07:55 l3f1199 kernel: ACPI: PCI interrupt for device 0000:03:00.0 disa
bled
Jul 21 09:07:55 l3f1199 kernel: iwl3945: probe of 0000:03:00.0 failed with error
 -22


Version-Release number of selected component (if applicable):
kernel-2.6.22.1-27.fc7

How reproducible:
Always


Steps to Reproduce:
1. modprobe iwl3945
2.
3.

Actual Results:
module is not loaded

Expected Results:
module is loaded and wireless interface shows up.

Additional info:
Relevant version information:

kernel-2.6.22.1-27.fc7
iwlwifi-firmware-2.14.3-2
udev-106-4.1.fc7

# ll /lib/firmware/iwlwifi-3945.ucode
-rw-r--r-- 1 root root 148476 2007-04-20 18:05 /lib/firmware/iwlwifi-3945.ucode

# modinfo iwl3945
filename:     /lib/modules/2.6.22.1-27.fc7/kernel/drivers/net/wireless/mac80211/iwlwifi/iwl3945.ko
...
version:        0.0.36kd
...
vermagic:       2.6.22.1-27.fc7 SMP mod_unload 686 4KSTACKS
Comment 1 Stefan Becker 2007-07-21 06:57:27 EDT
Already reported. Unfortunately iwlwifi-firmware-2.14.4-1 hasn't been pushed to
updates yet. Will retry with package from updates-testing...

*** This bug has been marked as a duplicate of 248997 ***

Note You need to log in before you can comment on or make changes to this bug.