Bug 248997 - iwl3945 does not work with testing kernel-2.6.22.1-27.fc7
iwl3945 does not work with testing kernel-2.6.22.1-27.fc7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 249123 249131 249170 249331 249386 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 04:31 EDT by Reindl Harald
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.6.22.1-27.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 09:57:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2007-07-20 04:31:10 EDT
Jul 20 09:52:53 notebook-rhsoft kernel: iwl3945: Detected Intel PRO/Wireless
3945ABG Network Connection
Jul 20 09:52:53 notebook-rhsoft kernel: iwl3945: Unhandled INTA bits 0x04000000
Jul 20 09:52:53 notebook-rhsoft kernel: iwl3945: Disabled INTA bits 0x04000000
were pending
Jul 20 09:52:53 notebook-rhsoft kernel: iwl3945:    with FH_INT = 0x00000000
Jul 20 09:52:53 notebook-rhsoft kernel: iwl3945: Could not read microcode: -22
Jul 20 09:52:53 notebook-rhsoft kernel: iwl3945: probe of 0000:06:00.0 failed
with error -22

BTW:
With this kernel unter kde i could not change volume-level
Have now running the kernel-2.6.21-1.3228.fc7 again on my hp-pavilion
Comment 1 Reindl Harald 2007-07-20 06:38:34 EDT
Problem seems to be "iwlwifi-firmware.noarch 2.14.3-2"
With iwlwifi-firmware.noarch 2.14.4-1 from testing it works with 2.6.22, but
this firmware kills iwl3945 unter 2.6.21

iwl3945 is generally strange, if it connects while booting - all works perfect,
if you lost your connection a rmmod/modprobe and restart auf wpa_supplicant in
many cases will not bring back connection :-(
Comment 2 John W. Linville 2007-07-20 09:57:41 EDT
Yes, the firmware update is required for the later version of the driver.  It 
will be pushed at the same time as the updated kernel.

There are many open issues regarding iwl3945.  Perhaps the 'lost connection' 
problem you report matches one of those?  If not, feel free to open a new bug 
to cover that.
Comment 3 Stefan Becker 2007-07-21 06:57:29 EDT
*** Bug 249131 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Becker 2007-07-21 06:59:07 EDT
*** Bug 249123 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Saou 2007-07-23 05:23:28 EDT
I see that kernel-2.6.22.1-27.fc7 has been pushed to stable, but the firmware
hadn't been :-(
I've just asked to have that done through bodhi now.
Comment 6 Reindl Harald 2007-07-23 06:37:20 EDT
Mhh and it makes me angry
Does the last time no one think before publishing kernels
the last 2.6.21 with dependecies on new mkinitrd was published while mkinitrd
was hanging in "updates-testing"

This should not happen often because normal users have big troubles with such
actions!
Comment 7 Jarod Wilson 2007-07-23 10:37:28 EDT
*** Bug 249170 has been marked as a duplicate of this bug. ***
Comment 8 Matthias Saou 2007-07-24 04:30:56 EDT
*** Bug 249331 has been marked as a duplicate of this bug. ***
Comment 9 John W. Linville 2007-07-24 08:41:07 EDT
*** Bug 249386 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.