Bug 249132 - kernels 2.6.22.1-27.fc7 and pilot-link with libusb support
kernels 2.6.22.1-27.fc7 and pilot-link with libusb support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 02:44 EDT by Serguei Miridonov
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.22.1-33
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 20:52:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fragments from /var/log/message after 'udevcontrol log_priority="debug"' (13.45 KB, text/plain)
2007-07-21 02:44 EDT, Serguei Miridonov
no flags Details
dmesg output and /var/log/messages fragments (93.35 KB, text/plain)
2007-07-23 01:45 EDT, Serguei Miridonov
no flags Details

  None (edit)
Description Serguei Miridonov 2007-07-21 02:44:35 EDT
Description of problem:
kernels 2.6.22.1-20.fc7 and 2.6.22.1-27.fc7 make pilot-link with libusb support
non-functional

Version-Release number of selected component (if applicable):

kernel 2.6.22.1-27.fc7
pilot-link-0.12.1 built with libusb support
udev-106-4.1.fc7

How reproducible:

The same pilot-xfer binary and udev package works with kernel-2.6.21-1.3228.fc7

Steps to Reproduce:
1. Build pilot-link-0.12.1 with libusb support (use './configure --with-python
--enable-libusb --enable-conduits --prefix=/opt/pilot-link/' to install it
separately from F7 pilot-link package)
2. Connect your PalmOS USB device, press Syncronize button
3. Try '/opt/pilot-link/bin/pilot-xfer -l -p usb:' with
kernel-2.6.21-1.3228.fc7, you will get file list in your PDA.
4. Boot 2.6.22.1-27.fc7 and repeat step #3. Nothing happens.

  
Actual results: No connection with PDA


Expected results: Information exchange with PDA


Additional info:

Two files attached. These are fragments from /var/log/message after 'udevcontrol
log_priority="debug"'. One is for working case, another is not working.
Comment 1 Serguei Miridonov 2007-07-21 02:44:35 EDT
Created attachment 159715 [details]
fragments from /var/log/message after 'udevcontrol log_priority="debug"'
Comment 2 Serguei Miridonov 2007-07-21 02:48:21 EDT
Sorry I forget to mention that to test this case, you need to blacklist visor
module (please, read pilot-link-0.12.1/doc/README.libusb file for more info)
Comment 3 Robin Gape 2007-07-22 19:52:39 EDT
Colleagues,

to avoid opening another bug, this bug also applies to F-Spot and digiKam (and
possibly other applications) in regard to being able to communicate with USB
cameras in PTP mode. With kernel 2.6.21.1-3228 such communication simply works,
and with kernel 2.6.22.1-27 it does not. It is _very_ annoying, and is somehow
associated with the 2.6.22 kernel. Is there any information I might provide
which would assist in its resolution? Or are there any tests which might help
(it feels like a permissions issue, but one isn't sure where to start poking first!)

Otherwise, I would suggest that the severity should be high, since it probably
affects any USB connected peripheral.
Comment 4 Serguei Miridonov 2007-07-23 01:45:29 EDT
Created attachment 159761 [details]
dmesg output and /var/log/messages fragments
Comment 5 Serguei Miridonov 2007-07-23 01:46:55 EDT
It seems that some USB stuff is broken in 2.6.22.1-27. I don't know if it is 
related or not but with this kernel Nokia E65 cell phone is not mounted 
anymore 
when connected with USB data cable in "Data transfer" mode. In FC5 and in F7 
with 2.6.21.1-3228 it mounts without a problem. Above are dmesg outputs and /
var/log/messages files related to working and nonworking kernels. udevcontrol 
log_priority="debug" was set for more information.
Comment 6 Chuck Ebbert 2007-07-23 12:20:38 EDT

*** This bug has been marked as a duplicate of 249272 ***
Comment 7 Serguei Miridonov 2007-07-23 12:37:35 EDT
Sorry, I do not agree that this bug has been marked as a duplicate of 249272. 
On my computer USB flash drives and CD/DVD drive attached to USB works without 
a problem. So, this is a separate bug. If you still think that this is a 
duplicate, please, provide some explanations.

Also, please note, this bug was filed earlier, so why THIS bug is duplicate?
Comment 8 Robin Gape 2007-07-24 16:20:18 EDT
(In reply to comment #6)
> 
> *** This bug has been marked as a duplicate of 249272 ***
Chuck,

I agree with Sergui, this bug is concerned with USB communication to an
intelligent peripheral. There is no problem with a USB mass storage device.

Robin
Comment 9 Serguei Miridonov 2007-07-24 17:13:53 EDT
Gentlemen, anybody working on that? Any progress? Is there a discussion 
somewhere regarding this kernel problem?
Comment 10 Chuck Ebbert 2007-07-24 18:00:10 EDT
Should be all fixed in 2.6.22.1-33, sent to updates-testing this morning
but not pushed out to the repo yet.
Comment 11 Serguei Miridonov 2007-07-24 19:03:48 EDT
Thank you. When will it be available for download? Is there a changelog?
Comment 12 Jarod Wilson 2007-07-24 21:04:56 EDT
You can get an advance copy directly out of the build system here:

http://koji.fedoraproject.org/packages/kernel/2.6.22.1/33.fc7/

Changelog is in the package itself, or in cvs.
Comment 13 Serguei Miridonov 2007-07-24 23:18:26 EDT
Thank you again. I have installed it and tested. pilot-link with libusb support 
seems working perfectly. However there is still an issue with connection Nokia 
E65 phone over USB. I confirm that it connects and mounts automatically with 
2.6.21.1-3228 kernel but fails with any available 2.6.22.1. Is that another bug 
#249272? Any idea? Any other mass storage devices (USB memory, ATA drives 
connected with ATA-USB adapter) are mounted automatically. MicroSD from the 
mentioned above Nokia E65 connected through USB card reader works as well. Only 
when inserted in the phone and the phone connected over USB data cable in "Data 
transfer" mode it can not mount automatically.

If this is a different bug, I would close this particular one but I think we 
should wait Robin Gape to test this kernel with PTP camera.
Comment 14 Robin Gape 2007-07-25 20:46:22 EDT
I have installed the 2.6.22.1-33 kernel. USB PTP camera functionality is
restored, as far as I can tell. The three test cameras are all recognised, and
pictures (images) can be downloaded and deleted. From my viewpoint the bug may
be closed.

Thanks to Sergui, Chuck and Jarod and whomsoever fixed the kernel bug.
Comment 15 Serguei Miridonov 2007-07-25 20:52:41 EDT
Thank you Robin. I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.