Bug 249272 - Can't mount VFAT!!!!
Can't mount VFAT!!!!
Status: CLOSED DUPLICATE of bug 249282
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-23 10:07 EDT by The Source
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 11:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fragments from /var/log/messages (2.73 KB, text/plain)
2007-07-23 13:27 EDT, Serguei Miridonov
no flags Details

  None (edit)
Description The Source 2007-07-23 10:07:26 EDT
Description of problem:
Latest kernel does not recognize vfat! My flash drive is vfat but mount command
says it is not. Happens on both my home PC (compiled kernel myself) and work PC
(standard package). Testes on many flash drives. Same problem.

Version-Release number of selected component (if applicable):
2.6.22.1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2007-07-23 12:20:41 EDT
*** Bug 249132 has been marked as a duplicate of this bug. ***
Comment 2 Serguei Miridonov 2007-07-23 13:27:40 EDT
Created attachment 159797 [details]
fragments from /var/log/messages

First of all, see my note in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249132

Now, some update. USB drive with vfat FS and ATA CD/DVD with ISO FS connected
with ATA/USB adapter can be mounted automatically. However, ATA drive with vfat
FS connected with ATA/USB adapter is not mounted automatically but can be
mounted manually. See attachment with fragments from /var/log/messages
Comment 3 The Source 2007-07-23 23:32:46 EDT
I repeat: I can't mount vfat manually. mount command says that fs type is wrong.
fs autodetection does not work either.
Comment 4 Serguei Miridonov 2007-07-23 23:58:13 EDT
I also run 2.6.22.1 kernel (stock 2.6.22.1-27.fc7) and as follows from my 
messages, I see completely different behavior. Just a simple test, could you 
please try these commands as root:

modprobe vfat ; cat /proc/filesystems

What do you have in the output?
Comment 5 The Source 2007-07-24 00:40:13 EDT
You know what? I ran cat /proc/filesystems before and after modprobe vfat.
Before there was no vfat and after it was present. So why vfat module does not
start automatically?
Comment 6 The Source 2007-07-24 00:42:34 EDT
But that didn't help. Though vfat is present in /proc/filesystems I can't mount
it anyway.
Comment 7 The Source 2007-07-24 00:43:33 EDT
Here's dmesg | tail

sd 8:0:0:0: [sdb] Mode Sense: 00 00 00 00
sd 8:0:0:0: [sdb] Assuming drive cache: write through
 sdb: sdb1
sd 8:0:0:0: [sdb] Attached SCSI removable disk
sd 8:0:0:0: Attached scsi generic sg3 type 0
hfs: unable to find HFS+ superblock
FAT: invalid media value (0x01)
VFS: Can't find a valid FAT filesystem on dev sdb.
FAT: invalid media value (0x01)
VFS: Can't find a valid FAT filesystem on dev sdb
Comment 8 Serguei Miridonov 2007-07-24 00:50:39 EDT
(In reply to comment #5)
> You know what? I ran cat /proc/filesystems before and after modprobe vfat.
> Before there was no vfat and after it was present. So why vfat module does not
> start automatically?

This is normal. vfat as many other modules is loaded automatically on demand. 
When not in use for some time, modules are unloaded to free memory.

My question was just to check if vfat is enabled in kernel configuration. Since 
vfat module present, this part seems OK.

Regarding your dmesg output, I think we need to wait what kernel maintainers 
say...
Comment 9 Serguei Miridonov 2007-07-24 00:54:27 EDT
Could you please try this command:

sfdisk -l /dev/sdb

(Don't try other options in sfdisk!!!)

And what did you try to mount manually? /dev/sdb or /dev/sdb1?
Comment 10 The Source 2007-07-24 01:01:04 EDT
Oh, shoooooot!!! I didn't notice that sdb1 was present (hmmm.. I don't remember
flash drives had /dev/sdxn format. But perhaps that was changed in latest
kernel). sdb1 mounts normally. But wny automatic mount does not work?
Comment 11 Serguei Miridonov 2007-07-24 01:15:26 EDT
This is not a kernel, this is just common USB drives layout. They all have 
partition table just like hard drives. Regarding automatic mount, I think this 
is the problem with some USB stuff in kernel. Something works, something 
doesn't.

I'm really surprised by status of Fedora 7 really... There is no well working 
kernel yet: 2.6.21 suffers from bug in libata module which strikes the disk 
head every shutdown, in 2.6.22 this bug was fixed but usb stuff seems heavily 
broken. If I knew that I would expect more stable Fedora update before 
upgrading from FC5. Let's see what kernel maintainers say but I'm afraid I will 
do next Fedora major upgrade in 5-6 months after F9 release to settle things 
down.
Comment 12 Serguei Miridonov 2007-07-24 23:28:02 EDT
The Source, there will be a new kernel 2.6.22.1-33.fc7 in testing soon. You 
also can get it here right now: http://koji.fedoraproject.org/packages/kernel/
2.6.22.1/33.fc7/i686/kernel-2.6.22.1-33.fc7.i686.rpm (make sure you will paste 
entire link as it very long and can brake here in bugzilla page). With this new 
kernel some problem is solved, some not (see https://bugzilla.redhat.com/
bugzilla/show_bug.cgi?id=249132 for more info). You may try it to check if your 
mount vfat bug is fixed.
Comment 13 Serguei Miridonov 2007-07-24 23:33:45 EDT
Hmm, sorry for testing... Does bugzilla allow html in the message? This is a 
link to the <a href=http://koji.fedoraproject.org/packages/kernel/
2.6.22.1/33.fc7/i686/kernel-2.6.22.1-33.fc7.i686.rpm>new kernel</a>
Comment 14 Serguei Miridonov 2007-07-24 23:34:17 EDT
Nope...
Comment 15 Serguei Miridonov 2007-07-24 23:59:33 EDT
Some update regarding automatic mounting problem... I tested 2.6.22.1-33.fc7 
kernel and unfortunately it does not mount Nokia E65 phone automatically (see 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249132#c5). It mounts USB 
flash memory. ATA hard drive connected over ATA-USB adapter: it is mounted 
automatically when the drive is connected first time. If I then unmount it 
choosing "Safely remove" in the KDE drive icon, remove the USB cable, then 
connect it again, the kernel recognizes the drive and partition but it is not 
automatically mounted. If I disconnect the USB cable, remove the power from the 
drive, then power-on it again and connect USB cable, it is again mounted 
automatically. Any idea?
Comment 16 Serguei Miridonov 2007-07-26 11:19:54 EDT
It seems there is a solution for this problem in a discussion regarding bug 
#249161: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249161

Duplicate bug?
Comment 17 David Zeuthen 2007-07-27 11:27:28 EDT
I'm 99% this is a dupe of bug 249282 so closing as such.

*** This bug has been marked as a duplicate of 249282 ***

Note You need to log in before you can comment on or make changes to this bug.