Bug 249156 - Unable to connect with ipw4965 device
Unable to connect with ipw4965 device
Status: CLOSED DUPLICATE of bug 373841
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 12:40 EDT by Thomas M Steenholdt
Modified: 2008-01-10 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 18:39:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (should at least be reviewed) (1.43 KB, patch)
2007-08-06 22:36 EDT, Thomas M Steenholdt
no flags Details | Diff

  None (edit)
Description Thomas M Steenholdt 2007-07-21 12:40:43 EDT
Description of problem:
Running F7 on i686, all updates errata applied as well as test-kernels
(currently 2.6.22.1-29.fc7) and with 4.44.15 firmware
(iwlwifi-4965-ucode-4.44.15-4 from atrpms) I'm unable to connect to WPA2
personal hidden network. Just getting the list of non-hidden networks takes
time, but they all show up eventually. But entering info for my hidden WPA2
network fails on me every time.

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-7.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Connect to WPA2 hidden network (possibly other kinds of networks too)
2.
3.
  
Actual results:
No dice!

Expected results:
Success!

Additional info:
Tried hidden WPA too, same problem.

This is an exempt from the log:
Jul 21 14:39:05 localhost NetworkManager: <info>  User Switch:
/org/freedesktop/NetworkManager/Devices/wlan0 / tmus_wrt 
Jul 21 14:39:05 localhost NetworkManager: <info>  Deactivating device wlan0. 
Jul 21 14:39:05 localhost dhcdbd: message_handler: message handler not found
under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.reason
Jul 21 14:39:05 localhost NetworkManager: <info>  Device wlan0 activation
scheduled... 
Jul 21 14:39:05 localhost NetworkManager: <info>  Deactivating device eth0. 
Jul 21 14:39:05 localhost dhclient: wmaster0: unknown hardware address type 801
Jul 21 14:39:05 localhost dhclient: wmaster0: unknown hardware address type 801
Jul 21 14:39:05 localhost dhclient: DHCPRELEASE on eth0 to 192.168.1.1 port 67
Jul 21 14:39:06 localhost avahi-daemon[2680]: Withdrawing address record for
192.168.1.102 on eth0.
Jul 21 14:39:06 localhost avahi-daemon[2680]: Leaving mDNS multicast group on
interface eth0.IPv4 with address 192.168.1.102.
Jul 21 14:39:06 localhost avahi-daemon[2680]: Interface eth0.IPv4 no longer
relevant for mDNS.
Jul 21 14:39:06 localhost avahi-daemon[2680]: Withdrawing address record for
fe80::218:8bff:fedb:2efe on eth0.
Jul 21 14:39:06 localhost avahi-daemon[2680]: Leaving mDNS multicast group on
interface eth0.IPv6 with address fe80::218:8bff:fedb:2efe.
Jul 21 14:39:06 localhost avahi-daemon[2680]: Interface eth0.IPv6 no longer
relevant for mDNS.
Jul 21 14:39:06 localhost NetworkManager: <info>  Activation (wlan0) started... 
Jul 21 14:39:06 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of
5 (Device Prepare) scheduled... 
Jul 21 14:39:06 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of
5 (Device Prepare) started... 
Jul 21 14:39:06 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of
5 (Device Configure) scheduled... 
Jul 21 14:39:06 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of
5 (Device Prepare) complete. 
Jul 21 14:39:06 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of
5 (Device Configure) starting... 
Jul 21 14:39:06 localhost NetworkManager: <info>  Activation (wlan0/wireless):
access point 'tmus_wrt' is encrypted, and a key exists.  No new key needed. 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'INTERFACE_ADD wlan0             wext    /var/run/wpa_supplicant ' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command 'AP_SCAN 2' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'ADD_NETWORK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was '0' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 ssid 746d75735f777274' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 scan_ssid 1' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 proto WPA2' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 key_mgmt WPA-PSK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 psk <key>' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 pairwise TKIP' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 group TKIP' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: sending command
'ENABLE_NETWORK 0' 
Jul 21 14:39:07 localhost NetworkManager: <info>  SUP: response was 'OK' 
Jul 21 14:39:07 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of
5 (Device Configure) complete. 
Jul 21 14:39:10 localhost NetworkManager: <info>  Error getting killswitch
power: org.freedesktop.Hal.Device.KillSwitch.NotSupported - Access type not
supported 
Jul 21 14:39:46 localhost last message repeated 6 times
Jul 21 14:39:47 localhost NetworkManager: <info>  Activation (wlan0/wireless):
association took too long (>40s), failing activation. 
Jul 21 14:39:47 localhost NetworkManager: <info>  Activation (wlan0) failure
scheduled... 
Jul 21 14:39:47 localhost NetworkManager: <info>  Activation (wlan0) failed for
access point (tmus_wrt) 
Jul 21 14:39:47 localhost NetworkManager: <info>  Activation (wlan0) failed. 
Jul 21 14:39:47 localhost NetworkManager: <info>  Deactivating device wlan0. 
Jul 21 14:39:47 localhost NetworkManager: <info>  SWITCH: no current connection,
found better connection 'eth0'. 
Jul 21 14:39:47 localhost NetworkManager: <info>  Will activate connection 'eth0'. 
Jul 21 14:39:47 localhost NetworkManager: <info>  Device eth0 activation
scheduled... 
Jul 21 14:39:47 localhost NetworkManager: <info>  Activation (eth0) started... 

...

I'm not sure whether the killswitch error is fatal or not. I know a lot of
people are getting it and it's in the log thousands of times.

Let me know if you guys need more info to help solve this problem.
Comment 1 Thomas M Steenholdt 2007-07-25 21:47:21 EDT
setting things up manually, using wpa_supplicant, iwconfig, ifup etc works fine.
So this is really not a driver problem, but more likely a driver/nm
compatibility thing in some way.
Comment 2 Russell Harrison 2007-07-30 11:13:53 EDT
I am also seeing this problem connecting to a WPA PEAP TKIP network.
Comment 3 Thomas M Steenholdt 2007-08-05 20:46:02 EDT
I changed the network configuration to WPA2-only (AES/CCMP). Same result. Then
enabled ESSID broadcasting. Now, *poof* - things work.
It's not quite clear to me what happens, but it seems like it's having problems
determining link (or linking to) hidden APs.. This is the area of the log that
starts the difference:

good:
Aug  5 22:20:43 whipher NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) complete. 
Aug  5 22:20:45 whipher NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0 
Aug  5 22:20:45 whipher NetworkManager: <info>  nm-device.c -
nm_device_set_active_link (596) device wlan0 link state set to 1 
Aug  5 22:20:45 whipher NetworkManager: <info>  Activation (wlan0/wireless)
Stage 2 of 5 (Device Configure) successful.  Connected to access point 'mynet'. 
Aug  5 22:20:45 whipher NetworkManager: <info>  Activation (wlan0) Stage 3 of 5
(IP Configure Start) scheduled. 

bad:
Aug  5 18:36:18 whipher NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) complete. 
Aug  5 18:36:58 whipher NetworkManager: <info>  Activation (wlan0/wireless):
association took too long (>40s), failing activation. 
Aug  5 18:36:58 whipher NetworkManager: <info>  Activation (wlan0) failure
scheduled... 
Aug  5 18:36:58 whipher NetworkManager: <info>  Activation (wlan0) failed for
access point (mynet) 
Aug  5 18:36:58 whipher NetworkManager: <info>  Activation (wlan0) failed. 
Aug  5 18:36:58 whipher NetworkManager: <info>  Deactivating device wlan0. 
Aug  5 18:36:59 whipher NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0 
Aug  5 18:37:06 whipher NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0 
Comment 4 Thomas M Steenholdt 2007-08-06 22:36:27 EDT
Created attachment 160791 [details]
proposed patch (should at least be reviewed)

I've been experimenting a bit tonight and this is what I've found.

AP_SCAN 2 : ESSID is set on the wireless device, but it never 
associates. Presumably because it cannot find the AP.

AP_SCAN 1: ESSID does NOT get set on the wireless device, so does not 
work alone - during the device setup phase, if you issue an "iwconfig 
wlan0 essid whatever", the device will associate fine.

So I made a patch to incorporate the two and to prove a point.	:) 

Please note, that this patch is intended to prove that the association 
to hidden IS possible, even with ipw4965 devices. The patch changes the 
AP_SCAN value for hidden networks and I have no clue as to what that 
will do for other wireless devices. Also, since I've not gotten 
acquainted to very much of the NetworkManager code, there might be 
better places to put some of these things. So it should at the very 
least be reviewed by someone more familiar with the NM code than myself. 

This patch has also been posted on the NetworkManager development mailinglist
for comments. There are people there who are experiencing the same problem.
Comment 5 Dan Williams 2008-01-10 18:39:21 EST

*** This bug has been marked as a duplicate of 373841 ***

Note You need to log in before you can comment on or make changes to this bug.