Bug 373841 - NetworkManager unable to connect to hidden wireless network on madwifi
NetworkManager unable to connect to hidden wireless network on madwifi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 178629 249156 267261 410931 427878 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 16:30 EST by Ryuhei Yokokawa
Modified: 2008-08-02 19:40 EDT (History)
12 users (show)

See Also:
Fixed In Version: 0.7.0-0.6.7.svn3235.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:50:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages file from /var/log/messages showing the results from NM (10.31 KB, text/plain)
2007-11-09 16:30 EST, Ryuhei Yokokawa
no flags Details

  None (edit)
Description Ryuhei Yokokawa 2007-11-09 16:30:18 EST
Description of problem:
I have a hidden wireless network.  I add the ssid manually using the NM-app.
NM tries to connect many times but fails to.  The only way I can get it to
connect is to issue this command while it is trying to connect: (where <essid>
is your hidden essid)
iwconfig wlan0 essid <essid>


Version-Release number of selected component (if applicable):
NetworkManager:
NetworkManager-gnome-0.7.0-0.5.svn3030.fc8
NetworkManager-openvpn-0.7.0-2.svn3047.fc8
NetworkManager-glib-0.7.0-0.5.svn3030.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8
NetworkManager-0.7.0-0.5.svn3030.fc8

Madwifi from LVN:
madwifi-0.9.3.3-1.lvn8
kmod-madwifi-2.6.23.1-42.fc8-0.9.3.3-9.lvn8
kmod-madwifi-0.9.3.3-9.lvn8


How reproducible:
Everytime

Steps to Reproduce:
1.Boot computer
2.Try manually adding hidden essid using the gnome-NM-app
3.Hope that it connects
4.Fail
  
Actual results:
Failure to connect to hidden wireless network

Expected results:
Success at connecting to hidden wireless network

Additional info:
Attached is part of the messages log file in /var/log which gives a good clue of
what is happening.  At the end of the file, it shows that NM connects to the net
when I assign the essid manually using the iwconfig tool.

Here is my lsmod:
Module                  Size  Used by
autofs4                20421  2 
nf_conntrack_ipv4      11717  3 
ipt_REJECT              7617  2 
iptable_filter          6465  1 
ip_tables              14213  1 iptable_filter
xt_state                6081  3 
nf_conntrack           51977  2 nf_conntrack_ipv4,xt_state
nfnetlink               8281  2 nf_conntrack_ipv4,nf_conntrack
xt_tcpudp               6977  5 
x_tables               14277  4 ipt_REJECT,ip_tables,xt_state,xt_tcpudp
cpufreq_ondemand       10317  1 
loop                   16581  0 
dm_mirror              21697  0 
dm_multipath           18249  0 
dm_mod                 46465  2 dm_mirror,dm_multipath
radeon                114145  2 
drm                    67028  3 radeon
ipv6                  245989  8 
snd_atiixp             18509  4 
snd_seq_dummy           6725  0 
snd_atiixp_modem       15177  1 
snd_ac97_codec         92389  2 snd_atiixp,snd_atiixp_modem
ac97_bus                6081  1 snd_ac97_codec
wlan_scan_sta          14464  1 
snd_seq_oss            29889  0 
ath_rate_sample        14592  1 
irda                  106617  0 
snd_seq_midi_event      9793  1 snd_seq_oss
snd_seq                44849  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
b44                    25937  0 
parport_pc             26981  0 
ath_pci                84384  0 
crc_ccitt               6081  1 irda
ssb                    29893  1 b44
parport                32393  1 parport_pc
wlan                  172740  4 wlan_scan_sta,ath_rate_sample,ath_pci
firewire_ohci          18113  0 
mii                     8385  1 b44
ath_hal               193488  3 ath_rate_sample,ath_pci
snd_seq_device         10061  3 snd_seq_dummy,snd_seq_oss,snd_seq
firewire_core          36097  1 firewire_ohci
crc_itu_t               6081  1 firewire_core
sdhci                  17997  0 
mmc_core               27333  1 sdhci
snd_pcm_oss            37569  0 
snd_mixer_oss          16705  3 snd_pcm_oss
video                  19921  0 
output                  6977  1 video
snd_pcm                63685  4
snd_atiixp,snd_atiixp_modem,snd_ac97_codec,snd_pcm_oss
battery                14025  0 
ac                      8133  0 
button                 10321  0 
snd_timer              20549  2 snd_seq,snd_pcm
k8temp                  8257  0 
serio_raw               9029  0 
snd                    43461  16
snd_atiixp,snd_atiixp_modem,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9633  3 snd
hwmon                   6469  1 k8temp
snd_page_alloc         11337  3 snd_atiixp,snd_atiixp_modem,snd_pcm
i2c_piix4              11341  0 
i2c_core               21825  1 i2c_piix4
joydev                 11649  0 
sg                     31965  0 
sr_mod                 17509  0 
cdrom                  33889  1 sr_mod
ata_generic             8901  0 
pata_atiixp             9409  3 
libata                 99633  2 ata_generic,pata_atiixp
sd_mod                 27329  4 
scsi_mod              119757  4 sg,sr_mod,libata,sd_mod
ext3                  110665  2 
jbd                    52457  1 ext3
mbcache                10177  1 ext3
uhci_hcd               23633  0 
ohci_hcd               21445  0 
ehci_hcd               31693  0 

Here is my modprobe.d/madwifi:
alias wifi0 ath_pci
alias wlan0 ath_pci
options ath_pci autocreate=sta
Comment 1 Ryuhei Yokokawa 2007-11-09 16:30:18 EST
Created attachment 253591 [details]
messages file from /var/log/messages showing the results from NM
Comment 2 Paul Vriens 2007-11-12 09:20:26 EST
At first I thought it was an issue with my 'Asus WL100-G' and the b43legacy
driver. After the last kernel update my system doesn't crash anymore after
removing the pcmcia card but still no go when using a hidden ESSID. Network is
fine when I 'unhide' the ESSID.

I'm not using madwifi btw, so this is plain F8 stuff.
Comment 3 Paul 2007-11-17 01:49:50 EST
i cant connect to hidden networks either.  If I enable the ssid broadcast it
works.  However, WPA doesnt work at all, ever.
Comment 4 Paul 2007-11-18 02:11:18 EST
scratch that.  since knetworkmanager is now a link to nm-applet....i had to use
gconf-editor to clear out all the remembered wifi networks.....then wpa started
working.  BUT, I still can't connect to a hidden network, whether the network
has wep, wpa, or nothing, i still cant connect.

Ideally, knetworkmanager should be brought back (since I use kde).  Otherwise, I
find NM to be much more stable than in fc7.
Comment 5 Michael 2007-11-18 12:18:20 EST
I am seeing the same problem. Something is not right with the hidden SSID.
Comment 6 Michael 2007-11-21 15:40:44 EST
Also, I have noticed that if you do broadcast the SSID and allow NetworkManager
to connect to the wireless network and then quit broadcasting the SSID the
connection is dropped and can not reconnect.
Comment 7 Paul 2007-11-23 20:00:45 EST
personally, i blame nm-applet.  It is a tranish on my otherwise smoothly running
kde desktop.
Comment 8 Paul 2007-11-23 20:02:10 EST
and for the record im having this issue with an ipw2200 card, not madwifi
Comment 9 Dan Williams 2007-12-03 12:08:21 EST
I've successfully used ipw2200 with hidden networks; can you see if a straight
wpa_supplicant config will connect for you using ap_scan=2?

WRT atheros, it has in the past needed ap_scan=1.  But that is not going to be
special-cased because now that ath5k is in the upstream kernel, it will use
whatever settings the mac80211 stack uses (and all other mac80211-based
drivers).  Drivers fundamentally _need_ to support ap_scan=2; ap_scan=1 +
scan_ssid=1 is an optimization of ap_scan=2 that some drivers just cannot support.

hidden SSID support is highly driver dependent and drivers need to get better
before it gets usably better for everyone, even without NetworkManager involved.
Comment 10 Michael 2007-12-04 09:17:22 EST
Thanks alot Dan! That worked fine for me.

In my /etc/wpa_supplicant/wpa_supplicant.conf file I put the following

ap_scan=2

network={
  ...
  scan_ssid=1
}

and it worked fine after a restart of the services.

Thanks!!!
Comment 11 Ignacio Vazquez-Abrams 2007-12-08 13:32:50 EST
Adding ap_scan=2 worked for iwl3945 on x86_64, but scan_ssid=1 breaks it.
Comment 12 Ignacio Vazquez-Abrams 2007-12-09 18:40:47 EST
No wait, I lie. Will do further diagnosing...
Comment 13 Dan Williams 2008-01-10 18:35:33 EST
*** Bug 427878 has been marked as a duplicate of this bug. ***
Comment 14 Dan Williams 2008-01-10 18:36:46 EST
*** Bug 410931 has been marked as a duplicate of this bug. ***
Comment 15 Dan Williams 2008-01-10 18:37:02 EST
*** Bug 267261 has been marked as a duplicate of this bug. ***
Comment 16 Dan Williams 2008-01-10 18:39:22 EST
*** Bug 249156 has been marked as a duplicate of this bug. ***
Comment 17 Dan Williams 2008-01-10 18:42:07 EST
*** Bug 178629 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2008-01-11 17:25:08 EST
NetworkManager-0.7.0-0.6.7.svn3235.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'
Comment 19 Thomas M Steenholdt 2008-01-11 21:03:33 EST
Using NetworkManager-0.7.0-0.6.7.svn3235.fc8 and kernel-2.6.23.13-105.fc8, the
connection is established nicely! Good work, guys!
However, NM does not seem able to automatically reconnect to the hidden network
after boot. I have to re-add the hidden network manually. This is probably a
different issue. It could be a regression in NM(?) I think this was fixed way
back, but I cant remember all the details.
Comment 20 Fedora Update System 2008-01-22 10:50:04 EST
NetworkManager-0.7.0-0.6.7.svn3235.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Alexei Podtelezhnikov 2008-01-22 11:03:31 EST
As far as I can see, an earlier snapshot svn3204 has been pushed out to 
stable. How did that happen?
Comment 22 Mogens Kjaer 2008-02-04 06:35:38 EST
Is this bug fixed?

I can't get NetworkManager to connect to a hidden SSID
Comment 23 Dan Williams 2008-02-04 07:20:45 EST
(In reply to comment #22)
> Is this bug fixed?
> 
> I can't get NetworkManager to connect to a hidden SSID

Yes, it's fixed.  You need to update to the latest Fedora 8 updates kernel, and
patch the madwifi driver to advertise SSID scan capability.  All in-kernel
drivers have been updated to reflect their scan capability, but since madwifi
isn't part of the kernel it's not something we can fix...

diff -ru madwifi-0 (copy).9.3.3/net80211/ieee80211_wireless.c
madwifi-0.9.3.3/net80211/ieee80211_wireless.c
--- madwifi-0 (copy).9.3.3/net80211/ieee80211_wireless.c	2007-07-26
08:58:47.000000000 -0400
+++ madwifi-0.9.3.3/net80211/ieee80211_wireless.c	2008-02-04 07:20:17.000000000
-0500
@@ -1026,6 +1026,8 @@
                IW_ENC_CAPA_CIPHER_TKIP | IW_ENC_CAPA_CIPHER_CCMP;
 #endif
 	
+	range->scan_capa = IW_SCAN_CAPA_ESSID;
+
 	return 0;
 }
 
Comment 24 Mogens Kjaer 2008-02-04 07:41:30 EST
Ah, it's driver dependent!

So if it doesn't work with the rt73usb driver what do I do?
Comment 25 Dan Williams 2008-02-04 09:09:08 EST
Well, is the rt73usb driver using the mac80211 stack?  If it is, it should
automatically pick up this capability on the latest kernels.
Comment 26 Mogens Kjaer 2008-02-04 09:23:16 EST
# lsmod|fgrep rt
exportfs                8129  1 nfsd
rt73usb                27201  0 
rt2x00usb              12737  1 rt73usb
rt2x00lib              21313  2 rt73usb,rt2x00usb
rfkill                  9297  1 rt2x00lib
input_polldev           7369  1 rt2x00lib
crc_itu_t               6081  1 rt2x00lib
mac80211              125265  2 rt2x00usb,rt2x00lib
parport_pc             26981  0 
iTCO_vendor_support     7109  1 iTCO_wdt
parport                32393  1 parport_pc

kernel 2.6.23.14-107
Comment 27 Dan Williams 2008-02-04 10:00:04 EST
Ok, so it should have the capability.  Can you paste in the lines from
/var/log/messages where NM starts up?  It should look something like:

NetworkManager: <info>  eth1: Device is fully-supported using driver 'ipw2200'.
NetworkManager: <info>  eth1: driver supports SSID scans (scan_capa 0x21).
NetworkManager: <info>  Now managing wireless (802.11) device 'eth1'.

Comment 28 Mogens Kjaer 2008-02-04 12:21:49 EST
Feb  4 12:40:53 localhost NetworkManager: <info>  starting...
Feb  4 12:40:53 localhost NetworkManager: <info>  eth0: Device is
fully-supported using driver 'tg3'.
Feb  4 12:40:53 localhost NetworkManager: <info>  Now managing wired Ethernet
(802.3) device 'eth0'. 
Feb  4 12:40:53 localhost NetworkManager: <info>  Bringing up device eth0
Feb  4 12:40:53 localhost kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Feb  4 12:40:53 localhost NetworkManager: <info>  Deactivating device eth0.
Feb  4 12:40:53 localhost NetworkManager: <info>  (eth0): exporting device as
/org/freedesktop/Hal/devices/net_00_0b_cd_dd_5b_cb
Feb  4 12:40:53 localhost NetworkManager: <info>  wlan0: Device is
fully-supported using driver 'rt73usb'.
Feb  4 12:40:53 localhost NetworkManager: <info>  Now managing wireless (802.11)
device 'wlan0'.
Feb  4 12:40:53 localhost NetworkManager: <info>  Bringing up device wlan0
Feb  4 12:40:53 localhost kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Feb  4 12:40:53 localhost NetworkManager: <info>  Deactivating device wlan0.
Feb  4 12:40:53 localhost NetworkManager: <info>  (wlan0): exporting device as
/org/freedesktop/Hal/devices/net_00_1a_70_35_0b_a5
Feb  4 12:40:53 localhost NetworkManager: <info>  (eth0) supplicant interface is
now in state 2 (from 1).
Feb  4 12:40:53 localhost NetworkManager: <info>  (wlan0) supplicant interface
is now in state 2 (from 1).

There's no "driver supports SSID scans"
Comment 29 Mogens Kjaer 2008-02-06 08:49:20 EST
I tried another machine with a PCMCIA card using the b43 driver.

Same problem, can't connect to access point with hidden SSID.
Comment 30 Dan Williams 2008-02-06 09:42:21 EST
Does NetworkManager on the other machine report anything about SSID scan
capability when it starts up?  If that message isn't in the logs, it likely
won't work.  You'll need NetworkManager-0.7.0-0.6.7.svn3235 or later, which was
pushed to F8-updates on 2008-01-22.  Try updating a bit later today.
Comment 31 Mogens Kjaer 2008-02-06 09:52:51 EST
I have NetworkManager-0.7.0-0.6.7.svn3204.fc8.i386.rpm as the latest
in updates/8/i386.

Is this related to comment #21 ?
Comment 32 Dan Williams 2008-02-06 09:58:55 EST
Yeah, something got screwed up in update repo generation, and that's being
corrected as I type this, hence the "try updating a bit later today."  When you
see 3235 hit the repos, any mac80211-based, ipw2200, hostap, or libertas drivers
should work better with hidden SSIDs for you.
Comment 33 Mogens Kjaer 2008-02-06 10:04:49 EST
I'll test later.

Will this fix end in F7 as well?
Comment 34 Dan Williams 2008-02-06 11:04:21 EST
No, it's not present in F7 yet.  On track for a 0.6.6 release sometime later
this month though.
Comment 35 Mogens Kjaer 2008-02-07 04:17:26 EST
It works both for b43 and rt73usb, thanks!

Note You need to log in before you can comment on or make changes to this bug.