Bug 249161 - usb stick is not mounted when inserted
usb stick is not mounted when inserted
Status: CLOSED DUPLICATE of bug 249282
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 14:53 EDT by cornel panceac
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 11:24:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages, sealert output (3.98 KB, text/plain)
2007-07-24 11:01 EDT, Mark Knoop
no flags Details

  None (edit)
Description cornel panceac 2007-07-21 14:53:58 EDT
Description of problem:
i insert one usbstick and it is not automounted with the new kernel.


Version-Release number of selected component (if applicable):
kernel-2.6.22.1-27.fc7

How reproducible:
every time

Steps to Reproduce:
1.insert usb stick
2.
3.
  
Actual results:
no icon shows up and the device is not mounted under media

Expected results:
one icon appears in nautilus indicating that the device is mounted under /media

Additional info:
inserting a cdrom, the disc is automounted.
the automount worked under kernel-2.6.21-1.3228.fc7 .
if the system boots with the device already plugged in, it is automounted during
boot.
no icon appears under 'computer:///' wich can be used to manually mount the device.
Comment 1 Bruce Brackbill 2007-07-21 22:00:44 EDT
I have the same problem with the latest updates from July 20/21 2007
kernel-2.6.22.1-27.fc7
Comment 2 Piergiorgio Sartor 2007-07-23 11:23:23 EDT
Same here. With some interesting cases.
I tested 2 USB storage devices, one is a flash stick, the other is an external
2.5" HD.
The first one works fine as before. The second one falls into the above problem.
One interesting thing is that both appears in /dev/disk/by-label/ with their
proper names.
What makes thing nasty is that gnome-mount, launched by command line, either is
stuck or does return "gnome-mount 0.6", i.e. it is either "waiting" or silently
failing. Furthermore, the option "--verbose" (of gnome-mount) does nothing.
Comment 3 Andre Robatino 2007-07-23 17:51:45 EDT
  Following today's updates (including selinux-policy*2.6.4-28.fc7), my USB
thumb drive automounts again with kernel-2.6.22.1-27.fc7.
Comment 4 cornel panceac 2007-07-24 00:04:17 EDT
confirmed. usb stick is automounted. selinux-policy-2.6.4-26.fc7 .
autofs-5.0.1-20 . 
Comment 5 Milan Slanař 2007-07-24 10:20:21 EDT
Still don't work for me. Should be reopened.
Comment 6 Mark Knoop 2007-07-24 11:01:02 EDT
Created attachment 159854 [details]
/var/log/messages, sealert output

- excerpt from /var/log/messages
- output of relevant sealert
Comment 7 Mark Knoop 2007-07-24 11:05:18 EDT
Still doesn't work for me also. 

The difference between the two events described in the attachment to Comment #6
is that the first, unsuccessful, attempt is with a USB card-reader plugged
directly into a spare USB port, whereas in the second, successful, attempt, the
same card was inserted into a USB reader which was plugged in since *before* the
last reboot. 
Comment 8 cornel panceac 2007-07-24 12:26:43 EDT
hmm. it's no longer working. selinux-policy-selinux-policy-2.6.4-28.fc7
but it's no longer working even with setenforce 0 so i'm wondering if it's
selinux related after all. maybe it's just the kernel unstable?

these are the packages updated/installed after my previous comment:
Jul 24 07:47:08 Updated: kdelibs.i386 6:3.5.7-9.fc7
Jul 24 07:47:11 Updated: qt4.i386 4.3.0-9.fc7.1
Jul 24 07:47:15 Updated: mplayer.i386 1.0-0.80.20070715svn.lvn7
Jul 24 07:47:19 Updated: qt4-x11.i386 4.3.0-9.fc7.1
Jul 24 07:47:23 Updated: selinux-policy.noarch 2.6.4-28.fc7
Jul 24 07:47:24 Installed: cyrus-sasl-gssapi.i386 2.1.22-6
Jul 24 07:47:24 Installed: mozldap-tools.i386 6.0.3-1.fc7
Jul 24 07:47:28 Updated: fedora-ds-base.i386 1.1.0-0.3.20070720.fc7
Jul 24 07:48:04 Updated: gnome-utils.i386 1:2.18.1-2.fc7
Jul 24 07:48:24 Updated: selinux-policy-targeted.noarch 2.6.4-28.fc7
Jul 24 07:48:24 Updated: ed.i386 0.7-1.fc7
Jul 24 07:48:29 Updated: mplayer-gui.i386 1.0-0.80.20070715svn.lvn7
Jul 24 07:48:39 Updated: gdm.i386 1:2.18.3-1.fc7
Jul 24 07:48:45 Updated: mplayer-doc.i386 1.0-0.80.20070715svn.lvn7
Jul 24 07:48:52 Updated: chmsee.i386 1.0.0-0.22.beta2.fc7
Jul 24 07:48:54 Updated: mencoder.i386 1.0-0.80.20070715svn.lvn7
Jul 24 07:49:05 Updated: seahorse.i386 1.0.1-6.fc7
Jul 24 07:50:00 Updated: kdelibs-apidocs.i386 6:3.5.7-9.fc7
Jul 24 07:50:18 Updated: gedit.i386 1:2.18.2-1.fc7
Jul 24 07:50:28 Updated: kdelibs-devel.i386 6:3.5.7-9.fc7
Jul 24 07:50:31 Updated: xine.i386 0.99.5-1.lvn7

Comment 9 cornel panceac 2007-07-24 12:34:40 EDT
news:

the device:

Bus 002 Device 006: ID 090c:1000 Feiya Technology Corp. Memory Bar

is _not_ mounted/recognized.

the device:

Bus 002 Device 007: ID 0457:0151 Silicon Integrated Systems Corp. Super Flash
1GB Flash Drive

_is_ recognized and automounted.

although i don't understand why lsusb reports only 1GB (it's a 2 GiB traxdata)

could it be that the first device is usb 1.0? (although it pretends it's 2.0?)
Comment 10 Mark Knoop 2007-07-24 13:58:52 EDT
Hmm, mine:

# lsusb
Bus 007 Device 003: ID 0aec:3260 Neodio Technologies Corp. 7-in-1 Card Reader
Bus 006 Device 005: ID 05dc:b023 Lexar Media, Inc. 
Bus 004 Device 005: ID 0fce:e041 Sony Ericsson Mobile Communications AB 

The Neodio 7-in-1 works (at least when attached prior to last reboot); the Lexar
doesn't. BUT, just tried plugging in my Sony Ericsson phone (in USB storage
mode) and it *does* mount.

So I went back and tried the Lexar again. If I plug in the reader *without* an
SD card in it, wait a couple of seconds, and then put the card in, it is mounted
by hal. But if I plug the reader in with a card already in it, it doesn't.

The setroubleshoot warning only occurs occasionally, not every time - perhaps
it's unrelated? Hope this info helps...

Hal reports all as usb 2.0. 
Comment 11 Mikkel L. Ellertson 2007-07-24 15:01:38 EDT
This may be related to the partition type. I have 2 sticks that I used for
testing. One mounter, the other did not.

PNY 128M stick - mounts.
/dev/sda1   *           1         495      126704    6  FAT16:

Nextdisk 32M stick - does not mount.
/dev/sda1   *           1         998       31920    4  FAT16 <32M

Comment 12 cornel panceac 2007-07-24 15:08:57 EDT
in my case:

the device/partition wich is automounted:

# fdisk -l /dev/sdb

Disk /dev/sdb: 2055 MB, 2055208960 bytes
255 heads, 63 sectors/track, 249 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1         250     2007008+   6  FAT16
Partition 1 has different physical/logical endings:
     phys=(248, 254, 63) logical=(249, 220, 35)


the device/partition wich is not automounted:

# fdisk -l /dev/sdb

Disk /dev/sdb: 2029 MB, 2029518848 bytes
17 heads, 32 sectors/track, 7286 cylinders
Units = cylinders of 544 * 512 = 278528 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        7287     1981936    6  FAT16


Comment 13 Brian Millett 2007-07-24 15:27:33 EDT
Status needs to be changed.

Ok, I'll throw this into the stew.

2 usb flash disks, 

1) SanDisk  U3 Cruzer Micro  2.18 PQ: 0 ANSI: 2
2) LEXAR    JD FIREFLY       1100 PQ: 0 ANSI: 0 CCS

Disk 1 mounts, disk 2 does not.

[bpm]$ sudo /lib/udev/usb_id -x /block/sdc
ID_VENDOR=SanDisk
ID_MODEL=U3_Cruzer_Micro
ID_REVISION=2.18
ID_SERIAL=SanDisk_U3_Cruzer_Micro_000017519860AD5C
ID_TYPE=disk
ID_BUS=usb

[bpm]$ sudo fdisk -l /dev/sdc

Disk /dev/sdc: 2048 MB, 2048729600 bytes
64 heads, 63 sectors/track, 992 cylinders
Units = cylinders of 4032 * 512 = 2064384 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1         992     1999749+   6  FAT16

[bpm]$ sudo /lib/udev/usb_id -x /block/sdd
ID_VENDOR=LEXAR
ID_MODEL=JD_FIREFLY
ID_REVISION=1100
ID_SERIAL=LEXAR_JD_FIREFLY_1069F012224107101006
ID_TYPE=disk
ID_BUS=usb

[bpm]$ sudo fdisk -l /dev/sdd

Disk /dev/sdd: 2029 MB, 2029518848 bytes
243 heads, 32 sectors/track, 509 cylinders
Units = cylinders of 7776 * 512 = 3981312 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1               1         510     1981936    b  W95 FAT32
Partition 1 has different physical/logical endings:
     phys=(249, 242, 32) logical=(509, 184, 32)

Tail of /var/log/messages as disk1 was inserted:

Jul 24 14:03:59 dufus kernel: scsi 4:0:0:0: Direct-Access     SanDisk  U3 Cruzer
Micro  2.18 PQ: 0 ANSI: 2
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: [sdc] 4001425 512-byte hardware
sectors (2049 MB)
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: [sdc] Write Protect is off
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: [sdc] Assuming drive cache: write through
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: [sdc] 4001425 512-byte hardware
sectors (2049 MB)
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: [sdc] Write Protect is off
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: [sdc] Assuming drive cache: write through
Jul 24 14:03:59 dufus kernel:  sdc: sdc1
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: [sdc] Attached SCSI removable disk
Jul 24 14:03:59 dufus kernel: sd 4:0:0:0: Attached scsi generic sg3 type 0
Jul 24 14:03:59 dufus hald: mounted /dev/sdc1 on behalf of uid 500
Jul 24 14:04:26 dufus kernel: usb 5-4: new high speed USB device using ehci_hcd
and address 7
Jul 24 14:04:26 dufus kernel: usb 5-4: configuration #1 chosen from 1 choice
Jul 24 14:04:26 dufus kernel: scsi5 : SCSI emulation for USB Mass Storage devices

tail from /var/log/messages as disk2 is inserted:

Jul 24 14:04:31 dufus kernel: scsi 5:0:0:0: Direct-Access     LEXAR    JD
FIREFLY       1100 PQ: 0 ANSI: 0 CCS
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: [sdd] 3963904 512-byte hardware
sectors (2030 MB)
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: [sdd] Write Protect is off
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: [sdd] Assuming drive cache: write through
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: [sdd] 3963904 512-byte hardware
sectors (2030 MB)
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: [sdd] Write Protect is off
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: [sdd] Assuming drive cache: write through
Jul 24 14:04:31 dufus kernel:  sdd: sdd1
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: [sdd] Attached SCSI removable disk
Jul 24 14:04:31 dufus kernel: sd 5:0:0:0: Attached scsi generic sg4 type 0
Comment 14 cornel panceac 2007-07-24 16:28:35 EDT
news:

while trying to import my photos:

An error occurred in the io-library ('Could not claim the USB device'): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device.

asexpected, same error with setenforce 0 .

camera is kodak easyshare z650 .
Comment 15 Andre Costa 2007-07-24 20:40:20 EDT
Hi,

I am experiencing this as well.

I have two USB pendrives (old 256M LG and new 1G PQI). LG has always been
correctly recognized and mounted by Fedora kernels, and still is with latest
kernel. PQI however has been working with previous F7 kernels, but stopped being
automatically recognized by latest kernel (it can be manually mounted, though).

Some additional info that might be useful for kernel (or HAL) developers:

'lshal -m' shows this for each pendrive:

** LG **

10:18:13.119: usb_device_67b_2515_noserial added
10:18:13.342: usb_device_67b_2515_noserial_if0 added
10:18:13.475: usb_device_67b_2517_noserial added
10:18:13.703: usb_device_67b_2517_noserial_if0 added
10:18:18.596: usb_device_67b_2517_noserial_if0_scsi_host added
10:18:18.598: usb_device_67b_2517_noserial_if0_scsi_host_scsi_device_lun0 added
10:18:18.705:
usb_device_67b_2517_noserial_if0_scsi_host_scsi_device_lun0_scsi_generic
added
10:18:18.957: storage_serial_Prolific_Technology_Inc__USB_Mass_Storage_Device
added
10:18:19.222: volume_part1_size_260030464 added

** PQI **

10:16:34.935: usb_device_3538_54_2007120000003F added
10:16:35.157: usb_device_3538_54_2007120000003F_if0 added
10:16:40.047: usb_device_3538_54_2007120000003F_if0_scsi_host added
10:16:40.049: usb_device_3538_54_2007120000003F_if0_scsi_host_scsi_device_lun0
added
10:16:40.160:
usb_device_3538_54_2007120000003F_if0_scsi_host_scsi_device_lun0_scsi_generic
added

I have no idea what these codes mean, but HAL seems to stop earlier for PQI
pendrive than for LG.

'lsusb -v' gives this for PQI:

Bus 003 Device 016: ID 3538:0054 Power Quotient International Co., Ltd 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x3538 Power Quotient International Co., Ltd
  idProduct          0x0054 
  bcdDevice            1.00
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
    MaxPower               80mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk (Zip)
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               8

HTH

Andre
Comment 16 idak 2007-07-25 06:40:33 EDT
This might be the same as Bugzilla Bug #249282.
Comment 17 Andre Robatino 2007-07-25 07:01:16 EDT
  The same USB thumb drive that automounted for me again 2 days ago doesn't
anymore.  There were some more updates but nothing that seems relevant.
Comment 18 Milan Slanař 2007-07-25 08:33:44 EDT
On comment #16: Yes. Following the advice from bug #249282 USB disk started
automounting. Should be marked duplicate of this bug.
Comment 19 cornel panceac 2007-07-25 23:34:12 EDT
unfortunately, commenting out that line (as suggested in #249282) makes my
onboard sound card (nvidia mcp55 high definition audio - intel) unusable, wich
for me is fatal :), so i have to ignore this advice.
Comment 20 Brian Millett 2007-07-26 08:40:12 EDT
Same here, pcmcia cards no longer worked.  what I did, and now the pcmcia still
mounts, as well as the lexar drive now is to move the label so it is just a no
op.  I just moved the LABEL="skip_wait to be right underneath the line that was
before suggested to comment out.


 diff -wruN 05-udev-early.rules /etc/udev/rules.d/05-udev-early.rules
--- 05-udev-early.rules 2007-07-26 07:37:21.000000000 -0500
+++ /etc/udev/rules.d/05-udev-early.rules       2007-07-25 18:05:51.000000000 -0500
@@ -6,6 +6,7 @@
 
 
 ACTION=="add", SUBSYSTEM=="?*", ENV{MODALIAS}=="?*", RUN+="modprobe
$env{MODALIAS}", GOTO="skip_wait"
+LABEL="skip_wait"
 
 # pnp devices
 ACTION=="add", SUBSYSTEM=="pnp", RUN+="/bin/sh -c 'while read id; do
/lib/udev/modprobe pnp:d$$id; done < /sys/$devpath/id'"
@@ -14,6 +15,6 @@
 
 ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"
 
-LABEL="skip_wait"
+#LABEL="skip_wait"
 
 ACTION=="add", SUBSYSTEM=="firmware", ENV{FIRMWARE}=="*",
RUN="/sbin/firmware_helper", OPTIONS="last_rule"
Comment 21 Mark Knoop 2007-07-26 09:51:39 EDT
Comment #20 works for me.
Comment 22 Mark Knoop 2007-07-26 10:00:42 EDT
Actually, it might be better to move the LABEL="skip_wait" line to *just before*
the "scsi" rule - then the GOTO rule is at least skipping the "pnp" and "net" lines.
Comment 23 Serguei Miridonov 2007-07-26 11:16:33 EDT
I can confirm that fix in comments 20 or 22 works for me. kernel-2.6.22.1-
33.fc7, udev-106-4.1.fc7. Tested with Nokia E65 phone connected with USB data 
cable in "Data transfer" mode and IDE hard drive connected with ATA-USB adapter.
Comment 24 Andre Robatino 2007-07-27 05:08:48 EDT
  Still doesn't automount with kernel-2.6.22.1-33.fc7 (haven't tried the above fix).
Comment 25 David Zeuthen 2007-07-27 11:24:49 EDT
I'm 99% this is a dupe of bug 249282 so closing as such.

*** This bug has been marked as a duplicate of 249282 ***

Note You need to log in before you can comment on or make changes to this bug.