Bug 249282 - USB memory can't mount on kernel 2.6.22.1-27.fc7
USB memory can't mount on kernel 2.6.22.1-27.fc7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
7
i386 Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 242789 249161 249178 249272 249662 250344 251372 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-23 10:49 EDT by idak
Modified: 2007-11-30 17:12 EST (History)
22 users (show)

See Also:
Fixed In Version: 113-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 13:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
add while() to get string surely. (876 bytes, patch)
2007-07-23 10:49 EDT, idak
no flags Details | Diff
collect while() handling (924 bytes, patch)
2007-07-23 11:27 EDT, idak
no flags Details | Diff

  None (edit)
Description idak 2007-07-23 10:49:42 EDT
Description of problem:
USB memory can't mount on kernel 2.6.22.1-27.fc7.
Because scis.type can't get collectly.
--
 # HALD_VERBOSE=1 /usr/sbin/hald --daemon=no
(snip)
21:22:32.501 [E] util.c:382: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.7/usb5/5-8/5-8:1.0/host4/target4:0:0/4:0:0:0/model'
21:22:32.501 [E] util.c:382: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.7/usb5/5-8/5-8:1.0/host4/target4:0:0/4:0:0:0/vendor'
21:22:32.501 [E] util.c:190: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.7/usb5/5-8/5-8:1.0/host4/target4:0:0/4:0:0:0/type'
21:22:32.501 [I] device.c:1969:
/sys/devices/pci0000:00/0000:00:1d.7/usb5/5-8/5-8:1.0/host4/target4:0:0/4:0:0:0/type
-> -1078645976 (-> scsi.type)
--

So I made a patch.
Comment 1 idak 2007-07-23 10:49:43 EDT
Created attachment 159788 [details]
add while() to get string surely.
Comment 2 David Zeuthen 2007-07-23 10:54:27 EDT
What's the result of running

 cat /etc/udev/rules.d/05-udev-early.rules |grep ioerr

on your system?
Comment 3 idak 2007-07-23 11:27:17 EDT
Created attachment 159789 [details]
collect while() handling

Sorry, second one is collect patch...
Comment 4 idak 2007-07-23 11:29:57 EDT
My system's ioerr is like follow.
[root@localhost ~]# cat /etc/udev/rules.d/05-udev-early.rules |grep ioerr
ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"
Comment 5 idak 2007-07-23 11:31:20 EDT
Comment on attachment 159788 [details]
add while() to get string surely.

>--- hal-0.5.9/hald/linux/device.c.orig	2007-07-23 23:17:56.000000000 +0900
>+++ hal-0.5.9/hald/linux/device.c	2007-07-23 23:31:15.000000000 +0900
>@@ -1963,9 +1963,12 @@ scsi_add (const gchar *sysfs_path, const
> 
> 	hal_device_property_set_string (d, "info.product", "SCSI Device");
> 
>-	hal_util_set_string_from_file (d, "scsi.model", sysfs_path, "model");
>-	hal_util_set_string_from_file (d, "scsi.vendor", sysfs_path, "vendor");
>-	hal_util_get_int_from_file (sysfs_path, "type", &type, 0);
>+	while (hal_util_set_string_from_file (d, "scsi.model", sysfs_path, "model") == FALSE)
>+		;
>+	while (hal_util_set_string_from_file (d, "scsi.vendor", sysfs_path, "vendor") == FALSE)
>+		;
>+	while (hal_util_get_int_from_file (sysfs_path, "type", &type, 0) == FALSE)
>+		;
> 	HAL_INFO (("%s/type -> %d (-> scsi.type)", sysfs_path, type));
> 	switch (type) {
> 	case 0:  /* TYPE_DISK (disk) */
Comment 6 Simone Gotti 2007-07-24 05:30:09 EDT
Hi all,

maybe I'm really wrong but I noticed that udev wasn't waiting for ioerr_cnt
because the rule was skipped by this previous rule:

ACTION=="add", SUBSYSTEM=="?*", ENV{MODALIAS}=="?*", RUN+="modprobe
$env{MODALIAS}", GOTO="skip_wait"

In fact after commenting this out or putting the wait for ioerr_cnt before it
udevd waited and hal was called after they creation so it found the
type,vendor,model files in sysfs.

Thanks!
Bye!
Comment 7 Csaba Ortutay 2007-07-24 08:02:45 EDT
Hello, I had the same issue with my usb pendrive, and commenting out that line
from the /etc/udev/rules.d/05-udev-early.rules file mentioned by Simone solved it.

Thank you

Comment 8 idak 2007-07-24 09:34:52 EDT
Thank you for that information!
I could solve this problem :-)
Comment 9 Simone Gotti 2007-07-24 09:36:39 EDT
Of course commenting it out was only a demonstration of the possible udev issue
triggered by the increased timing on sysfs device population. This will break
module hotplugging. Maybe just fixing this rule will fix the issue.
Comment 10 David Zeuthen 2007-07-24 11:21:23 EDT
What udev version is this?
Comment 11 Simone Gotti 2007-07-24 13:46:26 EDT
On one of my fedora 7 systems (I debugged the problem on another friend's laptop
but the /etc/udev/rules.d/05-udev-early.rules looks the same) the udev version
is: udev-106-4.1.fc7
Comment 12 Mario Pascucci 2007-07-25 04:22:00 EDT
(In reply to comment #6)
> Hi all,
> 
> maybe I'm really wrong but I noticed that udev wasn't waiting for ioerr_cnt
> because the rule was skipped by this previous rule:
> 
> ACTION=="add", SUBSYSTEM=="?*", ENV{MODALIAS}=="?*", RUN+="modprobe
> $env{MODALIAS}", GOTO="skip_wait"
> 
> In fact after commenting this out or putting the wait for ioerr_cnt before it
> udevd waited and hal was called after they creation so it found the
> type,vendor,model files in sysfs.
> 

I can confirm the problem with a luks encrypted external USB disk, too.
After commenting that line in 05-udev-early.rules the system shows again
password prompt and mount disk automatically. Fedora 7 updated on july 24, 2007,
kernel 2.6.22.1-27.fc7, udev 106-4.1.fc7
Comment 13 David Zeuthen 2007-07-25 11:41:51 EDT
Harald.. what's going on? What is the justification of having that GOTO
skip_wait thing?
Comment 14 David Zeuthen 2007-07-27 11:06:58 EDT
*** Bug 242789 has been marked as a duplicate of this bug. ***
Comment 15 David Zeuthen 2007-07-27 11:07:42 EDT
*** Bug 249178 has been marked as a duplicate of this bug. ***
Comment 16 Serguei Miridonov 2007-07-27 11:18:07 EDT
Please, check bugs 249161 and 249272. Seem to be duplicates as well...
Comment 17 David Zeuthen 2007-07-27 11:24:54 EDT
*** Bug 249161 has been marked as a duplicate of this bug. ***
Comment 18 David Zeuthen 2007-07-27 11:27:31 EDT
*** Bug 249272 has been marked as a duplicate of this bug. ***
Comment 19 David Zeuthen 2007-07-27 11:55:30 EDT
*** Bug 249662 has been marked as a duplicate of this bug. ***
Comment 20 NILMONI DEB 2007-07-27 13:19:00 EDT
On kernel 2.6.22.1-33.fc7, USB pen drive seems to be detected and 
mounted/unmounted just fine. Are others seeing the same behavior?
Comment 21 NILMONI DEB 2007-07-27 13:23:55 EDT
(In reply to comment #16)
> Please, check bugs 249161 and 249272. Seem to be duplicates as well...

Bug 242359 may be a duplicate as well.
Comment 22 Serguei Miridonov 2007-07-27 13:30:54 EDT
(In reply to comment #20)
> On kernel 2.6.22.1-33.fc7, USB pen drive seems to be detected and 
> mounted/unmounted just fine. Are others seeing the same behavior?

For Nokia E65 connected with USB data cable in "Data transfer" mode the fix in 
05-udev-early.rules is required. Without that it is not mounted automatically.
Comment 23 Mario Bruckschwaiger 2007-07-27 13:48:04 EDT
The 05-udev-early.rules "fix" also works for Nokia N95 (Bug 249662).
Comment 24 Mario Pascucci 2007-07-27 17:26:37 EDT
I downgraded to udev in Fedora 7 DVD and booted with kernel-2.6.21-1.3228.fc7,
and the password panel shows up again, but usb encrypted disk still not mount,
and no device is created in /dev/mapper. I think that we looking in the wrong
direction. Can be HAL or d-bus problem?
Comment 25 Oscar Osta 2007-07-29 15:58:05 EDT
Hi all,
I have commented this line and the sound card don't works. My laptop is a HP
Compaq NX7400.

I have try move the line 
ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt" 
before 
ACTION=="add", SUBSYSTEM=="?*", ENV{MODALIAS}=="?*", RUN+="modprobe
$env{MODALIAS}", GOTO="skip_wait" 
and my USB memory auto mount and the sound card works.

Bye!
Comment 26 Richard L. England 2007-07-29 21:08:12 EDT
As a data point, the following works (automounts) on kernel  2.6.22.1-33.fc7

PQI 1Gig  (works)
-------------

Jul 29 08:56:04 didius kernel: usb 5-6.1: new high speed USB device using
ehci_hcd and address 11
Jul 29 08:56:04 didius kernel: usb 5-6.1: configuration #1 chosen from 1 choice
Jul 29 08:56:04 didius kernel: scsi12 : SCSI emulation for USB Mass Storage devices
Jul 29 08:56:09 didius kernel: scsi 12:0:0:0: Direct-Access     Generic  USB
Flash Disk   1.00 PQ: 0 ANSI: 2
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: [sdc] 1934848 512-byte hardware
sectors (991 MB)
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: [sdc] Write Protect is off
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: [sdc] Assuming drive cache: write
through
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: [sdc] 1934848 512-byte hardware
sectors (991 MB)
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: [sdc] Write Protect is off
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: [sdc] Assuming drive cache: write
through
Jul 29 08:56:09 didius kernel:  sdc: sdc1
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: [sdc] Attached SCSI removable disk
Jul 29 08:56:09 didius kernel: sd 12:0:0:0: Attached scsi generic sg4 type 0
Jul 29 08:56:10 didius hald: mounted /dev/sdc1 on behalf of uid 500



$ cat /proc/scsi/usb-storage/12
   Host scsi12: usb-storage
       Vendor: Generic 
      Product: USB Flash Disk  000000000000001
Serial Number: 000000000000001000000817
     Protocol: Transparent SCSI
    Transport: Bulk
       Quirks:


$ /sbin/lsusb
Bus 003 Device 002: ID 03f0:3611 Hewlett-Packard 
Bus 003 Device 001: ID 0000:0000  
Bus 005 Device 011: ID 3538:0050 Power Quotient International Co., Ltd 
Bus 005 Device 001: ID 0000:0000  
Bus 005 Device 003: ID 0409:0059 NEC Corp. HighSpeed Hub
Bus 004 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 001: ID 0000:0000 

While the following does not:
Memorex 4Gig
-------------

Jul 28 16:21:44 didius kernel: usb 5-6.1: new high speed USB device using
ehci_hcd and address 8
Jul 28 16:21:45 didius kernel: usb 5-6.1: configuration #1 chosen from 1 choice
Jul 28 16:21:45 didius kernel: scsi9 : SCSI emulation for USB Mass Storage devices
Jul 28 16:21:50 didius kernel: scsi 9:0:0:0: Direct-Access     Memorex 
TRAVELDRIVE 005B PMAP PQ: 0 ANSI: 0 CCS
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: [sdc] 8058880 512-byte hardware
sectors (4126 MB)
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: [sdc] Write Protect is off
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: [sdc] Assuming drive cache: write through
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: [sdc] 8058880 512-byte hardware
sectors (4126 MB)
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: [sdc] Write Protect is off
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: [sdc] Assuming drive cache: write through
Jul 28 16:21:50 didius kernel:  sdc: sdc1
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: [sdc] Attached SCSI removable disk
Jul 28 16:21:50 didius kernel: sd 9:0:0:0: Attached scsi generic sg4 type 0


$ cat /proc/scsi/usb-storage/4
   Host scsi4: usb-storage
       Vendor: hp
      Product: psc 2400 series
Serial Number: MY39FD203F6T
     Protocol: Transparent SCSI
    Transport: Bulk
       Quirks:
$ cat /proc/scsi/usb-storage/9
   Host scsi9: usb-storage
       Vendor: Memorex 
      Product: TRAVELDRIVE 005B
Serial Number: 07751F940666
     Protocol: Transparent SCSI
    Transport: Bulk
       Quirks:



$ /sbin/lsusb
Bus 003 Device 002: ID 03f0:3611 Hewlett-Packard 
Bus 003 Device 001: ID 0000:0000  
Bus 005 Device 008: ID 12f7:1e23  
Bus 005 Device 001: ID 0000:0000  
Bus 005 Device 003: ID 0409:0059 NEC Corp. HighSpeed Hub
Bus 004 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 001: ID 0000:0000 

nor did the Memorex 2Gig work...

With the change to 05-udev-early.rules, outlined here, things seem to work.
Comment 27 idak 2007-07-30 08:02:46 EDT
Release candidate udev-113-7.fc7
could get from
http://koji.fedoraproject.org/koji/buildinfo?buildID=12152
Comment 28 Alex Villacís Lasso 2007-07-30 16:59:22 EDT
For your information, I created a bug report at:

http://bugzilla.kernel.org/show_bug.cgi?id=8770

of this issue, as a kernel bug. 2.6.21 series worked OK, 2.6.22 (self-compiled)
did not, 2.6.22 distro updates did not, either. 2.6.23-rc1 does not work,
either. Just to be clear, is this a kernel bug, or an userspace (udev/HAL) bug?
Comment 29 Simone Gotti 2007-07-30 17:20:55 EDT
Here we're talking about an udev rules bug that weren't waiting for the creation
of some files under /sys needed by hal on a scsi add kernel event.
The kernel populates these files after the scsi add event happens. Quite
probably on 2.6.21 they were populated in a shorter time, so moving to 2.6.22
made this problem happen more often.
Quite probably on a 2.6.21 kernel with a faster system hal will check for these
files before they are created giving the same problem.
Comment 30 Milan Slanař 2007-07-31 09:38:04 EDT
I am using new kernel 2.6.22.1-41 and udev-113-7 from updates-testing and USB
works for me.
Comment 31 Aly Dharshi 2007-07-31 11:27:02 EDT
I am using the latest kernel (not in updates-testing):

[root@edtnas67 dharshi]# uname -a
Linux localhost.localdomain 2.6.22.1-33.fc7 #1 SMP Mon Jul 23 17:33:07 EDT 2007
i686 athlon i386 GNU/Linux

    This is the dmesg output:

usb 3-6: new high speed USB device using ehci_hcd and address 7
usb 3-6: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 7
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 5:0:0:0: Direct-Access     SEAGATE  ST660211USB      4.06 PQ: 0 ANSI: 2
sd 5:0:0:0: [sdd] 11719008 512-byte hardware sectors (6000 MB)
sd 5:0:0:0: [sdd] Write Protect is off
sd 5:0:0:0: [sdd] Mode Sense: 73 00 00 08
sd 5:0:0:0: [sdd] Assuming drive cache: write through
sd 5:0:0:0: [sdd] 11719008 512-byte hardware sectors (6000 MB)
sd 5:0:0:0: [sdd] Write Protect is off
sd 5:0:0:0: [sdd] Mode Sense: 73 00 00 08
sd 5:0:0:0: [sdd] Assuming drive cache: write through
 sdd: sdd1
sd 5:0:0:0: [sdd] Attached SCSI removable disk
sd 5:0:0:0: Attached scsi generic sg4 type 0
usb 3-6: USB disconnect, address 7
usb 3-6: new high speed USB device using ehci_hcd and address 8
usb 3-6: configuration #1 chosen from 1 choice
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 8
usb-storage: waiting for device to settle before scanning 


ofcourse the problem is that there is no icon on the desktop, I am currently
doing an update and I see there is an autofs update, I suspect that may not
solve the problem, if there is anymore info that I can provide to help
troubleshoot let me know.

Aly.
Comment 32 Aly Dharshi 2007-07-31 11:34:37 EDT
I commented out the line as mentioned above as a work around and it did the trick:

#ACTION=="add", SUBSYSTEM=="?*", ENV{MODALIAS}=="?*", RUN+="modprobe
$env{MODALIAS}", GOTO="skip_wait"

this is 05-udev-early.rules, on kernel version 2.6.22.1-33.fc7 which is in updates.
Comment 33 Serguei Miridonov 2007-07-31 11:40:14 EDT
Autofs may not help. It's better to try to update udev. Run as root

yum --enablerepo=*-testing update udev libvolume_id

And then reboot computer.
Comment 34 Fedora Update System 2007-07-31 18:51:06 EDT
udev-113-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 35 David Zeuthen 2007-07-31 20:10:28 EDT
*** Bug 250344 has been marked as a duplicate of this bug. ***
Comment 36 William Lovaton 2007-08-04 10:06:25 EDT
(In reply to comment #34)
> udev-113-8.fc7 has been pushed to the Fedora 7 testing repository.  If
problems still persist, please make note of it in this bug report.

Just wanted to say that updating to this version of udev from updates-testing
works for me.

Previously this bug was triggered using a 2GB Kingston Traveler and a 1GB
Trascend, but curiously enough it did work for 4GB Sony Vaio... Go figure!.
Comment 37 Scott R. Godin 2007-08-04 15:33:51 EDT
bug was gone in previous kernel but has returned in 2.6.22.1-41.fc7

again, commenting out the line as suggested above resolves the problem, but I'm 
curious about the back-and-forth waffling with kernel releases affecting, and 
not affecting this issue. 

worked, doesn't work, worked, doesn't work. 

Also one additional issue I spotted was when you plug in more than one usb disk 
(in my case two flash drives) where the first one mounts properly to the 
desktop and the second one never does. 

not sure whether this is related but thought I should mention it. 

With the change above, both drives mount properly and show up on the desktop.
Comment 38 Harald Hoyer 2007-08-06 05:33:34 EDT
# yum --enablerepo=*-testing update udev 
and you should not have to comment out anything...
Comment 39 Fedora Update System 2007-08-06 13:57:31 EDT
udev-113-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 Xion Luhnis 2007-08-07 08:29:43 EDT
(In reply to comment #39)
> udev-113-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems
still persist, please make note of it in this bug report.

I installed the last stable version udev-113-8.fc7 but there are still problems
with usb using kernel 2.6.22.1-41.fc7.

The 05-udev-early.rules "fix" cannot be done because the file only contains :

# sysfs is populated after the event is sent
ACTION=="add", KERNEL=="[0-9]*:[0-9]*", SUBSYSTEM=="scsi",
WAIT_FOR_SYSFS="ioerr_cnt"
Comment 41 Harald Hoyer 2007-08-07 09:15:09 EDT
> The 05-udev-early.rules "fix" cannot be done because the file only contains

???

"skip_wait" was removed from any rules in udev...
Comment 42 Eric LANDES 2007-08-07 17:05:21 EDT
I encountered also a problem with my wireless usb key with the kernel
2.6.22.1-33.fc7, while it worked with kernel 2.6.21-1.3228.
Problem is that it does not work also with the last kernel 2.6.22.1-41.fc7,
together with new udev 113-8.fc7. There is even then a system freeze or crash. 
First time I post, so I dont' know how to reopen a bug...

=========================================================================================================
Case where plugging a wireless USB key (Belkin) works

# uname -a
Linux pc-linux 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:56:37 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux
# rpm -q udev
udev-113-8.fc7

Here, I plug and start the network service which gives : 
# tail -f /var/log/messages
Aug  7 21:51:19 localhost kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  7 21:51:19 localhost dhclient: wmaster0: unknown hardware address type 801
Aug  7 21:51:19 localhost dhclient: wmaster0: unknown hardware address type 801
Aug  7 21:51:19 localhost dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Aug  7 21:51:20 localhost kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Aug  7 21:51:20 localhost kernel: wlan0: duplicate address detected!
Aug  7 21:51:22 localhost dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Aug  7 21:51:23 localhost dhclient: DHCPACK from 192.168.1.1
Aug  7 21:51:23 localhost avahi-daemon[2317]: Joining mDNS multicast group on
interface wlan0.IPv4 with address 192.168.1.11.
Aug  7 21:51:23 localhost avahi-daemon[2317]: New relevant interface wlan0.IPv4
for mDNS.
Aug  7 21:51:23 localhost avahi-daemon[2317]: Registering new address record for
192.168.1.11 on wlan0.IPv4.

# cat /etc/udev/rules.d/05-udev-early.rules |grep ioerr
ACTION=="add", KERNEL=="[0-9]*:[0-9]*", SUBSYSTEM=="scsi",
WAIT_FOR_SYSFS="ioerr_cnt"
# lsusb
Bus 002 Device 005: ID 050d:705c Belkin Components 
Bus 002 Device 002: ID 05e3:0606 Genesys Logic, Inc. 
Bus 002 Device 004: ID 05e3:0606 Genesys Logic, Inc. 
Bus 002 Device 001: ID 0000:0000  
# dmesg
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP xx:xx:xx:xx:xx:xx
wlan0: RX authentication from xx:xx:xx:xx:xx:xx (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP xx:xx:xx:xx:xx:xx
wlan0: RX ReassocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

=========================================================================================================
Case where plugging a wireless USB key (Belkin) does not work

# uname -a
Linux pc-linux 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:21:43 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux
# rpm -q udev
udev-113-8.fc7
# cat /etc/udev/rules.d/05-udev-early.rules |grep ioerr
ACTION=="add", KERNEL=="[0-9]*:[0-9]*", SUBSYSTEM=="scsi",
WAIT_FOR_SYSFS="ioerr_cnt"

Here, I plug the usb key which gives : 
# tail -f /var/log/messages
Aug  7 22:08:29 localhost kernel: usb 2-2.4.4: new high speed USB device using
ehci_hcd and address 5
Aug  7 22:08:29 localhost kernel: usb 2-2.4.4: configuration #1 chosen from 1 choice
Aug  7 22:08:29 localhost kernel: usb 2-2.4.4: reset high speed USB device using
ehci_hcd and address 5
Aug  7 22:08:30 localhost kernel: zd1211rw_mac80211 2-2.4.4:1.0: phy0
Aug  7 22:08:30 localhost kernel: usbcore: registered new interface driver
zd1211rw_mac80211
Aug  7 22:08:30 localhost kernel: zd1211rw_mac80211 2-2.4.4:1.0: firmware
version 4725
Aug  7 22:08:30 localhost kernel: zd1211rw_mac80211 2-2.4.4:1.0: zd1211b chip
050d:705c v4810 high xx-xx-xx AL2230_RF pa0 g--NS
Aug  7 22:08:31 localhost kernel: zd1211rw_mac80211 2-2.4.4:1.0: error
ioread32(CR_REG1): -110
Aug  7 22:08:31 localhost kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  7 22:08:32 localhost dhclient: wmaster0: unknown hardware address type 801

# lsusb
Bus 002 Device 005: ID 050d:705c Belkin Components 
Bus 002 Device 004: ID 05e3:0606 Genesys Logic, Inc. 
Bus 002 Device 002: ID 05e3:0606 Genesys Logic, Inc. 
Bus 002 Device 001: ID 0000:0000  
# dmesg
usb 2-2.4.4: new high speed USB device using ehci_hcd and address 5
usb 2-2.4.4: configuration #1 chosen from 1 choice
usb 2-2.4.4: reset high speed USB device using ehci_hcd and address 5
wmaster0: Selected rate control algorithm 'simple'
zd1211rw_mac80211 2-2.4.4:1.0: phy0
usbcore: registered new interface driver zd1211rw_mac80211
zd1211rw_mac80211 2-2.4.4:1.0: firmware version 4725
zd1211rw_mac80211 2-2.4.4:1.0: zd1211b chip 050d:705c v4810 high xx-xx-xx
AL2230_RF pa0 g--NS
zd1211rw_mac80211 2-2.4.4:1.0: error ioread32(CR_REG1): -110
ADDRCONF(NETDEV_UP): wlan0: link is not ready

Here, I start the network service, but it does not work (stop it with ^C)
# tail -f /var/log/messages
Aug  7 22:09:07 localhost kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  7 22:09:07 localhost dhclient: wmaster0: unknown hardware address type 801
Aug  7 22:09:07 localhost dhclient: wmaster0: unknown hardware address type 801
Aug  7 22:09:07 localhost dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67

Here, I unplug the usb key
# tail -f /var/log/messages
Aug  7 22:09:13 localhost dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Aug  7 22:09:28 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255
port 67 interval 7
Aug  7 22:09:50 localhost kernel: zd1211rw_mac80211 2-2.4.4:1.0:
zd_chip_control_leds error -71
Aug  7 22:09:50 localhost kernel: usb 2-2.4.4: USB disconnect, address 5
Aug  7 22:09:51 localhost kernel: zd1211rw_mac80211 2-2.4.4:1.0:
zd_chip_control_leds error -22
(if I restart the computer here, the restart process prints a lot of
zd_chip_control_leds error -22 and freezes at a "SCSI synchronisation cache" step)

Here, I plug one more time the usb key
# tail -f /var/log/messages
Aug  7 22:10:22 localhost last message repeated 31 times

I then restart the network service, but the system either freeze ou crash
=========================================================================================================
Comment 43 Bastien Nocera 2007-08-08 13:39:17 EDT
*** Bug 251372 has been marked as a duplicate of this bug. ***
Comment 44 Bruce Brackbill 2007-08-09 18:43:59 EDT
works for me again
udev-113-9.fc7
kernel-2.6.22.1-41.fc7

Comment 45 Steve Giess 2007-08-10 09:35:15 EDT
udev updated to udev-113-9.fc7

USB memory now works correctly
Comment 46 Juliano F. Ravasi 2007-08-14 17:43:18 EDT
kernel-2.6.22.1-41.fc7
udev-113-9.fc7

I'm having serious problems trying to use my Motorola V360 phone on current
kernel and udev. It should look like a USB memory stick, but when I plug it:

usb 4-2: new full speed USB device using uhci_hcd and address 3
usb 4-2: configuration #1 chosen from 2 choices
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 5:0:0:0: Direct-Access     Motorola Motorola Phone   2.31 PQ: 0 ANSI: 2
sd 5:0:0:0: [sdc] 990976 512-byte hardware sectors (507 MB)
sd 5:0:0:0: [sdc] Write Protect is off
sd 5:0:0:0: [sdc] Mode Sense: 0b 00 00 08
sd 5:0:0:0: [sdc] Assuming drive cache: write through
sd 5:0:0:0: [sdc] 990976 512-byte hardware sectors (507 MB)
sd 5:0:0:0: [sdc] Write Protect is off
sd 5:0:0:0: [sdc] Mode Sense: 0b 00 00 08
sd 5:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc1
sd 5:0:0:0: [sdc] Attached SCSI removable disk
sd 5:0:0:0: Attached scsi generic sg3 type 0
sd 5:0:0:0: [sdc] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 5:0:0:0: [sdc] Sense Key : Medium Error [current]
sd 5:0:0:0: [sdc] Add. Sense: No additional sense information
end_request: I/O error, dev sdc, sector 990912
printk: 6 messages suppressed.
Buffer I/O error on device sdc, logical block 123864
sd 5:0:0:0: [sdc] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 5:0:0:0: [sdc] Sense Key : Medium Error [current]
sd 5:0:0:0: [sdc] Add. Sense: No additional sense information
end_request: I/O error, dev sdc, sector 990912
Buffer I/O error on device sdc, logical block 123864
sd 5:0:0:0: [sdc] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 5:0:0:0: [sdc] Sense Key : Medium Error [current]
sd 5:0:0:0: [sdc] Add. Sense: No additional sense information
end_request: I/O error, dev sdc, sector 990960
Buffer I/O error on device sdc, logical block 123870

The last 5 lines repeat ad aeternum while the phone is plugged. Icon never shows
up. Using the original F7 kernel works fine.

It seems that something was not quite fixed.

Note You need to log in before you can comment on or make changes to this bug.