Bug 249192 - FlightGear should require SimGear
Summary: FlightGear should require SimGear
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: puretls   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Fabrice Bellet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 249193 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-22 12:21 UTC by Rodd Clarkson
Modified: 2008-01-06 17:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 00:10:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rodd Clarkson 2007-07-22 12:21:10 UTC
Description of problem:

After installing FlightGear it wouldn't run from the Games menu.  I tried
running it in a terminal using fgfs and got the following error message:

[rodd@localhost ~]$ fgfs 
fgfs: error while loading shared libraries: libsgroute-0.3.10.so: cannot open
shared object file: No such file or directory

After installing SimGear this issue resolves itself.

Comment 1 Fabrice Bellet 2007-07-22 13:07:18 UTC
It does require SimGear.

[bellet@monkey rpm]$ sudo rpm -Uhv FlightGear-0.9.10-6.fc7.i386.rpm 
error: Failed dependencies:
        fgfs-base = 0.9.10 is needed by FlightGear-0.9.10-6.fc7.i386
        libsgbucket-0.3.10.so is needed by FlightGear-0.9.10-6.fc7.i386
        libsgdebug-0.3.10.so is needed by FlightGear-0.9.10-6.fc7.i386
        libsgenvironment-0.3.10.so is needed by FlightGear-0.9.10-6.fc7.i386
        libsgephem-0.3.10.so is needed by FlightGear-0.9.10-6.fc7.i386
        libsgio-0.3.10.so is needed by FlightGear-0.9.10-6.fc7.i386
[...]

How did you install FlightGear ? 

Comment 2 Rodd Clarkson 2007-07-23 00:10:22 UTC
Yeah, you're right, this is a major bug with the yum package manager.  Off to
file a bug against this package.

Comment 3 Fabrice Bellet 2008-01-06 17:47:19 UTC
*** Bug 249193 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.