Bug 249194 - yum is upset to find kmdls for old kernel
yum is upset to find kmdls for old kernel
Status: CLOSED DUPLICATE of bug 330711
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 08:34 EDT by Brian Millett
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 21:38:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of trying to update the kernel from 2.6.23.1-49.fc8 to 2.6.23.8-63.fc8 (1.98 KB, text/plain)
2007-12-06 19:45 EST, John Guthrie
no flags Details

  None (edit)
Description Brian Millett 2007-07-22 08:34:27 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[bpm]$ rpm -qa | grep yum
yum-allowdowngrade-1.1.5-1.fc7
yum-skip-broken-1.1.5-1.fc7
yum-metadata-parser-1.1.0-2.fc7
yum-plugin-kmdl-0.7-9.fc7
yum-utils-1.1.5-1.fc7
yum-downloadonly-1.1.5-1.fc7
yum-3.2.1-1.fc7
yum-fastestmirror-1.1.5-1.fc7
yum-kernel-module-1.1.5-1.fc7


How reproducible:

right now every time

Steps to Reproduce:
1.
2.yum update
3.
  
Actual results:

Resolving Dependencies
--> Running transaction check
---> Package kernel-devel.i686 0:2.6.22.1-27.fc7 set to be updated
---> Package kernel-doc.noarch 0:2.6.22.1-27.fc7 set to be updated
filelists.sqlite.bz2      100% |=========================|  33 kB    00:01     
---> Package kernel.i686 0:2.6.22.1-27.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.22.1-27.fc7 set to be updated
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
nvidia-graphics100.14.11-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
fuse-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
nvidia-graphics100.14.09-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
ipw3945-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
ieee80211-kmdl-2.6.21-1.3228.fc7
--> Finished Dependency Resolution
---> Package ipw3945-kmdl-2.6.22.1-27.fc7.i686 0:1.2.0-18.3.fc7 set to be installed
---> Package nvidia-graphics100.14.09-kmdl-2.6.22.1-27.fc7.i686
1:100.14.09-90.fc7 set to be installed
---> Package nvidia-graphics100.14.11-kmdl-2.6.22.1-27.fc7.i686
1:100.14.11-91.fc7 set to be installed
--> Running transaction check
---> Package ipw3945-kmdl-2.6.22.1-27.fc7.i686 0:1.2.0-18.3.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.22.1-27.fc7 set to be updated
---> Package nvidia-graphics100.14.11-kmdl-2.6.22.1-27.fc7.i686
1:100.14.11-91.fc7 set to be updated
---> Package kernel-doc.noarch 0:2.6.22.1-27.fc7 set to be updated
---> Package kernel.i686 0:2.6.22.1-27.fc7 set to be updated
---> Package nvidia-graphics100.14.09-kmdl-2.6.22.1-27.fc7.i686
1:100.14.09-90.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.22.1-27.fc7 set to be updated
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
fuse-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
nvidia-graphics100.14.09-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
nvidia-graphics100.14.11-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
ipw3945-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3228.fc7 for package:
ieee80211-kmdl-2.6.21-1.3228.fc7
--> Processing Dependency: ieee80211-kmdl-2.6.22.1-27.fc7 >= 1.1.11 for package:
ipw3945-kmdl-2.6.22.1-27.fc7
--> Finished Dependency Resolution
Error: Unresolveable requirement /boot/vmlinuz-2.6.21-1.3228.fc7 for
fuse-kmdl-2.6.21-1.3228.fc7
Error: Unresolveable requirement /boot/vmlinuz-2.6.21-1.3228.fc7 for
nvidia-graphics100.14.09-kmdl-2.6.21-1.3228.fc7
Error: Unresolveable requirement /boot/vmlinuz-2.6.21-1.3228.fc7 for
nvidia-graphics100.14.11-kmdl-2.6.21-1.3228.fc7
Error: Unresolveable requirement /boot/vmlinuz-2.6.21-1.3228.fc7 for
ipw3945-kmdl-2.6.21-1.3228.fc7
Error: Unresolveable requirement /boot/vmlinuz-2.6.21-1.3228.fc7 for
ieee80211-kmdl-2.6.21-1.3228.fc7
Error: Missing Dependency: ieee80211-kmdl-2.6.22.1-27.fc7 >= 1.1.11 is needed by
package ipw3945-kmdl-2.6.22.1-27.fc7

Expected results:

Should update the kernel and ignore the older kernel requirements

Additional info:

This email from Axil Thimm
--
No, it's yum bug: The kernel was removed in Fedora's repo and now yum
is upset to find kmdls for that kernel. There is a plugin that fixes
this behaviour.

Currently Fedora withdraws kernels too fast, e.g. updates only
contains one kernel. So the moment a new kernel gets into the repo you
get the old obsolted and yum is confused. It would be nice if Fedora
would keep at least two kernels (the latest may have some regression
after all) and also fix yum.
Comment 1 Paul Johnson 2007-07-24 10:54:54 EDT
This is a very serious bug.  I turned off the installonlyn completely, and yum
still refuses to install the new kernel for absolutely no reason.  I do not want
it to remove the old kernel, I don't want to break those dependencies.  I wish
yum allowed a --nodeps option like rpm allows.  I could circumvent this.

---> Package gdm.x86_64 1:2.18.3-1.fc7 set to be updated
--> Processing Dependency: kernel-x86_64 = 2.6.21-1.3228.fc7 for package:
openafs-kernel
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-x86_64 = 2.6.21-1.3228.fc7 is needed by
package openafs-kernel
Comment 2 Brian Millett 2007-07-24 11:49:03 EDT
I finally was able to update by installing yum-skip-broken plugin, then changing
the /etc/yum/pluginconf.d/skip-broken.conf => check_always = 1 value.

Shouldn't have to install some plugin to bandaid yum to work.
Comment 3 Seth Vidal 2007-07-24 12:27:03 EDT
(In reply to comment #1)
> This is a very serious bug.  I turned off the installonlyn completely, and yum
> still refuses to install the new kernel for absolutely no reason.  I do not 

What version of yum are you using?
Comment 4 John Guthrie 2007-07-29 00:00:50 EDT
I am finding that this is happening with yum-3.2.1-1.fc7.  I have even been
seeing this behavior when I run

yum install kernel-2.6.22.1-33.fc7.i686

Here is the output:

Loading "presto" plugin
Loading "refresh-updatesd" plugin
Loading "protectbase" plugin
Loading "fedorakmod" plugin
Loading "changelog" plugin
Loading "skip-broken" plugin
Loading "security" plugin
Loading "kernel-module" plugin
Loading "priorities" plugin
Loading "tsflags" plugin
Loading "downloadonly" plugin
Setting up Install Process
Parsing package install arguments
Setting up Presto
Reading Presto metadata in from local files
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository protections
0 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
filelists.sqlite.bz2      100% |=========================| 6.4 MB    00:40     
---> Package kernel.i586 0:2.6.21-1.3194.fc7 set to be updated
---> Package kernel.i686 0:2.6.22.1-33.fc7 set to be updated
--> Processing Dependency: /boot/vmlinuz-2.6.22.1-27.fc7 for package:
ieee80211-kmdl-2.6.22.1-27.fc7
--> Processing Dependency: kernel-i686 = 2.6.22.1-27.fc7 for package: kmod-em8300
--> Processing Dependency: kernel-i686 = 2.6.22.1-27.fc7 for package: kmod-sysprof
--> Processing Dependency: /boot/vmlinuz-2.6.22.1-27.fc7 for package:
ipw3945-kmdl-2.6.22.1-27.fc7
--> Finished Dependency Resolution
Error: Unresolveable requirement /boot/vmlinuz-2.6.22.1-27.fc7 for
ieee80211-kmdl-2.6.22.1-27.fc7
Error: Unresolveable requirement kernel-i686 = 2.6.22.1-27.fc7 for kmod-em8300
Error: Unresolveable requirement kernel-i686 = 2.6.22.1-27.fc7 for kmod-sysprof
Error: Unresolveable requirement /boot/vmlinuz-2.6.22.1-27.fc7 for
ipw3945-kmdl-2.6.22.1-27.fc7

What's seems to be really strange is that it only wants to remove the previous
(or maybe it's the currently running) kernel.  I had this problem before when
2.6.22.1-27.fc7 came out.  It was wanting to remove kernel-2.6.21-1.3228, but
not kernel-2.6.21-1.3194.  Now it is wanting to remove 2.6.22.1-27, but none of
the others.
Comment 5 John Guthrie 2007-07-29 00:55:18 EDT
Just to be thorough, I tried booting to 2.6.21-1.3228, but the above command is
still wanting to remove kernel 2.6.22.1-27, so it doesn't have anything to do
with the running kernel.  It just wants to remove the last installed kernel, or
perhaps the latest version kernel.
Comment 6 John Guthrie 2007-08-07 08:51:16 EDT
I should also note that this is affecting the yum-downloadonly package as well.
 If I try to run something like

yum --downloadonly install kernel

Then I end up getting the same error message as above.  I would expect that it
would actually download the package, but not install it, since downloading
shouldn't be a problem.
Comment 7 Seth Vidal 2007-08-08 02:22:51 EDT
downloadonly will only download if it can resolve the deps. It doesn't download
just any old thing. so i expect it to do that part, at least.
Comment 8 Jeremy Katz 2007-09-13 14:46:46 EDT
Does this still happen with yum-3.2.5?
Comment 9 Brian Millett 2007-09-13 17:17:51 EDT
yes.  yum 3.2.5 fixed a broken skip-broken plugin, but the problem still exists:

yum-3.2.5-1.fc7

Resolving Dependencies
--> Running transaction check
---> Package kernel-doc.noarch 0:2.6.22.5-76.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.22.5-76.fc7 set to be updated
---> Package kernel.i686 0:2.6.22.5-76.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.22.5-76.fc7 set to be updated
--> Processing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 for package:
ipw3945-kmdl-2.6.22.4-65.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 for package:
ieee80211-kmdl-2.6.22.4-65.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 for package:
fuse-kmdl-2.6.22.4-65.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 for package:
nvidia-graphics100.14.09-kmdl-2.6.22.4-65.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 for package:
nvidia-graphics100.14.11-kmdl-2.6.22.4-65.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 for package:
gspcav1-kmdl-2.6.22.4-65.fc7
--> Finished Dependency Resolution
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
ipw3945-kmdl-2.6.22.4-65.fc7
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
fuse-kmdl-2.6.22.4-65.fc7
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
ieee80211-kmdl-2.6.22.4-65.fc7
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
nvidia-graphics100.14.09-kmdl-2.6.22.4-65.fc7
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
nvidia-graphics100.14.11-kmdl-2.6.22.4-65.fc7
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
gspcav1-kmdl-2.6.22.4-65.fc7
Comment 10 Roderick Johnstone 2007-09-21 14:22:35 EDT
Although the yum-skip-broken plugin used to fix this problem for me, with the
latest yum and plugins even that workaround seems to be broken:

Installed Packages
yum.noarch                               3.2.5-1.fc7            installed
yum-metadata-parser.x86_64               1.1.0-2.fc7            installed
yum-plugin-kmdl.noarch                   0.7-9.fc7              installed
yum-skip-broken.noarch                   1.1.7-1.fc7            installed
yum-utils.noarch                         1.1.7-1.fc7            installed

linux> yum --skip-broken update 
.
.
.
--> Finished Dependency Resolution
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
nvidia-graphics100.14.09-kmdl-2.6.22.4-65.fc7
Error: Missing Dependency: /boot/vmlinuz-2.6.22.4-65.fc7 is needed by package
nvidia-graphics100.14.11-kmdl-2.6.22.4-65.fc7
Comment 11 John Guthrie 2007-12-06 19:45:54 EST
Created attachment 280301 [details]
Output of trying to update the kernel from 2.6.23.1-49.fc8 to 2.6.23.8-63.fc8

It looks as though this bug is still with us in F8.  I'm attaching some output
from trying to upgrade my kernel from 2.6.23.1-49.fc8 to 2.6.23.8-63.fc8.  It
ends with the following:

--> Running transaction check
--> Processing Dependency: kernel-i686 = 2.6.23.1-49.fc8 for package:
kmod-sysprof
--> Processing Dependency: kernel-i686 = 2.6.23.1-49.fc8 for package:
kmod-em8300
---> Package kernel.i686 0:2.6.23.8-63.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.23.1-49.fc8 is needed by package
kmod-em8300
Error: Missing Dependency: kernel-i686 = 2.6.23.1-49.fc8 is needed by package
kmod-sysprof

When I first started with F8, I only had 2.6.23.1-42.fc8.  Then I upgraded to
2.6.23.1-49.fc8 with no problem.  Now, once again it is trying to remove the
most recently installed kernel.  I find it interesting that this bug waited
until the second kernel upgrade to rear its ugly head again.
Comment 12 John Guthrie 2007-12-06 19:47:21 EST
In case it wasn't clear from the above discussion, (Although it is in the
attachment.) this was with yum-3.2.7-2.fc8.
Comment 13 Seth Vidal 2007-12-06 21:38:31 EST

*** This bug has been marked as a duplicate of 330711 ***

Note You need to log in before you can comment on or make changes to this bug.