Bug 249209 - ATAPI cdrom drive fails to work
Summary: ATAPI cdrom drive fails to work
Status: CLOSED DUPLICATE of bug 242536
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-22 17:20 UTC by Andrew Clayton
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 18:58:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (18.64 KB, text/plain)
2007-07-22 17:22 UTC, Andrew Clayton
no flags Details
Output of lspci -vvxxx (21.18 KB, text/plain)
2007-09-23 18:14 UTC, Andrew Clayton
no flags Details

Description Andrew Clayton 2007-07-22 17:20:48 UTC
Description of problem:

The internal CD drive has not worked since upgrading from FC6 to F7. See bug #244521

Some relevant dmesg below (I'll attach the full thing)

scsi scan: 96 byte inquiry failed.  Consider BLIST_INQUIRY_36 for this device
scsi 1:0:0:0: CD-ROM            QSI      CD-ROM SCR-242   CJCC PQ: 0 ANSI: 5

Upon inseting a cdrom into the drive I get this in dmesg.

end_request: I/O error, dev sr0, sector 4
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 4
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 4
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 4
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 4
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 4
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr0, sector 4
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : No Sense [current] 
sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)


Tried 3 different data cd's.


Version-Release number of selected component (if applicable):

kernel-2.6.22.1-27.fc7.i686

How reproducible:

100%

Steps to Reproduce:
1. Insert a cd into driver
2.
3.
  
Actual results:

Lots of errros in dmesg

Expected results:

Mounted cd

Additional info:

Comment 1 Andrew Clayton 2007-07-22 17:22:52 UTC
Created attachment 159749 [details]
dmesg log

dmesg output from laptop

Comment 2 Victor Lorenz 2007-07-29 01:24:10 UTC
Can open CD or DVD directory. Shows files but files cannot be opened. Using
Pioneer DVR-109. Problem is both i386 and x86_64. Files can be opened with same
drive under Windows. 

Comment 3 stephane ploix 2007-08-03 20:08:43 UTC
I have the same problem with my laptop with the CD/DVD RW drive. Drive reference
by lsscsi:  [3:0:0:0]    cd/dvd  Slimtype DVDRW SOSW-833S  VS04  /dev/scd0.
My kernel is: Linux host 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:21:43 EDT 2007
x86_64 x86_64 x86_64 GNU/Linux. But I had the same under the other distributed
kernels.

Drive was working perfectly under FC5 & FC6 but since I have upgrade to F7, I've
got problems. CDROMs are not detected. When I boot with a CDROM in the drive, it
is detected but it fails to open files.

In dmesg, I got many messages like this:
 ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata4.00: cmd a0/00:00:00:00:20/00:00:00:00:00/a0 tag 0 cdb 0x0 data 0
         res 40/00:03:00:00:20/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata4: soft resetting port
ata4.00: configured for PIO0
ata4: EH complete


Comment 4 Christopher Brown 2007-09-20 11:04:29 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 5 Victor Lorenz 2007-09-20 12:03:05 UTC
I replaced my DVD drive and it works fine both in read and write mode so may
have been a hardware problem.

Comment 6 Christopher Brown 2007-09-20 12:41:43 UTC
Okay, thanks for the update Victor. I can't be sure yours is a dupe of Andrew's
as the hardware is different however so I'll leave this open in the hope that he
can add something.

Cheers
Chris

Comment 7 Andrew Clayton 2007-09-20 13:19:45 UTC
I'll re-check tonight.


Comment 8 Andrew Clayton 2007-09-21 08:52:52 UTC
OK, problem still persists with 2.6.22.5-76.fc7

It still boots a Fedora 7 boot.iso cd OK.


Comment 9 Christopher Brown 2007-09-21 09:26:27 UTC
Okay, thanks for the update Andrew. If you can attach the output from the
following commands:

# lspci -vvxxx

I'll re-assign to the relevant maintainer for them to have a look. When
attaching please make sure to use text/plain.

You could also try booting with acpi=off as a boot parameter and see if this
helps. From your dmesg output I notice that there is a bug with your dock
driver, though I'm not sure this is related.

Cheers
Chris

Comment 10 Andrew Clayton 2007-09-21 09:38:38 UTC
Will do, may be Monday before I can post the info though.

I noticed the dock problem, but seeing as I don't have any dock capabilities I
just ignored it.

Cheers,
Andrew

Comment 11 Andrew Clayton 2007-09-23 18:13:14 UTC
Booting with acpi=off didn't help.

Comment 12 Andrew Clayton 2007-09-23 18:14:23 UTC
Created attachment 203551 [details]
Output of lspci -vvxxx

Comment 13 Christopher Brown 2007-09-23 18:58:33 UTC
Thanks Andrew. I'm setting this as a dupe of bug #242536. Same hardware, same
driver, same error.

*** This bug has been marked as a duplicate of 242536 ***

Comment 14 Victor Lorenz 2007-10-11 15:27:29 UTC
Started to have problems writing to DVDs again. Based on info found on the web
replaced the 40 wire connector with an 80 wire connector. Seems to have solved
the problem. (May have been the issue all along in my case i.e. not being able
to boot iso etc.)


Note You need to log in before you can comment on or make changes to this bug.