Bug 249302 - Init script in quagga errata 2007:0563 needs a few fixes and improvements
Summary: Init script in quagga errata 2007:0563 needs a few fixes and improvements
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: quagga   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 243143
TreeView+ depends on / blocked
 
Reported: 2007-07-23 16:06 UTC by David Kovalsky
Modified: 2014-03-31 23:44 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0563
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 20:10:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0563 normal SHIPPED_LIVE quagga bug fix update 2007-11-07 23:09:25 UTC

Description David Kovalsky 2007-07-23 16:06:36 UTC
Description of problem:
 - typo on line 19 in /etc/init.d/bgpd: 'otpin'
 - unable to shut down bgpd if networking is turned off
   in /etc/sysconfig/network since networking check on line
   22 terminates the script sooner with return=1 (this is not only a problem 
   of start, same with status etc.)
 - line 7 specifies a bogus config file

Please note that this is only in /etc/init.d/bgpd, other scripts in the quagga
package may and probably will suffer from similar issues.

Version-Release number of selected component (if applicable):
quagga-0.98.6-4.el5

Comment 1 RHEL Product and Program Management 2007-07-23 16:26:22 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Martin Bacovsky 2007-07-24 10:38:12 UTC
This issue should be fixed in quagga-0.98.6-5.el5

Comment 7 errata-xmlrpc 2007-11-07 20:10:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0563.html



Note You need to log in before you can comment on or make changes to this bug.