Bug 249361 - Unhanlded exception while updating Fedora 7
Unhanlded exception while updating Fedora 7
Status: CLOSED DUPLICATE of bug 249374
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-23 18:07 EDT by Andrea
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 22:24:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea 2007-07-23 18:07:08 EDT
While updating Fedora 7 to the latest packages using pirut
23-07-2007, around 23:00 BST
I got this unhandled exception. It happened only once/

Component: Software Updater
Summary: TBedf28128 Progress.py:85:callback:TypeError: unsupported operand
type(s) for /: 'int' and 'NoneType'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 726, in
applyChanges
    self.runTransaction(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 701, in
runTransaction
    tserrors = yum.YumBase.runTransaction(self, tsprog)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.5/site-packages/pirut/Progress.py", line 85, in callback
    self.progress.set_fraction(self.num / self.total * (1 - PREP) + PREP)
TypeError: unsupported operand type(s) for /: 'int' and 'NoneType'

Local variables in innermost frame:
what: 8
h: (<rpm.hdr object at 0xb856e90>,
u'//var/cache/yum/updates/packages/kdesdk-3.5.7-6.fc7.i386.rpm')
self: <pirut.Progress.PirutTransactionProgress instance at 0xba92fac>
logmsg:
amount: 0
user:
total: 0
PREP: 0.25
Comment 1 Jeremy Katz 2007-07-24 16:38:59 EDT
Is this reproducible?
Comment 2 Andrea 2007-07-25 18:35:02 EDT
Not really.
I've tried to update kdesdk again but I did not get any error.
Comment 3 Jeremy Katz 2007-07-25 22:24:20 EDT

*** This bug has been marked as a duplicate of 249374 ***

Note You need to log in before you can comment on or make changes to this bug.