Bug 249374 - kdesdk: don't use %pretrans (borks pup, anaconda, ...)
kdesdk: don't use %pretrans (borks pup, anaconda, ...)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 249361 249375 249377 249378 249379 249429 249447 249496 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 00:26 EDT by stephen brennom
Modified: 2007-11-30 17:12 EST (History)
10 users (show)

See Also:
Fixed In Version: 3.5.7-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 01:20:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
file generated by updater/bugzilla (1.11 KB, application/octet-stream)
2007-07-24 00:30 EDT, stephen brennom
no flags Details

  None (edit)
Description stephen brennom 2007-07-24 00:26:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
saved error information file is attached

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1.run updater with today's updates (10 on my machine)
2.
3.

Actual Results:
updater downloaded all updates and started installing them. the install took a lomg time and then popped up an error message. 9 of 10 updates appear to have installed correctly. gdm packages did not install.

Expected Results:
correct install of all 10 updates

Additional info:
Comment 1 stephen brennom 2007-07-24 00:30:43 EDT
Created attachment 159829 [details]
file generated by updater/bugzilla

this is the file the updater prompted me to save
Comment 2 Jeremy Katz 2007-07-24 17:30:26 EDT
This is caused by kdesdk adding a %pretrans scriptlet which substantial chunks
of the distro aren't prepared for and can't be (for one thing, think about this
on a new install -- there *is* no bash to run the scriptlet at that point).
Comment 3 Jeremy Katz 2007-07-24 17:32:30 EDT
*** Bug 249375 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2007-07-24 17:32:57 EDT
*** Bug 249377 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2007-07-24 17:33:00 EDT
*** Bug 249379 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2007-07-24 17:33:17 EDT
*** Bug 249378 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2007-07-24 17:33:35 EDT
*** Bug 249447 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2007-07-24 17:34:09 EDT
*** Bug 249429 has been marked as a duplicate of this bug. ***
Comment 9 Rex Dieter 2007-07-24 17:52:27 EDT
fyi, root cause is kdesdk scriptlet:
# trick to replace a dir by a symlink -- Rex
%pretrans
if [ ! -L  %{_docdir}/HTML/en/cervisia/common ]; then
  rm -rf   %{_docdir}/HTML/en/cervisia/common
fi
exit 0

Ugh, not much of a successful trick, will need to revert.
Comment 10 Rex Dieter 2007-07-24 18:13:32 EDT
%changelog
* Fri Jul 24 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 3.5.7-7
- don't use %pretrans (#249374)
Comment 11 Fedora Update System 2007-07-25 01:20:14 EDT
kdesdk-3.5.7-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Jeremy Katz 2007-07-25 09:42:31 EDT
*** Bug 249496 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2007-07-25 22:24:28 EDT
*** Bug 249361 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.