Bug 249367 - Graphical install fails with nVidia Quadro NVS 140m
Graphical install fails with nVidia Quadro NVS 140m
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-07-23 20:11 EDT by Russell Harrison
Modified: 2010-10-22 12:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.1.3-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/tmp/ramfs/X.log from graphical install (26.52 KB, text/plain)
2007-07-24 12:27 EDT, Russell Harrison
no flags Details
Xorg.0.log for nv driver when it freezes (46.12 KB, text/plain)
2007-08-28 18:58 EDT, Matthew Saltzman
no flags Details

  None (edit)
Description Russell Harrison 2007-07-23 20:11:42 EDT
Description of problem:
When attempting to do a graphical install on a Lenovo ThinkPad T61 Anaconda
fails starting xorg and falls back to a vnc install.

How reproducible:

Additional info:
Right before Anaconda fails I briefly see the message "NVidia Corporation
unknown 0429"

I also had the problem with a respin I made using revisor today.

After the install doing a telinit 5 gives a blank screen when X attempts to
start, and I'm unable to switch back to a terminal. 

lspci shows the device as:
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0429 (rev a1)
Comment 1 Chris Lumens 2007-07-24 09:41:29 EDT
Please attach /tmp/ramfs/X.log to this bug report.
Comment 2 Russell Harrison 2007-07-24 12:27:11 EDT
Created attachment 159865 [details]
/tmp/ramfs/X.log from graphical install
Comment 3 Russell Harrison 2007-07-24 12:30:18 EDT
/tmp/ramfs/X.log attached
Comment 4 Adam Jackson 2007-08-27 12:07:37 EDT
Yeah, that's an nv driver bug alright.  It should be fixed in newer nv drivers,
but I haven't pushed an nv update for F7 in a while.  I'll do that now.
Comment 5 Fedora Update System 2007-08-27 17:44:16 EDT
xorg-x11-drv-nv-2.1.3-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Matthew Saltzman 2007-08-28 18:57:24 EDT
The card seems to be recognized now, but when X starts, the system freezes solid
and must be powered off to clear.

Xorg.0.log attached below.
Comment 7 Matthew Saltzman 2007-08-28 18:58:52 EDT
Created attachment 177501 [details]
Xorg.0.log for nv driver when it freezes
Comment 8 Adam Jackson 2007-09-06 17:19:28 EDT
(II) NV(0): Modeline "1280x800"x0.0   69.30  1280 0 0 0  800 0 0 0 (0.0 kHz)

Somehow I don't think that's okay.
Comment 9 Matthew Saltzman 2007-09-06 17:47:02 EDT
OK but how did it get there and what can I do to fix it?  (Or is it even my

Turns out the system doesn't lock up completely, but the display does.  The
backlight is on but the screen is blank.  I can still reboot with CTRL-ALT-F1

The behavior is the same after system-config-display --reconfig.

The vesa driver appears to work fine.  The NVidia binary driver also appears to
work fine, except that the brightness adjustment doesn't work.
Comment 10 Matthew Saltzman 2007-09-27 12:15:25 EDT
Still a problem in f8-test2 xorg-x11-drv-nv-2.1.5-1.fc8.  Also a problem with
the nouveau driver.  
Comment 11 Adam Jackson 2007-09-27 13:51:09 EDT
It's not your fault.  I was just commenting for my own benefit.  And on
rereading the code I think it's fine and there's just some other issue.  Looking
into it.
Comment 12 Rob Wilmoth 2007-10-25 11:39:52 EDT
I'm having the same problem in F8. Is there anything i can do to assist? Running
F-8 Test 2, xorg-x11-drv-nv-2.1.5-2.fc8
Comment 13 Karl F. Larsen 2007-10-28 13:02:42 EDT
I have a small computer full of Nvidia things. My VGA device lspci found is this:

00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce 6100] (rev a2)
I think it might be newer than yours. My point is to say I have installed 2
versions of F7 on this computer and both were done with full video. Alas the
image was not centered on the screen but it worked.

Once installed the X windows is even more off center and supports just 640x480
image. After finding the Nvidia drivers for Linux then I can get a big image
with millions of colors. 

There are a bunch of differnet Nvidia video hardware out there.

Comment 14 Matěj Cepl 2007-10-31 12:18:25 EDT
Rob, could you please re-test with the latest updates for Rawhide. Apparently
similar bug 349201 got resolved now.
Comment 15 Matthew Saltzman 2007-11-01 10:08:03 EDT
Still fails for me with fully updated F8T3, as described in Comment #9.
Comment 16 Russell Harrison 2007-11-05 09:26:00 EST
The same problem is still there in the rawhide livecd I generated on Sunday
November the 4th.  It should be pretty close to F8-rc3.  I can only boot the
livecd if I add xdriver=vesa to the kernel command line.

Should we clone this bug to F8 since the problem exist in both versions and
rawhide is essentially F8 right now?
Comment 17 Fedora Update System 2007-12-03 06:41:15 EST
xorg-x11-drv-nv-2.1.3-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Matthew Saltzman 2007-12-03 09:56:45 EST
xorg-x11-drv-nv-2.1.5-2.fc8 appears to work in F8.  Hibernate still doesn't work
for that driver, but that's probably a different bug.

Any chance of an errata for RHEL 5?  There is currently *no* driver there that
works for this card--not even VESA.
Comment 19 Matthew Saltzman 2007-12-03 11:48:12 EST
I'm sorry, I was wrong.  xorg-x11-drv-nv-2.1.5-2.fc8 does *not* work for f8. 
Could we have a release for F8 also?  Or do I need to actually clone this bug?

Comment 21 Matthew Saltzman 2008-01-13 12:40:53 EST
Just installed xorg-x11-drv-nv-2.1.6-1.fc8.x86_64 from F* updates-testing, and
it works, sort of.

The display does operate now.  But there are a few issues I've encountered:

(1) System-config-display hardware tab and lspci still report that the video
card is an "nVidia Corporation Unknown device 0429.

(2) When set to use "millions of colors", the default F8 background gradient is
visible as a series of distinct bands, not a smoothly varying gradient.

(3) I have not found a set of quirks for pm-suspend that will restore the display.

Suspend doesn't work at all, in fact (see bug #254214), but when the machine
cycles itself out of suspend mode, the display is black.  Switching to a VC does
not bring it back.  The caps-lock key does not toggle the LED, but the keyboard
works and I can reboot the machine with <ctrl>-<alt>-<F1>, <ctrl>-<alt>-<del>. 
I tried quirks s3-mode; s3-mode and s3-bios; and s3-mode, s3-bios, and
vbemode-restore, as well as no quirks at all, and none of those worked.  (I have
not tried hibernating yet.  I conjectured that if I could get a set of quirks
that worked for suspend, it would work for hibernate as well.)
Comment 22 Bug Zapper 2008-05-14 09:38:52 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Bug Zapper 2008-06-16 21:56:57 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.