Bug 249378 - During Update => software updater fails
Summary: During Update => software updater fails
Status: CLOSED DUPLICATE of bug 249374
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i586 Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-24 06:27 UTC by Marcel Bariou
Modified: 2014-01-21 22:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 21:33:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marcel Bariou 2007-07-24 06:27:04 UTC
During Software Update 
Component Software Updater
Summary: TBedf28128 Progress.py:85:callback:TypeError: unsupported operand
type(s) for /: 'int' and 'NoneType'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 726, in
applyChanges
    self.runTransaction(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 701, in
runTransaction
    tserrors = yum.YumBase.runTransaction(self, tsprog)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.5/site-packages/pirut/Progress.py", line 85, in callback
    self.progress.set_fraction(self.num / self.total * (1 - PREP) + PREP)
TypeError: unsupported operand type(s) for /: 'int' and 'NoneType'

Local variables in innermost frame:
what: 8
h: (<rpm.hdr object at 0xd8a3020>,
u'//var/cache/yum/updates/packages/kdesdk-3.5.7-6.fc7.i386.rpm')
self: <pirut.Progress.PirutTransactionProgress instance at 0x9e0356c>
logmsg: 
amount: 0
user: 
total: 0
PREP: 0.25

Comment 1 Jeremy Katz 2007-07-24 21:33:01 UTC

*** This bug has been marked as a duplicate of 249374 ***


Note You need to log in before you can comment on or make changes to this bug.