Bug 249379 - pup backtrace when updating
pup backtrace when updating
Status: CLOSED DUPLICATE of bug 249374
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 02:30 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 17:32:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-07-24 02:30:07 EDT
Description of problem:
pup is giving me a backtrace when I try to update packages.

Version-Release number of selected component (if applicable):
pirut-1.3.8-1.fc8
pirut-1.3.9-1.fc8

How reproducible:
every time

Steps to Reproduce:
1. install recent fedora devel
2. run pup
  
Actual results:
2. during update get a python backtrace:

Component: pirut
Summary: TBedf28128 Progress.py:85:callback:TypeError: unsupported operand
type(s) for /: 'int' and 'NoneType'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 743, in
applyChanges
    self.runTransaction(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 717, in
runTransaction
    tserrors = yum.YumBase.runTransaction(self, tsprog)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.5/site-packages/pirut/Progress.py", line 85, in callback
    self.progress.set_fraction(self.num / self.total * (1 - PREP) + PREP)
TypeError: unsupported operand type(s) for /: 'int' and 'NoneType'

Local variables in innermost frame:
what: 8
h: (<rpm.hdr object at 0xc2682c0>,
u'//var/cache/yum/development/packages/rsyslog-1.17.1-1.fc8.i386.rpm')
self: <pirut.Progress.PirutTransactionProgress instance at 0xc1eb84c>
logmsg: 
amount: 0
user: 
total: 0
PREP: 0.25


Expected results:
no errors

Additional info:
The machine is left in a broken partial state: easiest just to reinstall.
yum upgrade works just fine.
Comment 1 Jeremy Katz 2007-07-24 17:32:50 EDT

*** This bug has been marked as a duplicate of 249374 ***

Note You need to log in before you can comment on or make changes to this bug.