Bug 249420 - wifi wireless default configuration may connect to wrong network
wifi wireless default configuration may connect to wrong network
Status: CLOSED DUPLICATE of bug 374281
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 12:24 EDT by Douglas Campbell
Modified: 2014-03-16 23:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 12:32:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Campbell 2007-07-24 12:24:23 EDT
Description of problem:
wifi wireless default/onfirstboot configuration may connect to wrong network.

Version-Release number of selected component (if applicable):


How reproducible:
Upon startup after initial install, and every reboot thereafter until changed.

Steps to Reproduce:
1. Install F7 on laptop containing recognized wifi device
2. After install, boot laptop

  
Actual results:
After first boot, and every boot thereafter, F7 enables laptop's ethernet
connector and its wifi adapter.  The wifi adapter automatically connects (in
"manager" mode) to the first nonsecure network it discovers, and configures
thereafter to connect to that network.  In my case, that is a network run by one
of my neighbors, not mine (which is "secure").  The computer immediately began
using the resources it discovered this way.

Expected results:
At a minimum, F7 should not enable the wifi adaptor by default.
At a maximum, F7 should offer to configure the wifi adaptor either during
install or when it is first used.

Compare to Windows Vista, which at least asks which network to connect to before
 enabling the wireless adaptor and doing so.

Additional info:
All available updates to FC7 were applied after the problem was noted.  No
change in behavior after updates applied (as expected).

My computer is an HP dv9033cl, which has integrated wireless and gigabit
ethernet controllers, both of which are recognized by FC7.

The wireless card was auto-configured by FC7 as the default route to the
internet.  I failed to notice that the wireless card was enabled, and configured
the ethernet adapter at a local address (192.168.7.xxx).  Since I had manually
configured for routing through my ethernet adapter to the internet via my
gateway host on (192.168.0.xxx), no packets apparently made it onto the
internet, because my neighbor's wifi had configured my wireless via dhcp at
address (192.168.1.xxx), and designated the wireless network as the default
route.  Therefore, packets destined for my ethernet gateway machine at
(192.168.0.xxx) were routed onto the 192.168.1.xxx (wifi) network.  When I
removed the routing data, I was able to access the internet via my neighbor's
box.  Had I not blindly configured the ethernet adapter during firstboot, I
would have been able to use my neighbor's network "out of the box".

Additionally, disabling the wifi network did not remove its route from the
routing tables.  Although ifconfig/iwconfig showed no wlan0 adapter, netstat -r did.

By the way, it took a lot of work to configure fc6 to use my wifi
(downloading/compiling kernel modules) -- it's really cool that fc7 was able to
access it out of the box.

I have repaired my instance of the problem by configuring the wifi adapter via
the network manager to use my essid and key.
Comment 1 Dan Williams 2008-02-12 09:27:01 EST
-> initscripts

Also as a note, even if the 'network' service doesn't set the card up, many
Linux drivers automatically connect to open networks by default.  So it's not
just a distro thing, it's also a kernel driver thing.
Comment 2 Bill Nottingham 2008-02-12 12:32:52 EST
This was fixed in an update to Fedora 8; initial wireless device configuration
no longer configures devices to be brought up by default. Of course, if they
have already been configured that way (such as in the Fedora 7 installer), they
will still be enabled by default.


*** This bug has been marked as a duplicate of 374281 ***

Note You need to log in before you can comment on or make changes to this bug.