Bug 374281 - Unconfigured wireless devices should not be used
Unconfigured wireless devices should not be used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 249420 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 23:30 EST by Pavel Roskin
Modified: 2014-03-16 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.79.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:55:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Roskin 2007-11-09 23:30:15 EST
Description of problem:

A system was configured with static IP and a specific DNS server on the ethernet
port.  Although there is an Atheros wireless card in that system, I was neither
told that it was there nor to configure it.  When I booted the system, I
discovered that it's not connected to the internet.  It turned out that the
unconfigured wireless interface was brought up and configured with dhclient. 
The wireless device associated to some access point and received a different
gateway address.  Also, /etc/resolv.conf was overwritten.

Version-Release number of selected component (if applicable):
8.60-1

How reproducible:
always

Steps to Reproduce:
1. Install Fedora on a system with a wireless and a ethernet device.
2. Configure the ethernet device with a static IP and DNS address during the
installation.
3. Reboot the system in presence of a an AP disconnected from network.
  
Actual results:
The static route is lost, /etc/resolv.conf is lost, the wireless interface is
associated to the AP.

Expected results:
The wireless interface is down, the network settings are preserved.

Additional info:
I can understand when connections are established over unconfigured wired links,
although it would be great if the routes and the DNS servers were fully restored
after the link goes away.

But bringing up wireless interfaces the user wasn't even told about and
connecting to a random AP borders to a crime.  In fact, people were arrested and
fined for using unsecured APs without permission.

Unless the user selects ESSID and wireless security settings (possibly "any
ESSID" and "no security"), no wireless device, built-in or hotplugged, should be
brought up, let alone allowed to overwrite user specified DNS configuration.
Comment 1 Bill Nottingham 2007-11-12 13:33:49 EST
Technically, they're configured, in that a config file is written. (If you look,
you'll have /etc/sysconfig/network-scripts/ifcfg-<whatever>). But that can be
changed to not configure them to be brought up on boot by default.
Comment 2 Bill Nottingham 2007-11-12 13:41:36 EST
Changed in kudzu-1.2.79.1-1/1.2.80-1. Note that this doesn't affect
configurations already written.
Comment 3 Fedora Update System 2007-11-12 19:06:07 EST
kudzu-1.2.79.1-1 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kudzu'
Comment 4 Pavel Roskin 2007-11-13 13:46:06 EST
It's working correctly with the new kudzu.  Thank you!
Comment 5 Fedora Update System 2007-11-20 12:55:35 EST
kudzu-1.2.79.1-1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Bill Nottingham 2008-02-12 12:32:54 EST
*** Bug 249420 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.