Bug 249496 - pup crashes during install transaction and leaves system broken
Summary: pup crashes during install transaction and leaves system broken
Status: CLOSED DUPLICATE of bug 249374
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 7
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-25 05:54 UTC by Need Real Name
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 13:42:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2007-07-25 05:54:29 UTC
Description of problem:
Ran an update with pup which crashed during the installation transaction.

Needed to manually yum install cairo because got "error while loading shared
libraries: libcairo.so.2: cannot open shared object file: No such file or
directory".

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
pup with updates

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[fpn@darkstar ~]$ pup
Loading "installonlyn" plugin
Excluding Packages from Fedora Core 7 - i386 - Freshrpms
Finished
Stopping lm_sensors: [  OK  ]
scrollkeeper-update: warning: /usr/share/omf/totem/totem-bg.omf overrides
/usr/local/share/omf/totem/totem-bg.omf
/usr/bin/scrollkeeper-update: warning: /usr/share/omf/totem/totem-bg.omf
overrides /usr/local/share/omf/totem/totem-bg.omf
Shutting down sensord: [FAILED]
Removing I2C drivers:  [  OK  ]

Component: Software Updater
Summary: TBedf28128 Progress.py:85:callback:TypeError: unsupported operand
type(s) for /: 'int' and 'NoneType'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 726, in
applyChanges
    self.runTransaction(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 701, in
runTransaction
    tserrors = yum.YumBase.runTransaction(self, tsprog)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.5/site-packages/pirut/Progress.py", line 85, in callback
    self.progress.set_fraction(self.num / self.total * (1 - PREP) + PREP)
TypeError: unsupported operand type(s) for /: 'int' and 'NoneType'

Local variables in innermost frame:
what: 8
h: (<rpm.hdr object at 0xdc00cb0>,
u'//var/cache/yum/updates/packages/kdesdk-3.5.7-6.fc7.i386.rpm')
self: <pirut.Progress.PirutTransactionProgress instance at 0xc931c6c>
logmsg: 
amount: 0
user: 
total: 0
PREP: 0.25

Expected results:


Additional info:

Comment 1 Jeremy Katz 2007-07-25 13:42:26 UTC

*** This bug has been marked as a duplicate of 249374 ***


Note You need to log in before you can comment on or make changes to this bug.