Bug 24950 - dd --> errors during boot.img creation
dd --> errors during boot.img creation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
All Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On: 25321
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-25 13:13 EST by Ben Levenson
Modified: 2007-03-26 23:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-04 22:20:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ide-floppy.c update. (22.61 KB, patch)
2001-01-31 08:47 EST, Sam Varshavchik
no flags Details | Diff
2.4.7-0.3 includes most of the changes in the maintainer's tree ... except for the actual bug. (8.63 KB, patch)
2001-08-04 22:20 EDT, Sam Varshavchik
no flags Details | Diff

  None (edit)
Description Ben Levenson 2001-01-25 13:13:55 EST
build: qa0124.0
tried to create boot.img from 7.1-beta3-ia64 tree, completed with the
following
errors:
ide-floppy: hdd: I/O error, pc = 5a, key = 5, asc = 24, ascq = 0
ide-floppy: hdd: I/O error, pc = 5a, key = 5, asc = 24, ascq = 0
20480+0 records in
20480+0 records out

verified on 3 systems, and multiple ls-120 floppies.
another similar error:

Another slightly different one:
ide-floppy: hda: I/O error, pc = 5a, key = 5, asc = 24, ascq = 0
ide-floppy: Protocol is not ATAPI
ide-floppy: hdc: not supported by this version of ide-floppy
ide-floppy: hda: I/O error, pc = 5a, key = 5, asc = 24, ascq = 0
20480+0 records in
20480+0 records out

I was able to make a 7.1-beta3-ia64 boot.img without errors by 
reinstalling our beta2 release.
Comment 1 Bernhard Rosenkraenzer 2001-01-25 15:56:25 EST
The error messages you're seeing are coming from the kernel.
They're probably indications of broken hardware (such as an ls120 medium with 
defective sectors). Reassigning to kernel just in case it's a kernel problem.
Comment 2 Arjan van de Ven 2001-01-25 16:02:37 EST
2 things can be going on:
1) Your hardware is wacked, or support for it is wacked
2) there is a known issue with "dd"'ing to devices. "dd" does a
   "truncate" on the device in that case, something that happened to
   work for 2.2 kernels but fails on 2.4 kernels. (truncating files
   is ok, but there is no sensible meaning for making your floppy disk
   smaller :)

I read it that you are running a 0.99.x series kernel when doing this,
which all have this problem.
Comment 3 Ben Levenson 2001-01-25 16:25:19 EST
Thanks for the quick response.
FWIW, I verified the errors on 6 different ls-120 floppies and three
different systems, so I'm guessing that it's not a hardware problem.
Once I reinstalled 7.1-beta2-ia64 (2.4.0-0.43.12) I could create the
floppies with no problems. yippy!
qa1024.0 and 7.1-beta3-ia64 are running 2.4.0-0.99.10/11. 
I also tried to use "dd" once I got a working installation of beta3 and
I received the same I/O errors.
Comment 4 Arjan van de Ven 2001-01-26 05:08:28 EST
Could you try to use the "notrunc" commandline option of "dd" ?
If it works with that option, it absolutely is the dd bug.
Comment 5 Glen Foster 2001-01-29 19:03:55 EST
This defect is considered MUST-FIX for Florence Release-Candidate #2
Comment 6 Ben Levenson 2001-01-29 19:37:45 EST
build: fisher
Unfortunately, conv=notrunc didn't have any
effect on the I/O errors I have been receiving.
Comment 7 Arjan van de Ven 2001-01-31 04:48:34 EST
We will merge a new ide-floppy driver version, let's see if that fixes it.
Comment 8 Sam Varshavchik 2001-01-31 08:46:52 EST
While waiting for the new ide-floppy.c from the maintainer, you can try the
following patch. It's going to bring up ide-floppy.c from -ac11 to the latest
version I got from the maintainer, two weeks ago.
Comment 9 Sam Varshavchik 2001-01-31 08:47:36 EST
Created attachment 8559 [details]
ide-floppy.c update.
Comment 10 Arjan van de Ven 2001-02-02 04:57:41 EST
Patch is integrated; next kernel build (0.99.18 or later) should have it
Comment 11 Sam Varshavchik 2001-02-03 17:12:23 EST
I'd like to test the build. Checked rawhide, but it still has 0.99.11.
Comment 12 Sam Varshavchik 2001-02-04 14:37:42 EST
Installed 0.99.21smp i686 from rawhide. I can mount floppies, dd to/from them
just fine.

Success.

Comment 13 Arjan van de Ven 2001-02-09 06:20:56 EST
Ben: Can you still reproduce this bug with the new driver ?
Comment 14 Michael K. Johnson 2001-02-28 20:47:55 EST
mrsam reports success, benl has not reported additional failures,
closing.  Reopen if you experience more failures.
Comment 15 Ben Levenson 2001-04-26 10:03:14 EDT
I'm finally back on ia64....
I think johnsonm forgot to click the  "mark bug as closed" button.
don't see the errors in the 0420.1 tree.  
closing.  
Comment 16 Sam Varshavchik 2001-07-14 00:00:08 EDT
Reopening.

Fairfax 2.4.5-10 reverted back to 0.9 version of ide-floppy.o

benl: you should be able to reproduce your original problem under 2.4.5-10

Please reapply ide-floppy.o 0.97 (2/2/2001) to 2.4.5-10, it shipped with the
RH70 kernel.
There are other problems with the 0.9 driver also (ex:
http://floppyutil.sourceforge.net will not be able to autoprobe LS-120 drives
unless there's a floppy inserted).

Comment 17 Sam Varshavchik 2001-07-16 23:37:02 EDT
Updating to beta2 - looks like 2.4.6-2 was also build with version 0.9
Comment 18 Sam Varshavchik 2001-08-04 22:20:32 EDT
Created attachment 26272 [details]
2.4.7-0.3 includes most of the changes in the maintainer's tree ... except for the actual bug.
Comment 19 Ben Levenson 2002-01-25 18:08:07 EST
Closing. Version 0.97 is included w/ current errata kernels.

Note You need to log in before you can comment on or make changes to this bug.