Bug 249698 - Computer doesn't get IP address assigned from DHCP server
Computer doesn't get IP address assigned from DHCP server
Status: CLOSED DUPLICATE of bug 250003
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 249699 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 10:51 EDT by Bukovansky Richard
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 07:07:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bukovansky Richard 2007-07-26 10:51:42 EDT
Description of problem:
With kernel 2.6.22.1-33.fc7 my computer is not able to get IP address from DHCP 
server for both network cards (LAN and WiFi).
With kernel 2.6.22.1-27.fc7 it works fine.


Version-Release number of selected component (if applicable):
2.6.22.1-33

How reproducible:


Steps to Reproduce:
1. Set your computer to use DHCP on LAN card
2. Upgrade to 2.6.22.1-33.fc7 kernel
3. Reboot and log in as normal user or root.
  
Actual results:
Network card doesn't get IP address assigned from DHCP server, but ZeroConf is 
used.

Expected results:
Network card gets IP address assigned from DHCP server.

Additional info:
Comment 1 Chuck Ebbert 2007-07-26 12:14:00 EDT
*** Bug 249699 has been marked as a duplicate of this bug. ***
Comment 2 CHIKAMA Masaki 2007-07-27 06:42:41 EDT
I have the same probelm.

Reverting "cfs update" seems to solve the problem. 
(replce linux-2.6-sched-cfs.patch with 2.6.22.1-27.fc7's one)

>* Fri Jul 20 2007 Chuck Ebbert <cebbert@redhat.com>
>- utrace update
>- CFS scheduler update

Need more information? Please let me know.
Comment 3 Chuck Ebbert 2007-07-27 16:42:38 EDT
CFS timer changes have been synced with what is upstream.
The next kernel will be out very shortly, it should be fixed.
Comment 4 Igor A Tarasov 2007-07-28 03:15:21 EDT
I have the same problem.
dhclient get DHCPINFORM message, but nothing happen then.
NetworkManager says that not reply received from DHCP server and interface 
configured using ZeroConf.

Even after manually configuration IP address on NIC, openvpn tunnel, based on 
UDP protocol, can't start :(
Comment 5 Peter Sabiniewicz 2007-07-28 16:34:53 EDT
I confirm the bug I am using FC 7 on Nforce 2 Mainboard ASUS A7N8X-X and i have
the same problem. IP adress is offered bye DHCP server (Cable Modem)but not
network card dont get IP adress.
Comment 6 Joachim Backes 2007-07-29 04:11:25 EDT
Having the same problem with my desktop PC (AMD, Athlon).

Additionally I found out: Booting to single user mode, then calling
"/etc/init.d/network start" by hand gets well an IP address by dhcp. But during
normalboot sequences (to init mode 3 or 5), it will hang. Race condition problem?

I can confirm that 2.6.22.1-27.fc7 boots fine. 
Comment 7 Roman Danilov 2007-07-29 14:56:49 EDT
I am having this problem too.
Hardware is: VMWare Server 1.0.3

When booting 2.6.22.1-33.fc7, it is hang on "determining IP information for
eth0...". But if I choose old 2.6.22.1-27.fc7, it works fine.
Comment 8 CHIKAMA Masaki 2007-07-29 21:36:58 EDT
I confirm that 2.6.22.1-41.fc7 from koji fixed this problem.
Comment 9 Bukovansky Richard 2007-07-30 06:11:17 EDT
Confirming also. -41 resolves the issue. Thanks.
Comment 10 Roman Danilov 2007-07-30 15:03:50 EDT
Yes, installation of 2.6.22.1-41.fc7 was fixed this bug. Thanks! :-)
Comment 11 Milan Kerslager 2007-08-01 07:07:07 EDT
The latest kernel-2.6.22.1-41.fc7 solves the problem. Please reopen or create
new bugreport if your problem persist. See bug #250003 for more info.

*** This bug has been marked as a duplicate of 250003 ***

Note You need to log in before you can comment on or make changes to this bug.