Bug 249737 - Rebuild cyrus-sasl using db4-4.6.19
Rebuild cyrus-sasl using db4-4.6.19
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Conklin
Fedora Extras Quality Assurance
:
Depends On: 249735
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-07-26 14:49 EDT by Robert Scheck
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 13:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-07-26 14:49:12 EDT
Description of problem:
Please rebuild cyrus-sasl using db4-4.6.18.

Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.22-6

Actual results:
Cyrus SASL is currently built using db4 < 4.6.18.

Expected results:
Cyrus SASL is currently built using db4 = 4.6.18.
Comment 1 Robert Scheck 2007-09-01 22:02:55 EDT
Ping?
Comment 2 Robert Scheck 2007-09-03 17:05:39 EDT
Please use 4.6.19 for the internal one. Several x86_64 issues are solved there.
Comment 3 Robert Scheck 2007-09-05 18:05:59 EDT
The following changes worked for me. But you should rename the copy of db-
4.6.18-glibc.patch from the db4 package somehow before adding to this package. 
Oh and IMHO the buildrequirement to gdbm-devel is no longer required.

--- cyrus-sasl.spec       2007-02-26 22:23:11.000000000 +0100
+++ cyrus-sasl.spec.rsc   2007-09-05 23:59:36.000000000 +0200
@@ -1,5 +1,5 @@
 %define _plugindir2 %{_libdir}/sasl2
-%define db_version 4.5.20
+%define db_version 4.6.19
 %define bootstrap_cyrus_sasl 0

 Summary: The Cyrus SASL library
@@ -28,6 +28,7 @@
 Patch26: cyrus-sasl-2.1.22-digest-commas.patch
 Patch27: cyrus-sasl-2.1.22-automake-1.10.patch
 Patch28: cyrus-sasl-2.1.21-keytab.patch
+Patch29: db-4.6.18-glibc.patch
 Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildRequires: autoconf, automake, libtool, gdbm-devel, groff
 BuildRequires: krb5-devel >= 1.2.2, openssl-devel, pam-devel, pkgconfig
@@ -128,6 +129,10 @@
 %patch27 -p1 -b .automake-1.10
 %patch28 -p1 -b .keytab

+pushd db-%{db_version}
+%patch29 -p1 -b .glibc27
+popd
+
 # FIXME - we remove these files directly so that we can avoid using the -f
 # flag, which has a nasty habit of overwriting files like COPYING.
 rm -f config/config.guess config/config.sub

Note You need to log in before you can comment on or make changes to this bug.