Bug 249822 - Something wrong with patches
Something wrong with patches
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 06:18 EDT by The Source
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 08:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2007-07-27 06:18:36 EDT
Description of problem:
Downloaded src.rpm of 2.6.22.1-33 kernel and I can't figure out how to apply
patches to the latest version. I have found patch to 2.6.22.1 but that is the
same that was in previous version. So I tried to apply all *.patch file. Some of
them apply properly, some give warning, some refer to non-existent files. Either
something is wrong with patches or I just don't understand what to do.

Version-Release number of selected component (if applicable):
2.6.22.1-33

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jarod Wilson 2007-07-27 08:38:06 EDT
# rpm -ivh kernel-2.6.22.1-33.fc7.src.rpm
# cd /usr/src/redhat/SPECS
# rpmbuild -bp kernel-2.6.spec

Works for me, and is essentially what the build system does. There's some additional info on how to do all 
this in the Fedora wiki.
Comment 2 Jarod Wilson 2007-07-27 08:39:53 EDT
http://fedoraproject.org/wiki/Docs/CustomKernel
Comment 3 The Source 2007-07-27 09:26:53 EDT
Yuck! What a mess!

patch -p1 < patch-2.6.22.1
make gconfig
make
su
make modules_install
make install

This is much simpler. Why don't you just include complete patch file into src.rpm?
Comment 4 Jarod Wilson 2007-07-27 09:37:45 EDT
Not quite sure what you're talking about. We *do* include the complete patch file in the srpm... Patch00 in 
the 2.6.22.1 kernel srpms is patch-2.6.22.1.bz2. I think you're missing something somewhere.
Comment 5 The Source 2007-07-27 10:19:01 EDT
So what is the difference between 2.6.22.1-27 and 2.6.22.1-33 then?
Comment 6 Jarod Wilson 2007-07-27 11:18:52 EDT
rpm -qp --changelog kernel-2.6.22.1-33.fc7.src.rpm, and/or diff the specs between the two and/or look 
at the cvs commit logs.

btw, bugzilla is NOT a support forum, its a bug tracking tool, so this really isn't the place for these 
questions... I'd suggest taking further questions to the fedora-devel-list.

Note You need to log in before you can comment on or make changes to this bug.