Bug 24986 - konqueror won't launch
Summary: konqueror won't launch
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Aaron Brown
URL:
Whiteboard: Florence RC-1
Keywords:
: 26298 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-25 23:32 UTC by Tim Waugh
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 00:56:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors (9.11 KB, text/plain)
2001-01-25 23:36 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2001-01-25 23:32:46 UTC
Fresh install (from oot tree between 7.1-beta3 and qa0125.0)

Typing in a URL (such as https://bugzilla.redhat.com/bugzilla) into the 
Alt-F2 dialog causes an 'examining file' dialog to momentarily display, 
followed by a 'konqueror' entry in the task bar, but then it disappears 
and that's the end of it.

Running konqueror from a konsole works fine.  I'll attach my 
.xsession-errors, from a session in which I have several attempts to 
launch konqueror from Alt-F2, followed by one from a konsole.

I see that there are newer KDE packages; I'll give those a go tomorrow.

Comment 1 Tim Waugh 2001-01-25 23:36:33 UTC
Created attachment 8290 [details]
.xsession-errors

Comment 2 Tim Waugh 2001-01-26 10:20:09 UTC
This still happens for me with the qa0126.0 tree.

Comment 3 Tim Waugh 2001-01-26 10:28:48 UTC
I should mention that this problem also happens when I click on the
'www.redhat.com' icon, and the other URL icons.

Comment 4 Bernhard Rosenkraenzer 2001-01-26 10:52:31 UTC
This is odd... I can't reproduce any of this, and there are a number of 
"Connection refused" errors in your .xsession errors.
Could this be caused by a firewall blocking the connection? Are you trying to 
launch konqueror in a remote session? Are kded and dcopserver running?
Does it still happen if you rm -rf ~/.k* ~/.DCOP* /tmp/mcop*?



Comment 5 Tim Waugh 2001-01-26 11:44:45 UTC
IPchains problems was my first thought, and so I made sure that lokkit wrote a
'no firewall' config and did 'service ipchains restart'.

It's running locally, on my machine at home.  Unfortunately I'm at work now, but
I'll see if I can get it to work remotely by logging in using kdm.  I'll try
removing those files.

Comment 6 Tim Waugh 2001-01-26 12:40:30 UTC
Huh.  Okay, running Xnest :1 -query localhost -geometry 640x480 while logged in
using ssh with X forwarding, it works fine, without me having done anything
else.

I'll pop back and try it again without changing anything, and again after
removing those files.

Comment 7 Tim Waugh 2001-01-26 13:03:10 UTC
(Still at work)

I added a new user with useradd, and logged in as them and clicked on 'Linux
Documents', and this happened again, and I have a 'connect() failed' in the
.xsession-errors.

Comment 8 Tim Waugh 2001-01-26 13:10:59 UTC
Without logging off, I ran the 'rm' command you suggested, and now it works.

Comment 9 Tim Waugh 2001-01-28 13:29:28 UTC
This also happens on upgrade from Red Hat Linux 7, or at least it did on the 
machine I'm using now.


Comment 10 Tim Waugh 2001-01-29 18:52:39 UTC
Bero, can you reproduce this yet?

Comment 11 Glen Foster 2001-01-30 00:01:37 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 12 Bernhard Rosenkraenzer 2001-01-30 00:23:54 UTC
Can't reproduce this... Does it happen with glibc-2.2.1-2? With a broken
dlopen(), anything can happen in KDE...

Comment 13 Tim Waugh 2001-01-30 11:04:55 UTC
It still happens with 2.2-9 (i386), which is what I had handy.


Comment 14 Tim Waugh 2001-02-02 22:36:08 UTC
This also happens on upgrade from Guinness.

Removing just .DCOP* works around the problem.

Comment 15 Bernhard Rosenkraenzer 2001-02-06 17:03:56 UTC
*** Bug 26298 has been marked as a duplicate of this bug. ***

Comment 16 Tim Waugh 2001-02-07 00:56:52 UTC
I'll try this again on a qa0206.0 install tomorrow morning.

Comment 17 Tim Waugh 2001-02-07 11:51:15 UTC
Okay, I can't get this to happen now.  I'm using the 20010205 packages from
qa0206.0.  I think it must be fixed.


Note You need to log in before you can comment on or make changes to this bug.