Bug 249891 - Upgrade fails
Upgrade fails
Status: CLOSED DUPLICATE of bug 250306
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 14:00 EDT by Nigel Horne
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 12:03:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2007-07-27 14:00:39 EDT
Description of problem:
rpm -ivh kernel-2.6.22.1-33.fc7 gives:
ofpath: /dev/hda: Device not configured
ybin: Unable to find OpenFirmware path for boot=/dev/hda2
ybin: Please add ofboot=<path> where <path> is the OpenFirmware path to
/dev/hda2 to /etc/yaboot.conf
ofpath: /dev/hda: Device not configured
ybin: Unable to determine OpenFirmware path for macosx=/dev/hda5
ybin: Try specifying the real OpenFirmware path for macosx=/dev/hda5 in
/etc/yaboot.conf


Version-Release number of selected component (if applicable):
kernel-2.6.22.1-33.fc7

How reproducible:
100%

Steps to Reproduce:
1. rpm -ivh kernel-2.6.22.1-33.fc7
2.
3.
  
Actual results:
ofpath: /dev/hda: Device not configured
ybin: Unable to find OpenFirmware path for boot=/dev/hda2
ybin: Please add ofboot=<path> where <path> is the OpenFirmware path to
/dev/hda2 to /etc/yaboot.conf
ofpath: /dev/hda: Device not configured
ybin: Unable to determine OpenFirmware path for macosx=/dev/hda5
ybin: Try specifying the real OpenFirmware path for macosx=/dev/hda5 in
/etc/yaboot.conf



Expected results:
Should upgrade


Additional info:
cat /etc/yaboot.conf:

# yaboot.conf generated by anaconda

boot=/dev/hda2
init-message=Welcome to Fedora Core\!
Hit <TAB> for boot options

partition=3
timeout=80
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
macosx=/dev/hda5
magicboot=/usr/lib/yaboot/ofboot
image=/boot/vmlinuz-2.6.22.1-33.fc7
        label=2.6.22.1-33.fc7
        read-only
        initrd=/boot/initrd-2.6.22.1-33.fc7.img
        append="rhgb quiet root=LABEL=/"

image=/boot/vmlinuz-2.6.22.1-27.fc7
        label=2.6.22.1-27.fc7
        read-only
        initrd=/boot/initrd-2.6.22.1-27.fc7.img
        append="rhgb quiet root=LABEL=/"
Comment 1 Chuck Ebbert 2007-08-21 12:03:42 EDT

*** This bug has been marked as a duplicate of 250306 ***

Note You need to log in before you can comment on or make changes to this bug.