Bug 250306 - /proc/ide missing in 2.6.22+ Fedora kernels
Summary: /proc/ide missing in 2.6.22+ Fedora kernels
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 249891 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-31 18:13 UTC by Alex Kanavin
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 21:13:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Kanavin 2007-07-31 18:13:32 UTC
/proc/ide was made optional in 2.6.22+ kernels and Fedora builds omit it. This
breaks userspace tools, at least yaboot but possibly others. Please fix ASAP,
the option is CONFIG_IDE_PROC_FS.

Comment 1 Paul Nasrat 2007-07-31 19:58:27 UTC
I'd probably be happy to fix yaboot (well ybin up) for 2.6.22+

Let me look into it.

Comment 2 Alex Kanavin 2007-07-31 20:21:00 UTC
Actually, ofpath :) I'm not sure if it's possible to fix without /proc/ide - it seems to be pulling some magic 
values out of it.

Comment 3 Paul Nasrat 2007-07-31 20:39:38 UTC
Let me poke tomorrow when I can get my hands on a box.

Comment 4 David Woodhouse 2007-08-01 08:48:27 UTC
This is fixed by re-enabling CONFIG_IDE_PROC_FS in the kernel for now. Hopefully
we'll be able to switch to libata for the pmac some time soon.

Comment 5 Chuck Ebbert 2007-08-21 16:03:45 UTC
*** Bug 249891 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.