Bug 250057 - no CJK support
no CJK support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: i18n, Regression
: 393581 (view as bug list)
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-07-30 03:24 EDT by Akira TAGOH
Modified: 2007-12-20 14:52 EST (History)
3 users (show)

See Also:
Fixed In Version: 8.61-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 14:52:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testcase (2.35 KB, text/plain)
2007-07-30 03:24 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Akira TAGOH 2007-07-30 03:24:24 EDT
Description of problem:
The latest ghostscript doesn't support CJK anymore.

Version-Release number of selected component (if applicable):
8.60-0.svn8117.2.fc8

How reproducible:
always

Steps to Reproduce:
1.gs -sDEVICE=x11 article9.ps
2.
3.
  
Actual results:
Error: /rangecheck in --widthshow--

Expected results:
shows Japanese text in a window.

Additional info:
Comment 1 Akira TAGOH 2007-07-30 03:24:30 EDT
Created attachment 160218 [details]
testcase
Comment 2 Sammy 2007-08-13 09:40:57 EDT
The CJK patches by Koji Otani was just checked in to the ghostscript trunk,
svn revision 8185.
FYI
Comment 3 Jens Petersen 2007-10-02 04:05:44 EDT
Is it possible to get those patches included in F8?
Comment 4 Tim Waugh 2007-10-02 05:47:23 EDT
There had been regressions reported by the developers.  I should be able to pull
in a new snapshot, but I'd been hoping for a newer release.
Comment 5 Akira TAGOH 2007-10-02 06:06:27 EDT
How about just backporting CJKV patches from ESP gs? apparently it's different
thing to what the changes committed into svn once.
Comment 6 Tim Waugh 2007-10-03 08:47:55 EDT
Looking more closely at SVN it looks like the CJK patches were actually reverted.

I would much rather follow upstream on this (now that it's GPL) rather than
carrying other patches around.
Comment 7 Tim Waugh 2007-11-21 09:30:20 EST
*** Bug 393581 has been marked as a duplicate of this bug. ***
Comment 8 Akira TAGOH 2007-11-21 20:27:54 EST
f8 bug? I can still see this bug on devel too.
Comment 9 CHIKAMA Masaki 2007-11-22 21:39:42 EST
Version 8.61 released, but it only includes a small part of the CJK patches.
Moreover, one of ghostscript developer have doubts about current configuration
of Fedora's ghostscript m17n. That is the usage of cidfmap.ja etc.

What do you think about it ?
Do we need more wide discussion ?
Comment 10 CHIKAMA Masaki 2007-11-22 21:45:47 EST
(In reply to comment #9)
> That is the usage of cidfmap.ja etc.
It's not clear, sorry.

Why do currnt cidfmap only include .ja, ko, zn_CN and zn_TW ? 
Why not others like Arabic or Serbian ?
Comment 11 Akira TAGOH 2007-11-25 02:07:38 EST
(In reply to comment #10)
> (In reply to comment #9)
> > That is the usage of cidfmap.ja etc.
> It's not clear, sorry.
> 
> Why do currnt cidfmap only include .ja, ko, zn_CN and zn_TW ? 
> Why not others like Arabic or Serbian ?

First, That's up to the each font packages. which files ghostscript reads are
currently hard-coded though, IMHO eventually it should becomes the sort of
add-ons, because we are free to add the fonts into the distribution as long as
it can be freely used and no license issues. making all the changes every times
in ghostscript package isn't suitable IMHO.
Second, there is no CMaps for Arabic and Serbian etc AFAIK. what currently
ghostscript supports for TrueType/OpenType fonts is to convert to CID font.
which means at least one CMap is required. presumably the font needs to be
embedded as Type3 or Type42 into PostScript for those languages. but I thought
cidfmap isn't to do that. Anyway, it should be filed separately to each font
packages though, I have no idea what the expected configuration for them is.
Comment 12 CHIKAMA Masaki 2007-11-27 05:19:53 EST
(In reply to comment #11)
> > Why do currnt cidfmap only include .ja, ko, zn_CN and zn_TW ? 
> > Why not others like Arabic or Serbian ?
> 
> First, That's up to the each font packages. which files ghostscript reads are
> currently hard-coded though, IMHO eventually it should becomes the sort of
> add-ons, because we are free to add the fonts into the distribution as long as
> it can be freely used and no license issues. making all the changes every times
> in ghostscript package isn't suitable IMHO.

But a ghostscript package should provide mechanism to support add-ons.
Current build configuration of ghostscript disallows reading  
/usr/share/ghostscript/lib/cidfmap, instead only it allows reading ./cidfmap .

So I propose to build the ghostscript with "--disable-compile-inits" 
for the first step. This option enables gs to read
/usr/share/ghostscript/lib/cidfmap and other resource data when it start up.
Comment 13 Fedora Update System 2007-11-28 20:32:15 EST
ghostscript-8.61-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 14 CHIKAMA Masaki 2007-11-29 06:01:51 EST
(In reply to comment #13)
With ghostscript-8.61-1.fc8, I think some of problem are solved.
Now we should file a new bug related to CJK support which isn't solved 
even at upstream. For example, Japanese virtical writing problem.
Comment 15 Fedora Update System 2007-12-03 06:38:27 EST
ghostscript-8.61-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 16 Fedora Update System 2007-12-12 14:52:26 EST
ghostscript-8.61-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 17 Fedora Update System 2007-12-15 12:49:12 EST
ghostscript-8.61-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 18 Fedora Update System 2007-12-20 14:52:48 EST
ghostscript-8.61-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.