Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 250078 - Referenced sha1pass not included in rpm
Referenced sha1pass not included in rpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 07:48 EDT by Mads Kiilerich
Modified: 2009-03-06 09:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 09:23:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2007-07-30 07:48:00 EDT
Description of problem:
/usr/share/doc/syslinux-3.36/README.menu says 'use the included Perl script
"sha1pass" to encrypt passwords'. The script is not included in the rpm. A quick
search gives no hint of which tool could be used instead.

Version-Release number of selected component (if applicable):
syslinux-3.36-4.fc7
Comment 1 Bug Zapper 2008-04-04 09:30:23 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 Mads Kiilerich 2008-04-04 09:41:12 EDT
Problem remains in syslinux-3.36-7.fc8
Comment 3 Mads Kiilerich 2008-04-04 09:54:17 EDT
It seems to have been fixed in syslinux-3.61-2 for F9. But the fix creates
conflicts in the spec, so it isn't obvious if it is intended or accidentially:

%files
...
%{_bindir}/*
...
%{_bindir}/ppmtolss16
%{_bindir}/lss16toppm
%{_bindir}/gethostip
Comment 4 John Poelstra 2008-04-04 17:28:53 EDT
pjones can you advise re comment#3 ?

thanks
Comment 5 Bug Zapper 2008-05-13 23:06:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Mads Kiilerich 2008-05-27 18:16:32 EDT
If md5pass is included intentionally then the package needs an dependency to
perl-Crypt-PasswdMD5.

In Fedora 9 with syslinux-3.61-2.fc9.i386:

[mk@localhost tmp]$ md5pass foo
Can't locate Crypt/PasswdMD5.pm in @INC (@INC contains:
/usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0
/usr/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.8.8
/usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl .) at
/usr/bin/md5pass line 4.
BEGIN failed--compilation aborted at /usr/bin/md5pass line 4.


# yum install /usr/lib/perl5/vendor_perl/5.5.10.0/Crypt/PasswdMD5.pm
Installed: perl-Crypt-PasswdMD5.noarch 0:1.3-3.fc9


[mk@localhost tmp]$ md5pass foo
$1$RCV1Ospl$3wg5Se3MFz2AK2L1B1hzo.
Comment 7 Mads Kiilerich 2009-03-06 09:23:21 EST
The primary problem is solved with syslinux-3.73-2.fc11.i586

The missing dependencies from comment #6 is tracked in Bug 465299 

Closing

Note You need to log in before you can comment on or make changes to this bug.