Bug 465299 - Missing dependencies for md5pass and sha1pass
Missing dependencies for md5pass and sha1pass
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 514895 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 12:47 EDT by Mads Kiilerich
Modified: 2009-09-01 05:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 15:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-10-02 12:47:56 EDT
Version-Release number of selected component (if applicable):
syslinux-3.61-3.fc10.i386


Steps to Reproduce:
[root@dev-mk ~]# yum install syslinux
...
[root@dev-mk ~]# md5pass 
Can't locate Crypt/PasswdMD5.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/local/lib/perl5/site_perl .) at /usr/bin/md5pass line 4.
BEGIN failed--compilation aborted at /usr/bin/md5pass line 4.
[root@dev-mk ~]# sha1pass 
Can't locate Digest/SHA1.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/local/lib/perl5/site_perl .) at /usr/bin/sha1pass line 4.
BEGIN failed--compilation aborted at /usr/bin/sha1pass line 4.
[root@dev-mk ~]# yum install perl-Crypt-PasswdMD5 perl-Digest-SHA1
...
[root@dev-mk ~]# md5pass 
$1$dqmVOcTV$Iu/61dwEhctnIgM64bYUP.
[root@dev-mk ~]# sha1pass 
$4$uFHj3YL3$FZJi1f3TXBQa/JWh7ruKS2x3YUc$
[root@dev-mk ~]# 


Additional info:
Problem first mentioned on Bug 250078
Comment 1 Bug Zapper 2008-11-25 22:28:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 TK009 2008-12-07 15:45:28 EST
This bug has been triaged
Comment 3 Mads Kiilerich 2009-03-06 08:57:17 EST
Problem confirmed with syslinux-3.73-2.fc11.i586
Comment 4 Jeremy Katz 2009-04-28 15:49:34 EDT
Fixed in cvs in devel for post F11
Comment 5 Yaakov Nemoy 2009-09-01 05:52:04 EDT
*** Bug 514895 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.