Bug 250130 - kernel is unable to see pata devices on (apple?) ppc
kernel is unable to see pata devices on (apple?) ppc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Test3
  Show dependency treegraph
 
Reported: 2007-07-30 11:56 EDT by Jesse Keating
Modified: 2013-01-09 21:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 15:09:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-07-30 11:56:41 EDT
PPC mac mini (http://jkeating.fedorapeople.org/lspci-v) can't install as the
kernel can't find the local hard disk.  Unknown how long this has been this way
(I only turn on the ppc machines at release time.  Our ample user base would
have informed us if they stopped working at some point right?)
Comment 1 David Woodhouse 2007-07-30 12:00:03 EDT
The pmac_ide driver in 2.6.23-0.45.rc0.git16.fc8 was working, at least on
PowerBook. Will attempt to reproduce with newer kernels, and on a Mini.
Comment 2 Jesse Keating 2007-07-30 17:22:38 EDT
This seems to effect my G5 and it's IDE DVD drive as well.
Comment 3 Will Woods 2007-07-30 17:37:15 EDT
I've had no luck with ide_pmac for a long time; see bug 224642 for some
possibly-related discussion.
Comment 4 Chuck Ebbert 2007-07-31 18:06:17 EDT
This could be the same problem as bug 250306. If so the fix is in the
latest kernel (Jul 31 2007) that contains the EDD boot fix.

* Tue Jul 31 2007 David Woodhouse <dwmw2@infradead.org>
...
- Re-enable CONFIG_IDE_PROC_FS to fix ybin

Comment 5 David Woodhouse 2007-08-01 05:03:21 EDT
Ah, that's possible. I had interpreted the bug report literally and had checked
that the current kernel really does find the hard disk. Perhaps stupidly, I
hadn't thought that it could be just the lack of /proc/ide causing problems in
userspace.

My crappy DSL line is still working on downloading rawhide, so I hadn't got as
far as actually trying the install in the mini yet. And since people have been
asking me for a few days when there'll be a rawhide install tree again, I assume
it isn't going to be installable when I _do_ finish fetching it?
Comment 6 Jesse Keating 2007-08-01 09:27:45 EDT
Could be it.  I wish the tree was installable, but alas.  We got install images
for i386 and x86_64, something failed for ppc.  Shocking.  Will look into it at
some point, have test1 to prepare.
Comment 7 Will Woods 2007-09-06 12:36:08 EDT
IDE seems fine on current (pre-F8Test2) rawhide on my G5. Jesse?
Comment 8 Jesse Keating 2007-09-07 15:09:40 EDT
Yep, looks fine.

Note You need to log in before you can comment on or make changes to this bug.