Bug 250136 - Authconfig needs to enable pam_mkhomedir when enabling external authentication methods
Authconfig needs to enable pam_mkhomedir when enabling external authenticatio...
Status: CLOSED DUPLICATE of bug 212790
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 12:38 EDT by Oded Arbel
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 13:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2007-07-30 12:38:53 EDT
Description of problem:
When using an external authentication method (for example - LDAP), then home
directories for users aren't created as part of the user creating process. Home
directories then need to be created either manually or by adding pam_mkhomedir
to the session section in /etc/pam.d/system-auth.

Enabling pam_mkhomedir should best be done automatically when needed, and as
authconfig is the tool used in Fedora to enable external authentication, then
its probably a good idea to have authconfig also automatically add the
pam_mkhomedir to the pam.d configuration when such authentication methods are
enabled.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomas Mraz 2007-07-30 13:03:41 EDT

*** This bug has been marked as a duplicate of 212790 ***

Note You need to log in before you can comment on or make changes to this bug.