Bug 212790 - pam_mkhomedir not enabled when using network login
pam_mkhomedir not enabled when using network login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: FutureFeature
: 250136 334761 (view as bug list)
Depends On:
Blocks: 219287 F9Target
  Show dependency treegraph
 
Reported: 2006-10-28 23:15 EDT by Daniel Morante
Modified: 2008-01-10 18:21 EST (History)
3 users (show)

See Also:
Fixed In Version: authconfig-5.3.19-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 17:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Morante 2006-10-28 23:15:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
On a fresh install during the welcome/setup wizard, when setting up a network login, the "pam_mkhomedir" module is not loaded into the "system-auth" file. THis prevents a user from loggin on when using the network login feature.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Install Fedora Normaly
2. Boot for First time
3. Run through setup Wizard
4. Select Network Login Option
5. Select any method and complete it's setup, Windbind for example.
6. Save Changes, exit setup wizard
7. Attempt to login as network user, for example "MSHOME\bob"

Actual Results:
An error message appears telling you that the home directory does not exist, offers to log you in with the "/root" home directory.  This fails.

Expected Results:
Should have automaticly created the home directory in "/home/MSHOME/bob", then login and show the desktop.

Additional info:
To get network login using Winbind to work properly, I had to manualy add in the following line to /etc/pam.d/system-auth:

session    required     pam_mkhomedir.so skel=/etc/skel umask=0022

and create the following directory:

/home/MSHOME, where "MSHOME" is the netbios name of the windows domain.
Comment 1 Daniel Morante 2006-10-28 23:16:26 EDT
I also forgot to mention that this problem has been around since FC 4.
Comment 2 Tomas Mraz 2006-10-31 06:44:42 EST
This problem was always there because this is just feature which was not yet
implemented.

I will consider it for FC 7.
Comment 3 Tomas Mraz 2006-11-06 04:28:19 EST
Note: For safe SELinux containment of the login processes the process of making
home directory and copying the /etc/skel should be contained in a different
process -> we need to split the pam_mkhomedir to a module and a helper binary.
Comment 4 Tomas Mraz 2007-07-30 13:03:46 EDT
*** Bug 250136 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Mraz 2007-10-16 12:49:03 EDT
*** Bug 334761 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Mraz 2008-01-09 17:53:44 EST
Implemented option which adds pam_mkhomedir to /etc/pam.d/system-auth-ac
Comment 7 cje 2008-01-10 17:42:58 EST
many thanks Tomas.  does that satisfy your point in comment #3?
Comment 8 Tomas Mraz 2008-01-10 18:21:14 EST
No, this would require pam_mkhomedir changes which I didn't do yet.

Note You need to log in before you can comment on or make changes to this bug.