Bug 250336 - RFE: add the ability to get a lockdump out of gfs through sysrq
Summary: RFE: add the ability to get a lockdump out of gfs through sysrq
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: GFS-kernel (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
high
low
Target Milestone: ---
Assignee: Robert Peterson
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 295531 295541
TreeView+ depends on / blocked
 
Reported: 2007-07-31 21:27 UTC by Josef Bacik
Modified: 2010-01-12 03:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 17:38:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that implements this functionality. (2.12 KB, patch)
2007-07-31 21:27 UTC, Josef Bacik
no flags Details | Diff

Description Josef Bacik 2007-07-31 21:27:38 UTC
As more customers are starting to use GFS in a shared root environment its 
becoming more difficult to troubleshoot gfs hangs, as we cannot run gfs_tool 
lockdump because a GFS hang usually means the entire box is hung and the only 
way to get information is via sysrq.  This patch dumps glock information via 
sysrq.  I've tested this patch on my cluster and doesn't appear to blow 
anything up.

Comment 1 Josef Bacik 2007-07-31 21:27:38 UTC
Created attachment 160362 [details]
patch that implements this functionality.

Comment 3 Robert Peterson 2008-03-25 17:38:50 UTC
While I still feel this would be useful, it requires registering a new
sysrq sequence.  Since the sysrq sequences are designed and implemented
by the upstream community, and gfs1 is not upstream (nor will it ever be)
the decision was made to not implement this fix.  It would be too easy
for upstream to make changes that are not compatible with the fix.
So let's keep it a patch for now.



Note You need to log in before you can comment on or make changes to this bug.