Bug 250344 - Inability to mount KINGSTON USB thumbdrives.
Summary: Inability to mount KINGSTON USB thumbdrives.
Status: CLOSED DUPLICATE of bug 249282
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-31 22:45 UTC by Gian Paolo Mureddu
Modified: 2013-03-06 03:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 00:10:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hal-device output (156.05 KB, text/plain)
2007-07-31 22:45 UTC, Gian Paolo Mureddu
no flags Details
dmesg output (21.93 KB, text/plain)
2007-07-31 22:47 UTC, Gian Paolo Mureddu
no flags Details
strace output from running gnome-mount against the device reported by dmesg (39.79 KB, text/plain)
2007-07-31 22:48 UTC, Gian Paolo Mureddu
no flags Details

Description Gian Paolo Mureddu 2007-07-31 22:45:35 UTC
Description of problem:
Automount of Kingston Data Traveler USB thumbdrives is broken in Fedora 7 i386.
This appears to be either a problem with gnome-mount or HAL or both (assigning
here to gnome-mount). When running hal-device as root there is no such instance
as of any devices with any info on them for 'KINGSTON' nor when trying to run
gnome-mount -d /dev/sdc1 (corresponding to the KINGSTON device according to
dmesg) results in the device being mounted. Only way to mount is as root from CLI.

Version-Release number of selected component (if applicable):
gnome-mount-0.6-2.fc7
hal-0.5.9-8.fc7

How reproducible:
Always

Steps to Reproduce:
1. Update F7 to the latest batch of updates.
2. Insert a Kingston USB Data Traveler thumbdrive to a USB port.
  
Actual results:
The USB drive is not mounted.

Expected results:
The USB drive to be mounted.

Additional info:

Attached are:

hal-devices output from the system this is happening
dmesg output
strace output of gnome-mount -d /dev/sdc1

Comment 1 Gian Paolo Mureddu 2007-07-31 22:45:35 UTC
Created attachment 160377 [details]
Hal-device output

Comment 2 Gian Paolo Mureddu 2007-07-31 22:47:13 UTC
Created attachment 160378 [details]
dmesg output

Comment 3 Gian Paolo Mureddu 2007-07-31 22:48:29 UTC
Created attachment 160380 [details]
strace output from running gnome-mount against the device reported by dmesg

Comment 4 Gian Paolo Mureddu 2007-07-31 22:51:29 UTC
Forgot to metion that this _only_ affects Fedora i386, as x86_64 doesn't exhibit
this problem.

Comment 5 David Zeuthen 2007-08-01 00:10:24 UTC
Most likely yet another dupe of bug 249282.

*** This bug has been marked as a duplicate of 249282 ***


Note You need to log in before you can comment on or make changes to this bug.