This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 250559 - system-config-cluster doesn't recognize extended parameters
system-config-cluster doesn't recognize extended parameters
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
low Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
:
: 250560 (view as bug list)
Depends On:
Blocks: 204097
  Show dependency treegraph
 
Reported: 2007-08-02 03:56 EDT by Sergey Bykov
Modified: 2010-01-22 14:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 14:00:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergey Bykov 2007-08-02 03:56:44 EDT
Description of problem:
I want to use quorum disk (Qdisk) with RHCS 4.5.
I use some specific parameters like "stop_cman" for <quorumd/> section and "tko"
for <heuristic/> section.
And when I start system-config-cluster it produce some error message:

Relax-NG validity error : Extra element quorumd in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element
cluster failed to validate content
/etc/cluster/cluster.conf fails to validate


Version-Release number of selected component (if applicable):
system-config-cluster-1.0.45-1.0
cman-1.0.17-0


How reproducible:
Always.

Steps to Reproduce:
1.Create new config with quorum disk.
2.Save this config and quit from system-config-cluster.
3.Edit /etc/cluster/cluster.conf and add some addition parameter (for example:
stop_cman) into <quorumd/> section.
4.Save config.
5.Start system-config-cluster.
  
Actual results:
Produce error message.

Expected results:


Additional info:
Comment 1 Sergey Bykov 2007-08-02 04:01:08 EDT
*** Bug 250560 has been marked as a duplicate of this bug. ***
Comment 2 Jim Parsons 2007-09-12 15:06:18 EDT
Fixed.
Comment 3 Lon Hohberger 2010-01-22 14:00:41 EST
Both are included in system-config-cluster-1.0.54-2.0; not sure why this bug was not closed.

Note You need to log in before you can comment on or make changes to this bug.