Bug 250560 - system-config-cluster doesn't recognize extended parameters
Summary: system-config-cluster doesn't recognize extended parameters
Status: CLOSED DUPLICATE of bug 250559
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-02 07:56 UTC by Sergey Bykov
Modified: 2009-04-16 20:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 08:00:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergey Bykov 2007-08-02 07:56:55 UTC
Description of problem:
I want to use quorum disk (Qdisk) with RHCS 4.5.
I use some specific parameters like "stop_cman" for <quorumd/> section and "tko"
for <heuristic/> section.
And when I start system-config-cluster it produce some error message:

Relax-NG validity error : Extra element quorumd in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element
cluster failed to validate content
/etc/cluster/cluster.conf fails to validate


Version-Release number of selected component (if applicable):
system-config-cluster-1.0.45-1.0
cman-1.0.17-0


How reproducible:
Always.

Steps to Reproduce:
1.Create new config with quorum disk.
2.Save this config and quit from system-config-cluster.
3.Edit /etc/cluster/cluster.conf and add some addition parameter (for example:
stop_cman) into <quorumd/> section.
4.Save config.
5.Start system-config-cluster.
  
Actual results:
Produce error message.

Expected results:


Additional info:

Comment 1 Sergey Bykov 2007-08-02 08:00:52 UTC

*** This bug has been marked as a duplicate of 250559 ***


Note You need to log in before you can comment on or make changes to this bug.