Bug 2506 - symlink problem
symlink problem
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-05-03 12:31 EDT by stef.pillaert
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-07-01 17:26:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description stef.pillaert 1999-05-03 12:31:53 EDT

I'm not sure if this is a bug, but I can't find a solution
in the FAQ's (I think).

** I try to install redhat 6.0 from hard disk. I mirrored
the distribution on a Linux-partition, mounted on "/home"
(so the "RedHat" directory (and all the other necessary
directories) are under "/home" (e.g. /home/RedHat,
/home/images, ...). The installer seems to be happy with it
at first, 'cause I can select the packages I want to
install. But after the formatting of the partitions (I don't
format the partition "sda5" mounted as "/home" of
course...), I get the message:
"Failed to create symlink for package source"

When I press <alt-F3>, I see:

* looking: sda1 ?= sda5
* looking: sda5 ?= sda5
* device sda5 is already mounted -- using symlink
* failed to create symlink /mnt//home: File exists

(is it normal to see the 2 "/"'s there?)

** O.K., I tried a FTP-install, I use the bootnet.img for
the startup disk, and now my SCSI adapter isn't recognized
(allthough the first startup-disk (from boot.img) did detect
it as a "BusLogic Adapter" without problems! Is there a
difference in detecting the SCSI between boot.img and

Help appreciated, it drives me nuts.

Comment 1 stef.pillaert 1999-05-03 13:59:59 EDT
OK, I saw that this problem is reported before (sorry, not familiar
to bugzilla). Should I just remove the whole line from /etc/fstab
concerning /sda5? I tried that, but no difference. What do I do in
diskdruid? I still have to tell him to mount sda5 as "/home", no? All
a bit confusing to me, sorry (I'm a bit new to Linux)
Comment 2 stef.pillaert 1999-05-04 09:43:59 EDT
...and even if I don't mount sda5 as /home in diskdruid (and the line
is removed from /etc/fstab), installation fails further on, saying
there are problems in the RPM-database (allthough I can acces it in
the shell (/tmp/rhimage leads to the correct location of the
Comment 3 jrm 1999-05-10 10:02:59 EDT
Regarding the installing from a ext2 partition that is in your fstab,
that appears to fail for me as well.  In my case however, removing the
entry from the fstab allows me to continue the install.

Here's details...
/dev/hda1 mounted on /home/ftp/pub/Redhat-6.0 contained the install
/dev/hda3 was root

Got a symlink type error when attempting to do the install.  Rebooted
into Redhat 5.2, removed the line from the fstab, retried Redhat 6.0
install and worked OK.
Comment 4 stef.pillaert 1999-05-10 10:21:59 EDT
Hm... I remember doing the same thing, but I couldn't go on
In the mean time, I managed to do a NFS-install, so it's a bit tricky
in trying it again to see what exactly was going on, sorry...

Thanks for the help though!
Comment 5 Jeff Johnson 1999-05-15 17:11:59 EDT
AFAICT this problem has been resolved. Please reopen if I'm wrong.
Comment 6 Jeff Johnson 1999-05-15 18:14:59 EDT
*** Bug 2846 has been marked as a duplicate of this bug. ***

I entered a new bug last week regarding how the installer
was broken in two different ways when doing a hard drive
install.  I also commented on someone else's problem with
their hard drive install, saying that it was similiar to the
problem I had.  My first bug report was closed, being called
a duplicate of the other report (2506).  That report was
subsequently closed, saying reopen if it is really broken.
Unfortunately, I don't appear to be able to reopen that bug
(or I can't find that option easily in bugzilla, possibly
because I didn't submit that one).  There is no boot.img
mentioned in the Errata, so both of the problems I
encountered still exist in the current set of disks.

Here are brief descriptions of the two problems:

1.  Can not upgrade the root partition if it is the
partition containing the install files, fails with an RPM
database not found message after mistakengly unmounting the

2.  Can not upgrade the root partition if another partition
contains the install files, if that partition is mentioned
in the /etc/fstab.  This causes some strange symlink problem
 having to do with /tmp/hdimage to appear.

I consider these bugs severe since most likely the root
partition someone is upgrading either contains the install
files, or the partition that contains them is going to be in
the /etc/fstab.  This means most hard drive based upgrades
will fail.

Feel free to email me for further info...
Comment 7 David Lawrence 1999-07-01 17:26:59 EDT
the errata boot images at


should hopefully solve this problem for you. Please reopen this bug
report if it does not.

Note You need to log in before you can comment on or make changes to this bug.