Bug 250794 - ppc64 debuginfo has stripped strace64.debug
ppc64 debuginfo has stripped strace64.debug
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: strace (Show other bugs)
4.0
ppc64 Linux
urgent Severity low
: ---
: ---
Assigned To: Jan Kratochvil
Brian Brock
: Regression
Depends On:
Blocks: 250797
  Show dependency treegraph
 
Reported: 2007-08-03 13:25 EDT by Jan Kratochvil
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0820
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:05:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2007-08-03 13:25:17 EDT
Description of problem:
During the RHEL4.5->RHEL4.6 build the verification (rpmdiff) failed as the
generated strace64.debug is empty.

Version-Release number of selected component (if applicable):
strace-4.5.16-1.el4.ppc64

How reproducible:
Not tried.

Steps to Reproduce:
1. Build strace-4.5.16-1.el4.ppc64 in Brew.

Actual results:
-rwxr-xr-x  1 jkratoch jkratoch 301600 Aug  3 18:43
strace-debuginfo-4.5.16-1.el4.ppc64/usr/lib/debug/usr/bin/strace.debug*
-rwxr-xr-x  1 jkratoch jkratoch   2640 Aug  3 18:43
strace-debuginfo-4.5.16-1.el4.ppc64/usr/lib/debug/usr/bin/strace64.debug*

(strace.debug correct, strace64.debug stripped)

Expected results:
-rwxr-xr-x  1 jkratoch jkratoch   2640 Aug  3 18:55
strace-debuginfo-4.5.15-1.el4.1.ppc64/usr/lib/debug/usr/bin/strace.debug*
-rwxr-xr-x  1 jkratoch jkratoch 294216 Aug  3 18:55
strace-debuginfo-4.5.15-1.el4.1.ppc64/usr/lib/debug/usr/bin/strace64.debug*

(strace.debug stripped, strace64.debug unstripped)

Well, it is also broken but it does not hurt.
The correct way is to produce both the two .debug files unstripped.
ppc64 platform uses strace.ppc and strace64.ppc64.
The package strace.ppc64 is never used.

Additional info:
The problem is line:
ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
/usr/lib/rpm/find-debuginfo.sh randomly chooses the first file and the second
one is already stripped so even its .debug file is empty/stripped.
Suggesting `ln' -> `cp -p'.
Comment 1 RHEL Product and Program Management 2007-08-03 13:34:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Andrew Cagney 2007-08-03 13:45:01 EDT
Regression on RHEL-4.5.
Problem is in debuginfo; so has no customer impact.
Workaround is trivial.
Tested automatically as part of errata process.

Recommend filling a separate bug against rpm, as I'm pretty sure this explains
why a few other programs also end up with empty debug info.
Comment 3 RHEL Product and Program Management 2007-08-03 13:45:24 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Jan Kratochvil 2007-08-03 13:49:15 EDT
Original debuginfo size:
-rwxr-xr-x  1 apache apache 263553 Aug  3 17:35
strace-debuginfo-4.5.16-1.el4.ppc64.rpm*
Proposed debuginfo size:
-rwxr-xr-x  1 apache apache 363149 Aug  3 19:29
strace-debuginfo-4.5.16-1.el4.1.ppc64.rpm*
Comment 8 Jan Kratochvil 2007-08-08 09:45:46 EDT
Problem fixed in Rawhide rpm-build by the new Roland's find-debuginfo.sh,
reported for RHEL in the Bug 251333.
Comment 11 errata-xmlrpc 2007-11-15 11:05:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0820.html

Note You need to log in before you can comment on or make changes to this bug.